[lib32]lib32-* manquant (résolu vite fait bien fait !)

Annonces, dépannage, évolution du projet yaourt
shom
Chu Ko Nu
Messages : 419
Inscription : jeu. 26 mai 2011, 22:44

[lib32]lib32-* manquant (résolu vite fait bien fait !)

Message par shom » lun. 20 juin 2011, 22:00

Salut a tous, j'aurais besoin de vous car j'aimerais installer teamviewer mais j'ai jamais réussi a compiler quoi que ce soit (quoi qu'avec yaourt ce soit vraiment simple).
J'ai lancé la commande

Code : Tout sélectionner

yaourt -S teamviewer
Il trouve les dépendances, les cherches et n'arrive pas a les resoudre..

Code : Tout sélectionner

==> Dépendances de teamviewer :
 - binutils (déjà installé)
 - lib32-libsm (compilation depuis AUR)
 - lib32-libxext (compilation depuis AUR)
 - lib32-glibc (compilation depuis AUR)
 - lib32-freetype2 (compilation depuis AUR)
 - lib32-gcc-libs (compilation depuis AUR)
 - lib32-alsa-lib (compilation depuis AUR)
 - lib32-libx11 (compilation depuis AUR)
 - lib32-libxtst (compilation depuis AUR)
 - lib32-libxdamage (compilation depuis AUR)
 - lib32-libxfixes (compilation depuis AUR)
 - lib32-libxcb (compilation depuis AUR)
 - lib32-libxi (compilation depuis AUR)
 - lib32-libxau (compilation depuis AUR)
 - lib32-libxdmcp (compilation depuis AUR)
Alors là, quand je change de nom lib32-freetype2 en lib32-freetype2-infinality dans le PKGBUILD c'est lib32-alsa-lib qu'il n'arrive pas a résoudre.. Et celui là, il n'y a pas de PKGBUILD sur Aur donc je suis vraiment paumé .. Un petit peu d'aide de votre part me dépannerait bien :)
Merci d'avance :)
Dernière édition par shom le lun. 20 juin 2011, 22:31, édité 1 fois.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10274
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [dépendance manquante]lib32-* manquant (en cours)

Message par FoolEcho » lun. 20 juin 2011, 22:16

Ajoute le dépôt [multilib] dans le pacman.conf , ça devrait aller mieux. http://wiki.archlinux.fr/Depots#D.C3.A9 ... ts_stables :chinois:

Code : Tout sélectionner

[multilib]
Include = /etc/pacman.d/mirrorlist
«The following statement is not true. The previous statement is true.» :nage:

shom
Chu Ko Nu
Messages : 419
Inscription : jeu. 26 mai 2011, 22:44

Re: [dépendance manquante]lib32-* manquant (en cours)

Message par shom » lun. 20 juin 2011, 22:28

Ah oui autant pour moi !
Mais maintentant j'ai

Code : Tout sélectionner

Erreur: l'ouverture du fichier /var/lib/pacman/sync/multilib.db a échoué: Failed to open '/var/lib/pacman/sync/multilib.db'
Erreur: l'ouverture du fichier /var/lib/pacman/sync/multilib.db a échoué: Failed to open '/var/lib/pacman/sync/multilib.db'
Erreur: l'ouverture du fichier /var/lib/pacman/sync/multilib.db a échoué: Failed to open '/var/lib/pacman/sync/multilib.db'
Erreur: impossible de trouver la cible: lib32-freetype2
EDIT : pacman -Syu :p Honte a moi ! Merci une fois de plus FoolEcho :D

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10274
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [dépendance manquante]lib32-* manquant (en cours)

Message par FoolEcho » lun. 20 juin 2011, 22:31

As-tu resynchronisé les dépôts ? (yaourt ou pacman -Sy )

(désolé, vu ton édition trop tard :-p )
«The following statement is not true. The previous statement is true.» :nage:

NY152
Daikyu
Messages : 63
Inscription : sam. 28 sept. 2013, 00:35

Re: [lib32]lib32-* manquant (résolu vite fait bien fait !)

Message par NY152 » dim. 22 oct. 2017, 17:13

<déterrage on>

Personnellement, j'ai cette erreur à l'installation de Teamviewer aussi !

Mais ce que l'on me dit est plus gênant ...

Code : Tout sélectionner

==> Dépendances de teamviewer :
 - lib32-fontconfig (déjà installé)
 - lib32-libsm (déjà installé)
 - lib32-libxinerama (déjà installé)
 - lib32-libxrender (déjà installé)
 - lib32-libxtst (déjà installé)
 - libxtst (déjà installé)
 - lib32-libpng12 (paquet trouvé)
 - lib32-libjpeg6-turbo (paquet trouvé)
 - lib32-freetype2<2.8.1 (compilation depuis AUR)


==> Éditer teamviewer.install ? [O/n] ("A" pour annuler)
==> ----------------------------------------------------
==> n

==> Lancer la compilation de teamviewer ? [O/n]
==> -------------------------------------------
==> o

==> Construction et installation du paquet
==> Installation/compilation des dépendances manquantes pour teamviewer:
erreur : impossible de trouver la cible : lib32-freetype2<2.8.1
==> Relancer la compilation de teamviewer ? [o/N]
==> ---------------------------------------------
Les dépôts sont à jour et le dépôt multilib est actif. Je sèche !

Si quelqu'un a une idée ...

</déterrage off>

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10274
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [lib32]lib32-* manquant (résolu vite fait bien fait !)

Message par FoolEcho » dim. 22 oct. 2017, 18:30

Comme suggéré dans les commentaires sur aur, tu as besoin d'une version anérieure de lib32-freetype2. Par exemple lib32-freetype2-infinality-ultimate (mais c'est un pis-aller puisque cette version devrait monter aussi à un moment ou un autre).

Merci de ne pas déterrer les vieux sujets mais d'en créer de nouveaux.
«The following statement is not true. The previous statement is true.» :nage:

NY152
Daikyu
Messages : 63
Inscription : sam. 28 sept. 2013, 00:35

Re: [lib32]lib32-* manquant (résolu vite fait bien fait !)

Message par NY152 » dim. 22 oct. 2017, 21:54

Je pensais, à juste titre, éviter un doublon en postant ici puisque le soucis était identique mais bon ...

Je vais contacter Teamviewer directement histoire de voir s'il ne peuvent pas mettre à jour les libs, on ne sait jamais !

En attendant, si d'autres personnes ont le même soucis, qu'il ne veulent pas pourrir leur système avec d'autres libs qui pourrait être défaillante avec le temps, ils peuvent utiliser une solution temporaire avec Teamviewer, installez la version ChromeOS ici : https://www.teamviewer.com/en/download/chrome-os/

Il s'agit d'une extension Chrome qui permet d'utiliser leur service via leur web-client.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10274
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [lib32]lib32-* manquant (résolu vite fait bien fait !)

Message par FoolEcho » lun. 23 oct. 2017, 19:14

NY152 a écrit :
dim. 22 oct. 2017, 21:54
Je pensais, à juste titre, éviter un doublon en postant ici puisque le soucis était identique mais bon ...
https://wiki.archlinux.fr/Forum#Ne_pas_ ... ieux_sujet
«The following statement is not true. The previous statement is true.» :nage:

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 3 invités