[Résolu] [Yaourt -Qdt] Avant de faire des bêtises

Annonces, dépannage, évolution du projet yaourt
carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

[Résolu] [Yaourt -Qdt] Avant de faire des bêtises

Message par carafife » lun. 02 avr. 2018, 22:01

Bonjour à tous,
Histoire de maintenir mon système propre j'ai fait ceci:

Code : Tout sélectionner

[carafife@Carafife ~]$ yaourt -Qdt
extra/cmake 3.10.3-1
community/dbus-c++ 0.9.0-8
extra/dkms 2.5-1
extra/gnome-icon-theme 3.12.0-4
extra/gnome-python 2.28.1-10
extra/gtk-vnc 0.7.2-1
community/jq 1.5-6
extra/kross 5.44.0-1 (kf5-aids)
community/lazarus-gtk2 1.8.2-1
extra/lcms 1.19-7
local/libcloudproviders 0.2.5+9+g93dc5ea-1
community/libcurl-compat 7.59.0-1
community/libcurl-gnutls 7.59.0-1
community/libgovirt 0.3.4+45+g46288e8-1
community/libnatpmp 20150609-1
community/libsecp256k1 20170927+825+g0b70241-1
extra/libupnp 1.6.25-1
community/libvirt-glib 1.0.0-1
extra/meson 0.45.1-1
extra/nghttp2 1.31.0-1
community/opendht 1:1.7.0rc4-1
community/patchelf 0.9-1
community/perl-authen-radius 0.26-2
community/perl-chart 2.4.10-2
community/perl-datetime 1.48-1
community/perl-email-mime-attachment-stripper 1.317-2
community/perl-email-reply 1.204-2
community/perl-email-send 2.201-2
community/perl-email-sender 1.300031-3
community/perl-file-slurp 9999.19-4
community/perl-gdgraph 1.54-2
community/perl-html-scrubber 0.15-3
community/perl-ldap 0.65-4
community/perl-math-random-isaac 1.004-4
community/perl-patchreader 0.9.6-3
community/perl-soap-lite 1.26-1
community/perl-template-gd 2.66-5
extra/perl-xml-twig 3.52-3
extra/postgresql 10.3-1
extra/python2-backports.functools_lru_cache 1.5-1
extra/qrencode 4.0.0-1
community/spice-gtk 0.34-1
extra/streamripper 1.64.6-3
extra/vala 0.40.2-1
community/yaml-cpp 0.6.2-1
==> Voulez-vous désinstaller ces paquets (avec options -Rcs) ?  [o/N]
==> -----------------------------------------------------------------
==> o
[sudo] Mot de passe de carafife : 
vérification des dépendances...
:: git peut nécessiter perl-mime-tools: git send-email
:: libreoffice-fresh peut nécessiter postgresql-libs: for postgresql-connector
:: qt4 peut nécessiter postgresql-libs: PostgreSQL driver
:: qt5-base peut nécessiter postgresql-libs: PostgreSQL driver

Paquets (139) augeas-1.10.1-1  ceph-libs-12.2.4-1  fpc-3.0.4-1  fpc-src-3.0.4-1
              gperftools-2.6.2-1  kparts-5.44.0-1  lazarus-1.8.2-1
              leveldb-1.20-1  libev-4.24-1  libvirt-4.2.0-1  netcf-0.2.8-4
              ninja-1.8.2-1  oniguruma-6.8.1-1  perl-appconfig-1.71-3
              perl-b-hooks-endofscope-0.21-3  perl-capture-tiny-0.46-3
              perl-class-data-inheritable-0.08-7  perl-class-inspector-1.32-2
              perl-class-load-0.24-2  perl-class-method-modifiers-2.12-3
              perl-class-singleton-1.5-2  perl-convert-asn1-0.27-3
              perl-convert-binhex-1.125-3  perl-data-hexdump-0.02-5
              perl-data-optlist-0.110-3  perl-datetime-locale-1.17-1
              perl-datetime-timezone-2.18-1
              perl-devel-globaldestruction-0.14-3  perl-devel-stacktrace-2.03-1
              perl-dist-checkconflicts-0.11-3  perl-email-abstract-3.008-2
              perl-email-address-1.909-1  perl-email-address-xs-1.01-1
              perl-email-date-format-1.005-3  perl-email-messageid-1.406-2
              perl-email-mime-1.946-2  perl-email-mime-contenttype-1.022-1
              perl-email-mime-encodings-1.315-2  perl-email-simple-2.214-1
              perl-eval-closure-0.14-3  perl-exception-class-1.44-1
              perl-exporter-tiny-1.000000-2  perl-fcgi-0.78-5
              perl-file-sharedir-1.102-3  perl-file-sharedir-install-0.11-3
              perl-gd-2.68-1  perl-gdtextutil-0.86-5
              perl-import-into-1.002005-3  perl-inc-latest-0.500-3
              perl-io-stringy-2.111-3  perl-list-allutils-0.14-3
              perl-list-moreutils-0.428-1  perl-list-moreutils-xs-0.428-1
              perl-list-someutils-0.56-1  perl-list-utilsby-0.11-1
              perl-math-round-0.07-2  perl-mime-lite-3.030-3
              perl-mime-tools-5.509-5  perl-mime-types-2.17-1
              perl-module-build-0.4224-5  perl-module-implementation-0.09-3
              perl-module-pluggable-5.2-3  perl-module-runtime-0.014-4
              perl-moo-2.003000-4  perl-moox-types-mooselike-0.29-3
              perl-mro-compat-0.13-2  perl-namespace-autoclean-0.28-3
              perl-namespace-clean-0.27-3  perl-package-stash-0.37-4
              perl-package-stash-xs-0.28-7  perl-params-util-1.07-8
              perl-params-validate-1.29-1
              perl-params-validationcompiler-0.27-1
              perl-return-value-1.666005-2  perl-role-tiny-2.000005-3
              perl-specio-0.42-1  perl-sub-exporter-0.987-3
              perl-sub-exporter-progressive-0.001013-3
              perl-sub-identify-0.14-4  perl-sub-install-0.928-3
              perl-sub-quote-2.003001-3  perl-template-toolkit-2.27-4
              perl-test-fatal-0.014-3  perl-text-iconv-1.7-14
              perl-text-soundex-3.05-4  perl-throwable-0.200013-3
              perl-variable-magic-0.62-1  perl-xml-filter-buffertext-1.01-7
              perl-xml-sax-writer-0.57-1  phodav-2.2-2  postgresql-libs-10.3-1
              python2-backports-1.0-1  restbed-4.6+28+gc3a259b-1  rhash-1.3.6-1
              cmake-3.10.3-1  dbus-c++-0.9.0-8  dkms-2.5-1
              gnome-icon-theme-3.12.0-4  gnome-python-2.28.1-10
              gtk-vnc-0.7.2-1  jq-1.5-6  kross-5.44.0-1  lazarus-gtk2-1.8.2-1
              lcms-1.19-7  libcloudproviders-0.2.5+9+g93dc5ea-1
              libcurl-compat-7.59.0-1  libcurl-gnutls-7.59.0-1
              libgovirt-0.3.4+45+g46288e8-1  libnatpmp-20150609-1
              libsecp256k1-20170927+825+g0b70241-1  libupnp-1.6.25-1
              libvirt-glib-1.0.0-1  meson-0.45.1-1  nghttp2-1.31.0-1
              opendht-1:1.7.0rc4-1  patchelf-0.9-1  perl-authen-radius-0.26-2
              perl-chart-2.4.10-2  perl-datetime-1.48-1
              perl-email-mime-attachment-stripper-1.317-2
              perl-email-reply-1.204-2  perl-email-send-2.201-2
              perl-email-sender-1.300031-3  perl-file-slurp-9999.19-4
              perl-gdgraph-1.54-2  perl-html-scrubber-0.15-3  perl-ldap-0.65-4
              perl-math-random-isaac-1.004-4  perl-patchreader-0.9.6-3
              perl-soap-lite-1.26-1  perl-template-gd-2.66-5
              perl-xml-twig-3.52-3  postgresql-10.3-1
              python2-backports.functools_lru_cache-1.5-1  qrencode-4.0.0-1
              spice-gtk-0.34-1  streamripper-1.64.6-3  vala-0.40.2-1
              yaml-cpp-0.6.2-1

Taille totale supprimée :  1395,00 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] n
Le problème est que la commande m'informe que certaines dépendances présentes dans la liste sont peut-être importantes pour d'autres applications. Y a t-il une option pour eviter d'effacer les bonnes ou si je réponds oui, elles seront épargnées?
Merci d'avance pour le coup de main
Dernière édition par carafife le ven. 06 avr. 2018, 18:07, édité 1 fois.
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15041
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Yaourt -Qdt] Avant de faire des bêtises

Message par benjarobin » lun. 02 avr. 2018, 23:39

Bonjour,
Ce sont des dépendances optionnelles, et je suis persuadé que tu n'as pas besoin de perl-mime-tools (A moins d'être un développeur du kernel Linux, mais dans ce cas tu ne poserais pas la question ici :-) ), ni besoin de postgresql-libs (A moins que tu possèdes des applications nécessitant une base de donnée PostgreSQL).

Le plus simple est de tout supprimer, et de voir à l'usage si des choses manquent. Dans le cas improbable d'un paquet manquant tu t'en rendras compte assez rapidement.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

carafife
Hankyu
Messages : 30
Inscription : lun. 05 févr. 2018, 21:59

Re: [Yaourt -Qdt] Avant de faire des bêtises

Message par carafife » ven. 06 avr. 2018, 18:05

Merci En effet, pas de talent de dev....
Je lance ça sans soucis ;-)
Antergos - Kernel: 4.15.1-2-ARCH x86_64 - Gnome 3.28 - Thinkpad X230 8Gb - Intel Core i5-3320M - Graphic HD 4000 - Audio: Series/C216 Family High Def. Audio Controller - ssd 240Gb

Répondre