[yaourt] Nouvelles versions de Yaourt !

Annonces, dépannage, évolution du projet yaourt
Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

[yaourt] Nouvelles versions de Yaourt !

Message par Skunnyk » mer. 18 juin 2014, 10:31

Yaourt 1.4 est de sortie !

Plus d'un an après la sortie de la version 1.3, yaourt est de retour o/

Au programme, entre autres (en anglais):

- Warn about root before any task
- Improve support for splitted packages when DEVELSRCDIR is set.
- Fix querying installed package with version constraint
- New $DEVELSRCDIR option ($DEVELBUILDDIR is deprecated)
- Modified abs_get_pkgbuild() to be able to download from the Arch official svntogit repos.
- Add USE_GIT to yaourtrc
- Bugfixes
- Manpages Update
- Translations update

De même, mise à jour de package-query (1.3) avec de multiples corrections de bugs et features.

Merci à Tuxce !

Tucnacek
Chu Ko Nu
Messages : 327
Inscription : sam. 28 sept. 2013, 22:40

Re: [yaourt] Nouvelle version 1.4 !

Message par Tucnacek » mer. 18 juin 2014, 14:00

Skunnyk a écrit :Merci à Tuxce !
+1 !

Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1239
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [yaourt] Nouvelle version 1.4 !

Message par floflo77890 » mer. 18 juin 2014, 14:03

Oui merci à Tuxce.

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [yaourt] Nouvelle version 1.4 !

Message par Skunnyk » lun. 23 juin 2014, 22:08

Et la version 1.5 dans la foulée :)
Petite correction sur les paquets splittés de AUR : https://github.com/archlinuxfr/yaourt/issues/38

Pour infos, il y a eu + de 13000 download de yaourt 1.4, en moins d'une semaine, pas mal!

Avatar de l’utilisateur
floflo77890
Maître du Kyudo
Messages : 1239
Inscription : lun. 29 juil. 2013, 21:05
Localisation : île de france

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par floflo77890 » lun. 23 juin 2014, 22:34

moi perso je préfère utiliser yaourt que pacman, même si yaourt ne fait qu'utiliser pacman.

Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par Moviuro » lun. 23 juin 2014, 23:53

floflo77890 a écrit :moi perso je préfère utiliser yaourt que pacman, même si yaourt ne fait qu'utiliser pacman.
Perso, j'utilise yaourt + powerpill (ici) car c'est une tuerie sur les connexions pourries (et aussi, j'utilise aria pour télécharger les sources des paquets AUR :D ).
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !

benjarobin
Maître du Kyudo
Messages : 15367
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par benjarobin » lun. 23 juin 2014, 23:55

Car tu es arrivé à utiliser powerpill, la dernière fois que j'ai essayé il m'a limite cassé la base de donnée car il ne gère pas correctement les paquets signés ? Désolé du HS :-)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par Moviuro » mar. 24 juin 2014, 00:57

benjarobin a écrit :Car tu es arrivé à utiliser powerpill, la dernière fois que j'ai essayé il m'a limite cassé la base de donnée car il ne gère pas correctement les paquets signés ? Désolé du HS :-)
J'ai pas eu de soucis depuis que je l'utilise (9 janvier de l'an de grâce 2014) Fin du HS, je vais essayer de trouver un article wiki ou forum où poster toutes les astuces pour booster pacman.
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !

Tucnacek
Chu Ko Nu
Messages : 327
Inscription : sam. 28 sept. 2013, 22:40

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par Tucnacek » mar. 24 juin 2014, 04:53

À choisir, vise peut-être plutôt le wiki. Les recherches m'y semblent toujours plus aisées que sur le forum qui regroupe plutôt les cas particuliers.

Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par Moviuro » mar. 24 juin 2014, 12:29

Tucnacek a écrit :À choisir, vise peut-être plutôt le wiki. Les recherches m'y semblent toujours plus aisées que sur le forum qui regroupe plutôt les cas particuliers.
Tada ! https://wiki.archlinux.fr/Astuces_Pacman
J'attends vos contributions complémentaires pertinentes !
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10499
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par FoolEcho » mar. 24 juin 2014, 19:40

Moviuro a écrit :
Tucnacek a écrit :À choisir, vise peut-être plutôt le wiki. Les recherches m'y semblent toujours plus aisées que sur le forum qui regroupe plutôt les cas particuliers.
Tada ! https://wiki.archlinux.fr/Astuces_Pacman
J'attends vos contributions complémentaires pertinentes !
A priori, je verrais plutôt à tout caser sur la page pré-existante Ameliorer_Pacman et supprimer la tienne... :chinois: :pastaper: :merci:
«The following statement is not true. The previous statement is true.» :nage:

Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [yaourt] Nouvelle version 1.4/1.5 !

Message par Moviuro » mar. 24 juin 2014, 20:27

FoolEcho a écrit :A priori, je verrais plutôt à tout caser sur la page pré-existante Ameliorer_Pacman et supprimer la tienne... :chinois: :pastaper: :merci:
Pas de soucis, d'ailleurs je viens de finir les modifs :) (pacsrv, entre autres)
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Skunnyk » lun. 08 juin 2015, 22:11

Yaourt 1.6 et package-query 1.6.1 sont de sortie !

Pas mal d'évolutions et de corrections de bugs :)
Ce qui pourrait vous interesser,la possibilité d'utiliser aur4 via un nouveau switch :

Code : Tout sélectionner

$ yaourt -Ss --aur-url https://aur4.archlinux.org mypackage
https://aur.archlinux.org reste par défaut.

Aussi, le support des dépendances specifiques aux archis (depends_x86_64 etc), ou encore la possibilité d'overrider l'appel à makepkg via la variable MAKEPKG. A noter que --sucre a été supprimé.

Le changelog complet :

* Support of aur and aur4 with the --aur-url switch (need package-query 1.6+)
* Add support for architecture specific dependencies (depends_x86_64 etc)
* Remove --sucre option
* Drop --asroot option from makepkg
* 'yaourt -G' offers an alternative if a directory with package name exists.
* Possibility to use MAKEPKG as an environment variable
* Handle 'checkdepends'
* Show the date of the latest update instead of the first submission.
* -U checks for aur dependencies
* Read configuration in $XDG_CONFIG_HOME (yaourt & makepkg)
* Improve parsing of multiline array in sanitize_pkgbuild()
* Sort packages in sysupgrade prompt
* Prefer $VISUAL over $EDITOR,
* man pages updates (-A, -m-args etc)
* Translations Update / New languages
* Code cleanup


Merci à tous les contributeurs et traducteurs :)

Avatar de l’utilisateur
Maximilien LIX
yeomen
Messages : 211
Inscription : mer. 23 avr. 2014, 14:27
Contact :

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Maximilien LIX » lun. 05 oct. 2015, 19:34

Génial, j'ai hâte de l'utiliser. :D
Linuxien et blogueur en carton
Acer AX3810 (Archlinux & Debian)
Acer Aspire V5 (ubuntu-Mate)
Lenovo Thinkpad Edge E330 (Archlinux)

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Skunnyk » lun. 05 oct. 2015, 21:31

Et hop, yaourt et package-query 1.7 sont disponibles :)

Au menu, des bugfixes, et la possibilité de télécharger les PKGBUILD AUR via git ! (avec AURUSEGIT=1)

Les changelogs !

Yaourt ( https://github.com/archlinuxfr/yaourt ) :

Code : Tout sélectionner

* Support cloning the git repo when specifying -G for AUR packages. Set AURUSEGIT=1 to use it . Need package-query > 1.6 #142
* Fix "Canceled upgrade try to run package-query without argument" #122
* Make yaourt display which deps are makedepends #137
* Remove "-e" from "read -ea packagesnum" #141
* Synchronize translations from transifex (https://www.transifex.com/archlinuxfr/yaourt/)
* Yaourt now exit with code 1 on PKGBUILD download failure #149
* Fix aur_comments, broken since AUR 4.1.
Package-query ( https://github.com/archlinuxfr/package-query ) :

Code : Tout sélectionner

* Support querying git clone url. git url are available via -f "%G" #15
* Fix Invalid versions are shown with upgrade queries. -Qu works again :) #10
* Fix a memory leak #12
* Avoid passing a NULL to strcasestr. #14 . Fix package-query to segfault on some search
* Remove AUR3 api compatibility
* Fix -f "%O" (optionals deps)
 
Le tout disponible sur AUR, les paquets arrivent dans la foulée :)

viperpaulo
Chu Ko Nu
Messages : 371
Inscription : lun. 06 déc. 2010, 13:58

Re: [yaourt] Nouvelles versions de Yaourt !

Message par viperpaulo » mer. 07 oct. 2015, 13:48

Merci pour cette news !
J'ai constaté un comportement bizarre, lorsque l'on utilise l'option --devel lors d'une mise à jour, les makedepends ne s'installent pas et ça produit une erreur.

benjarobin
Maître du Kyudo
Messages : 15367
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [yaourt] Nouvelles versions de Yaourt !

Message par benjarobin » mer. 07 oct. 2015, 13:57

Merci de remonter un problème, mais ici ce n'est pas trop l'endroit.
Dans un autre sujet, voir encore plus sympa, ce serait de le faire sur Github avec un maximum de détail. Commande lancée, sortie complète de la commande, paquet impacté...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Samirdu91
Hankyu
Messages : 29
Inscription : dim. 11 oct. 2015, 09:24

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Samirdu91 » dim. 18 oct. 2015, 10:42

Comment on peut vous aider à traduire yaourt : D

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Xorg » dim. 18 oct. 2015, 11:02

Samirdu91 a écrit :Comment on peut vous aider à traduire yaourt : D
Tu n'as pas beaucoup cherché... https://github.com/archlinuxfr/yaourt#translations
Yaourt est déjà traduit à 100% en français (cf https://www.transifex.com/archlinuxfr/y ... nguage/fr/).
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [yaourt] Nouvelles versions de Yaourt !

Message par Skunnyk » jeu. 03 mars 2016, 00:02

Et hop, Yaourt & pacakge-query 1.8 !

Le changelog de yaourt : https://github.com/archlinuxfr/yaourt/releases/tag/1.8
Et de package-query : https://github.com/archlinuxfr/package- ... es/tag/1.8

Note: vous devez updater manuellement package-query depuis AUR (https://aur.archlinux.org/packages/package-query/) étant donné que la dernière version de AUR casse la compatibilité avec package-query 1.7, reglé en 1.8 …


Enjoy :)

Répondre