[yaourt] Impossible de lire le PKGBUILD (resolu)

Annonces, dépannage, évolution du projet yaourt
Avatar de l’utilisateur
albireo
Chu Ko Nu
Messages : 398
Inscription : ven. 15 sept. 2006, 15:47
Localisation : vallée de la save en Occitanie

Re: [yaourt] Impossible de lire le PKGBUILD (en cours)

Message par albireo » jeu. 08 janv. 2015, 20:35

je m'excuse, je suis pas très reactif car je suis pas souvent devant l'ordi en ce moment mais c'est fait :
http://pastebin.archlinux.fr/765139
Utilisateur ArchLinux depuis 2004
Arch 64/gnome sur ASUS H87M-E C2 + i5 3.2GHz + 8Go + 1To + écran 22"
Arch 64/LXDE sur LDLC MERCURE ML3-4-S1 -> DAC Micromega -> ampli Onkyo -> enceintes Focal :D

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [yaourt] Impossible de lire le PKGBUILD (en cours)

Message par benjarobin » jeu. 08 janv. 2015, 20:49

Je reproduis le problème si je met PACMAN="pacman --color always" dans yaourtrc
Même si on met juste PACMAN="pacman --color" ou PACMAN="pacman -v" on peut reproduire le problème
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
albireo
Chu Ko Nu
Messages : 398
Inscription : ven. 15 sept. 2006, 15:47
Localisation : vallée de la save en Occitanie

Re: [yaourt] Impossible de lire le PKGBUILD (en cours)

Message par albireo » jeu. 08 janv. 2015, 20:55

effectivemet l'erreur vient de là. j'ai supprimé PACMAN="pacman --color always" dans yourtrc et j'ai supprimé un alias que j'avais dans .bashrc et ça fonctionne normalement.
problème résolu mais qui peut aider à améliorer yaourt :D
Utilisateur ArchLinux depuis 2004
Arch 64/gnome sur ASUS H87M-E C2 + i5 3.2GHz + 8Go + 1To + écran 22"
Arch 64/LXDE sur LDLC MERCURE ML3-4-S1 -> DAC Micromega -> ampli Onkyo -> enceintes Focal :D

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [yaourt] Impossible de lire le PKGBUILD (en cours)

Message par tuxce » jeu. 08 janv. 2015, 21:03

albireo a écrit : problème résolu mais qui peut aider à améliorer yaourt :D
Je suis pas sûr que ça puisse être contourné ça :)
PACMAN est censé contenir le nom d'un exécutable, non une commande, sinon, par défaut, yaourt appelle pacman --color auto et on peut forcer la couleur en spécifiant USECOLOR=2 dans la config.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15019
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [yaourt] Impossible de lire le PKGBUILD (resolu)

Message par benjarobin » jeu. 08 janv. 2015, 21:09

Test minimal pour reproduire le souci

Code : Tout sélectionner

#!/bin/bash

trap_exit() {
    echo "Fail"
    exit 2
}
trap 'trap_exit USR1 "Erreur..."' ERR

PACMAN="pacman -v"
PACMAN_PATH=$(type -P $PACMAN)
echo "pass"
echo "$PACMAN_PATH"
exit 0
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1924
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [yaourt] Impossible de lire le PKGBUILD (en cours)

Message par Xorg » jeu. 08 janv. 2015, 21:28

Xorg a écrit :[...] il faut voir s'il n'y a pas de problème avec ton fichier de configuration /etc/yaourtrc [...]
Comme quoi on n'était pas loin de la solution dès la première réponse... :lol:

Et en plus à la deuxième réponse :
albireo a écrit :[...]
mon yaourtrc j'ai uniquement changé ça et ça fait un bail et n'a jamais causé de problème
#
Command
PACMAN="pacman --color always"
DIFFEDITCMD="meld"
[...]
C'était sous nos yeux depuis le début.

Mais on peut tout de même remercier Benjarobin et Tuxce pour tout le dévouement qu'ils ont mis à chercher le problème. :wink:
Arch Linux x86_64 - Linux-ck-sandybridge - Gnome 3 (Wayland)
Intel® Core™ i5 2500K - Sapphire Radeon HD 6870 - 8Go de DDR3 - SSD 120Go + 2 HDD 500Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
albireo
Chu Ko Nu
Messages : 398
Inscription : ven. 15 sept. 2006, 15:47
Localisation : vallée de la save en Occitanie

Re: [yaourt] Impossible de lire le PKGBUILD (resolu)

Message par albireo » ven. 09 janv. 2015, 07:22

le problème c'est qu'en fait on ne peut pas utiliser d'alias concernant pacman dans .bashrc sous peine de voir yaourt commettre des erreurs de ce genre. Et ça c'est pas facile à reperer vu le temps mis pour trouver la solution. Sinon merci à tous le monde yaourt fonctionne normalement. :D
Utilisateur ArchLinux depuis 2004
Arch 64/gnome sur ASUS H87M-E C2 + i5 3.2GHz + 8Go + 1To + écran 22"
Arch 64/LXDE sur LDLC MERCURE ML3-4-S1 -> DAC Micromega -> ampli Onkyo -> enceintes Focal :D

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [yaourt] Impossible de lire le PKGBUILD (resolu)

Message par tuxce » ven. 09 janv. 2015, 10:43

Si, un alias, tu peux l'utiliser, c'est la variable PACMAN qui ne peux pas contenir une commande avec des options parce que makepkg la vérifie et échoue si ce n'est pas le nom d'un exécutable.

Répondre