[yaourt] Impossible de l'installer (arm) [résolu]

Annonces, dépannage, évolution du projet yaourt
ElMoribond
Hankyu
Messages : 32
Inscription : mer. 25 mars 2015, 10:33

[yaourt] Impossible de l'installer (arm) [résolu]

Message par ElMoribond » lun. 10 août 2015, 17:45

Bonjour,

Je n'arrive pas à installer yaourt sur mon armv7.
Il y a une dépendance manquante, package-query>=1.4

J'ai essayé la méthode indiqué sur https://archlinux.fr/yaourt mais le lien du package-query.tar.gz n'est plus valide.

Qlqlun a-t-il une piste/solution?

Merci
Dernière édition par ElMoribond le lun. 10 août 2015, 19:13, édité 1 fois.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1828
Inscription : jeu. 15 mars 2012, 05:08

Re: [yaourt] Impossible de l'installer (arm)

Message par waitnsea » lun. 10 août 2015, 18:32

J'ai fait une installation il y a 10 j avec :

Code : Tout sélectionner

ou en utilisant notre dépôt, ajoutez:
[archlinuxfr]
SigLevel = Never
Server = http://repo.archlinux.fr/$arch

à /etc/pacman.conf, puis lancez:

pacman -Sy yaourt
sans aucun problème
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

ElMoribond
Hankyu
Messages : 32
Inscription : mer. 25 mars 2015, 10:33

Re: [yaourt] Impossible de l'installer (arm)

Message par ElMoribond » lun. 10 août 2015, 19:01

Surprenant.
Voici ce que çà donne à l'instant:
# pacman -Sy yaourt
:: Synchronisation des bases de données de paquets...
core est à jour
extra est à jour
community 2,8 MiB 213K/s 00:13 [----------------------------------------] 100%
alarm est à jour
aur est à jour
odroidu est à jour
archlinuxfr est à jour
résolution des dépendances...
avertissement : impossible de résoudre « package-query>=1.4 », une dépendance de « yaourt »
:: Le paquet suivant ne peut être mis à jour à cause de dépendances insolubles :
yaourt

:: Voulez-vous ignorer le paquet ci-dessus pour cette mise à jour ? [o/N]
De plus package-query est introuvable sur http://repo.archlinux.fr/arm/ et http://fr.mirror.archlinuxarm.org/arm/.

Avatar de l’utilisateur
papajoke
Chu Ko Nu
Messages : 494
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [yaourt] Impossible de l'installer (arm)

Message par papajoke » lun. 10 août 2015, 19:02

Bonjour,
la page aur de package-query compatible arm avec lien vers la source
Dernière édition par papajoke le lun. 10 août 2015, 19:18, édité 1 fois.
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

ElMoribond
Hankyu
Messages : 32
Inscription : mer. 25 mars 2015, 10:33

Re: [yaourt] Impossible de l'installer (arm)

Message par ElMoribond » lun. 10 août 2015, 19:12

Nickel, merci papajoke.
Donc après avoir récupéré le PKGBUILD:
$ makepkg -Acs
# pacman -U package-query-1.6.2-1-armv7h.pkg.tar.xz
# pacman -S yaourt
:)

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1112
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [yaourt] Impossible de l'installer (arm) [résolu]

Message par Skunnyk » dim. 23 août 2015, 21:29

J'ai mis à jour la doc de yaourt (sur https://archlinux.fr/yaourt-en / https://archlinux.fr/yaourt ) avec les URLs de AUR4 et une note pour ARM.

Répondre