Page 1 sur 1

[yaourt] version et paquet développement (résolu)

Publié : ven. 03 mars 2017, 10:37
par viperpaulo
Bonjour,

j'ai installé le paquet yakyak-git, celui-ci est en version 1-4 sur AUR, quand on le compile pkgver() fait le job et trouve un numéro de version qui ressemble soit à ça v1.2.0.r657.gf2cfa6c-1 quand on utilise la fonction telle qu'elle est dans le PKGBUILD, soit r1187.f2cfa6c-1 lorsqu'on utilise la version "short". Mais voilà, déjà le pkgrel=5 est écrasé, mais surtout le paquet est systématiquement détecté comme pas à jour et on me le propose à la compile à chaque fois, ce qui est un peu agaçant.

J'aimerai savoir si c'est un comportement normal de yaourt ou s'il s'agit d'un bug. Si c'est un comportement normal, alors le PKGBUILD est mal rédigé, mais que faudrait-il proposer comme modifs ? J'ai l'impression que les autres paquets AUR ne sont pas uploadés en version 1-4 mais avec une version issue de pkgver() directement, est-ce le souci ? Quid du pkgrel ?

Merci :)

Re: [yaourt] version et paquet développement

Publié : ven. 03 mars 2017, 10:52
par benjarobin
viperpaulo a écrit :
ven. 03 mars 2017, 10:37
Bonjour, les autres paquets AUR ne sont pas uploadés en version 1-4 mais avec une version issue de pkgver() directement, est-ce le souci ?
Oui, et yaourt ici ne peut rien faire...
viperpaulo a écrit :
ven. 03 mars 2017, 10:37
Quid du pkgrel ?
Dans la plupart des cas il doit être égale à 1, mais ce n'est clairement pas lui le problème.

Re: [yaourt] version et paquet développement

Publié : ven. 03 mars 2017, 11:21
par viperpaulo
Ok c'est ce qu'il me semblait !
Merci de ta confirmation ;)

Re: [yaourt] version et paquet développement (résolu)

Publié : sam. 04 mars 2017, 18:18
par Xorg
viperpaulo a écrit :
ven. 03 mars 2017, 10:37
[...] le paquet est systématiquement détecté comme pas à jour et on me le propose à la compile à chaque fois, ce qui est un peu agaçant.
J'ai le même soucis avec radeon-profile-git, qui m'agace tout autant.

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : radeon-profile 20161221.r13.g4385106-1
==> Lancement de build()...
[..]
avertissement : radeon-profile-git-20161221.r13.g4385106-1 est à jour -- réinstalle
Par contre, avec d'autres paquets, pas de soucis :

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : cpu-x-git 3.1.3.r26.g5ff695a-1
==> Les sources sont prêtes.
==> cpu-x-git est déjà à jour.

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : libcpuid-git 2:0.4.0.r11.g1e597b9-1
==> Les sources sont prêtes.
==> libcpuid-git est déjà à jour.

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : rhythmbox-plugin-alternative-toolbar-git 0.r300.9f43233-1
==> Les sources sont prêtes.
Au début, je pensais que pour radeon-profile-git, le problème venait du pkgbase=radeon-profile (qui n'a rien a faire là normalement). Maintenant, avec ton cas, ça me met des doutes.
J'ai du mal à dire si ça vient d'une erreur au niveau du PKGBUILD ou bien un bug dans Yaourt. Je vais investiguer et voir si la fonction de comparaison de Yaourt ne serait pas le fautive, l'histoire de trancher.

Re: [yaourt] version et paquet développement (résolu)

Publié : sam. 04 mars 2017, 22:08
par Xorg
Bon, je ne me suis pas trop embêté, j'ai fait un bash -x $(which yaourt) -Syu --devel, et par exemple j'ai cela quand la vérification fonctionne correctement :

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : rhythmbox-plugin-alternative-toolbar-git 0.r300.9f43233-1
==> Les sources sont prêtes.
[...]
++ echo 0.r300.9f43233-1
++ pkgversion rhythmbox-plugin-alternative-toolbar-git
++ pkgquery -Qif %v rhythmbox-plugin-alternative-toolbar-git
++ package-query --aur-url https://aur.archlinux.org --color -Qif %v rhythmbox-plugin-alternative-toolbar-git
+ is_x_gt_y 0.r300.9f43233-1 0.r300.9f43233-1
++ vercmp 0.r300.9f43233-1 0.r300.9f43233-1
+ [[ 0 -gt 0 ]]
++ _gettext '%s is already up to date.' rhythmbox-plugin-alternative-toolbar-git.
Et pour radeon-profile-git :

Code : Tout sélectionner

==> Lancement de pkgver()...
==> Version mise à jour : radeon-profile 20161221.r13.g4385106-1
==> Lancement de build()...
Ça ne fait pas le vercmp avant d'exécuter build(), ça semble lié à la présence de la variable pkgbase dans mon cas.
Mais bon, je ne suis plus quoi faire, le responsable du paquet ne répond plus à mes messages sur AUR, et il se trouve que le mainteneur du paquet est le développeur du logiciel, donc je crois que je ne peux pas y faire grand chose...

Dans le cas de yakyak-git, le seul petit soucis que je vois, c'est que le .SRCINFO ne correspond pas à ce PKGBUILD (pkgrel diffère).

Re: [yaourt] version et paquet développement (résolu)

Publié : ven. 10 mars 2017, 15:43
par Fanch
Salut,
Je suis pas sur que ca repond vraiment à ton souci, mais tu peux utiliser la variable epoch :
https://wiki.archlinux.org/index.php/PKGBUILD#epoch
A rajouter dans le PKGBUILD avant de compiler