[Mise à jour impossible] téléchargement des clés requises bloqué (résolu)

Annonces, dépannage, évolution du projet yaourt
othiery
newbie
Messages : 2
Inscription : jeu. 28 sept. 2017, 22:53

[Mise à jour impossible] téléchargement des clés requises bloqué (résolu)

Message par othiery » jeu. 28 sept. 2017, 23:01

Bonjour,

La mise à jour de archlinux sur mon poste reste bloquée sur le message "téléchargement des clés requises..." pendant un temps indéfini.

Voila la commande que j'utilise : sudo yaourt -Syu

Devant ce message, j'ai tenté sudo pacman-key --refresh-keys (sans succès).

Puis j'ai essayé d'enchaîner

Code : Tout sélectionner

sudo rm -rf /etc/pacman.d/gnupg/
sudo pacman-keys --init
Même après cela, ça reste bloqué.

Avez-vous une idée de ce que je pourrais faire ?

Merci
Dernière édition par othiery le dim. 01 oct. 2017, 19:02, édité 1 fois.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [Mise à jour impossible] téléchargement des clés requises bloqué (non résolu)

Message par waitnsea » ven. 29 sept. 2017, 05:30

othiery a écrit :
jeu. 28 sept. 2017, 23:01
Voila la commande que j'utilise : sudo yaourt -Syu
Bonjour,
Yaourt (de même pacaur et autres) ne doit jamais s'utiliser en root, donc avec sudo !
Ceci est réservé à pacman qui ne chargera que les paquets officiels sans avoir à compiler.
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

jean_no
yeomen
Messages : 277
Inscription : dim. 09 sept. 2007, 12:19

Re: [Mise à jour impossible] téléchargement des clés requises bloqué (non résolu)

Message par jean_no » ven. 29 sept. 2017, 17:44

Salut

Peux-tu essayer:

Code : Tout sélectionner

sudo pacman -S archlinux-keyring
et après:

Code : Tout sélectionner

sudo pacman -Syu
A+

othiery
newbie
Messages : 2
Inscription : jeu. 28 sept. 2017, 22:53

Re: [Mise à jour impossible] téléchargement des clés requises bloqué (résolu)

Message par othiery » dim. 01 oct. 2017, 18:56

Bonjour,

Merci pour votre aide.
Je n'utiliserai plus yaourt en root ;-)

Au final, j'ai pu résoudre le problème en suivant les instructions de la page https://classicforum.manjaro.org/index. ... ic=33308.0

Comme proposé, j'ai tenté la commande

Code : Tout sélectionner

sudo pacman -S archlinux-keyring
Après avoir attendu (très) longtemps, j'ai fini par avoir un message du type
error: key "####################" could not be looked up remotely
, ce qui m'a mené à la page indiqué.
La seule chose qui a marché a consisté à modifier pacman.conf avec le paramètre
SigLevel = Never
.
J'ai ensuite exécuté :

Code : Tout sélectionner

sudo pacman -Syu
Puis j'ai réactivé le paramétrage d'origine de pacman.conf.
Je ne comprends pas très bien pourquoi, mais les mises à jours faites ultérieurement ont fonctionné sans les blocages que j'avais auparavant.

Merci encore !

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1945
Inscription : jeu. 15 mars 2012, 05:08

Re: [Mise à jour impossible] téléchargement des clés requises bloqué (résolu)

Message par waitnsea » dim. 01 oct. 2017, 20:01

othiery a écrit :
dim. 01 oct. 2017, 18:56
Je n'utiliserai plus yaourt en root
Au final, j'ai pu résoudre le problème en suivant les instructions de la page https://classicforum.manjaro.org/index. ... ic=33308.0
Si tu es sous Manjaro, les clé,, miroirs, clés gpg, etc... ne sont pas ceux d'Archlinux !!!
Fais attention à ne pas casser ton système !
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Répondre