[yaourt] xine-ui

Annonces, dépannage, évolution du projet yaourt
saintshakajin
Daikyu
Messages : 53
Inscription : ven. 11 août 2006, 22:05

[yaourt] xine-ui

Message par saintshakajin »

Hello les gens,

Voilà, j'ai une installation toute fraiche de Arch et je me dis, utilisons à mort yaourt.
De ce fait, je fais un yaourt -Sb xine-ui et là commence mes problèmes... il n'installe pas toutes les dépendances pour la compilation et donc me génère une erreur:

Code : Tout sélectionner

==> Finished making: xmms  (Wed Mar 21 10:42:33 CET 2007)
==> Installing package with pacman -U...
loading package data... done.
error: unsatisfied dependencies:
  xmms: requires libvorbis

==> ERROR: Failed to build "xmms"
Error: Failed to build "flac"
press CTRL+C to abort operation
waiting for 3 sec
Je n'arrive pas à comprendre pourquoi vu que yaourt gère normalement ceci (enfin makepkg).
Aurais-je oublié de mettre une option dans mon yaourt -Sb xine-ui?
Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain »

salut !
visiblement, si tu remonte un peu plus haut dans ton terminal, tu verras que la compilation du paquetage libvorbis (qui aurait du être compilé et installé en tant que dépendance de xmms ) a échoué.

Pour en savoir plus, lances un yaourt -Sb libvorbis :wink:
saintshakajin
Daikyu
Messages : 53
Inscription : ven. 11 août 2006, 22:05

Message par saintshakajin »

Je sais mais le but n'est quand même pas de compiler les dépendances à a main, à moins que j'ai râté un épisode :shock:
Il compile libvorbis et les désinstalle après. Puis il en a besoin plus tard et là, que dalle... j'ai pris l'exemple libvorbis mais j'en ai d'autres car j'avais fait un yaourt -Sb libvorbis xine-ui et j'ai quand même eu un stress avec une autre dépendance
Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain »

saintshakajin a écrit :Je sais mais le but n'est quand même pas de compiler les dépendances à a main, à moins que j'ai râté un épisode :shock:
Effectivement on a pas à se faire les dépendances à la main. Mais il se trouve que ce paquetage ne se compile pas chez toi pour une raison qui est indiquée à l'écran. Donc il faut d'abord relever l'erreur, corriger le PKGBUILD et ensuite tu pourras relancer la compilation avec yaourt.
Répondre