Cups 1.4 dans [Extra]

Merci de consulter cette rubrique avant de poster
Répondre
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Cups 1.4 dans [Extra]

Message par warnaud » jeu. 15 oct. 2009, 09:23

Le nouveau cups 1.4.x introduit de nombreuses nouvelles fonctionnalités. Du fait du changement de syntaxe de configuration, merci de partir d'un fichier cupsd.conf vierge. Vous pouvez en créer un à partir du fichier /etc/cups/cupsd.conf.default .

Imprimantes USB:
Pour faire fonctionner les imprimantes USB, vous devez désactiver le module usblp dans votre fichier rc.conf . Merci de blacklister ce module c'est à dire:
MODULES=(!usblp)

Article original: http://www.archlinux.org/news/469/ (Andreas Radke)
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 468
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: Cups 1.4 dans [Extra]

Message par FenDanT » jeu. 15 oct. 2009, 11:35

Coucoux warnaud :copain:

Merci pour l'astuce... J'ai blacklisté le module, mais toujours rien... Suppression et réinstallation de l'imprimante et tout est ok... :bravo:
Windows à des pépins ? Linux a un noyau ! :)

astreides
Chu Ko Nu
Messages : 433
Inscription : dim. 27 janv. 2008, 09:37

Re: Cups 1.4 dans [Extra]

Message par astreides » jeu. 15 oct. 2009, 11:38

Bonjour
J'ai blacklisté le module et du coup j'ai plus accès à http://localhost:631/ me innacessible.
J'ai remis le module et accès possible sauf que je ne peux plus imprimer : suppression et réinstallation et ca marche tjrs pas.
Merci de votre aide

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: Cups 1.4 dans [Extra]

Message par tuxce » jeu. 15 oct. 2009, 11:47

et t'as essayé ça:
warnaud a écrit :merci de partir d'un fichier cupsd.conf vierge.
?

astreides
Chu Ko Nu
Messages : 433
Inscription : dim. 27 janv. 2008, 09:37

Re: Cups 1.4 dans [Extra]

Message par astreides » jeu. 15 oct. 2009, 11:53

j'ai vidé le fichier et tjrs pas possible de me connecter sauf si je remet le module dans rc.conf

astreides
Chu Ko Nu
Messages : 433
Inscription : dim. 27 janv. 2008, 09:37

Re: Cups 1.4 dans [Extra]

Message par astreides » jeu. 15 oct. 2009, 18:09

module blacklisté mais impossible d'imprimer quoique ce soit.
Je cale ...

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: Cups 1.4 dans [Extra]

Message par tuxce » jeu. 15 oct. 2009, 18:27

astreides a écrit :j'ai vidé le fichier et tjrs pas possible
vierge ne veut pas dire vide, mais sans ajout, il faut donc reprendre celui du paquet qui a du se mettre en .pacnew

astreides
Chu Ko Nu
Messages : 433
Inscription : dim. 27 janv. 2008, 09:37

Re: Cups 1.4 dans [Extra]

Message par astreides » jeu. 15 oct. 2009, 19:24

tjrs pas possible d'imprimer
un tail /var/log/messages.log
ne done :

Oct 15 19:17:31 xxxxxxxx ntpd[3570]: Listening on interface #6 eth0, 192.168.1.10#123 Enabled
Oct 15 19:17:42 xxxxxxxx kernel: fuse init (API version 7.12)
Oct 15 19:19:21 xxxxxxxx acpid: client 3575[0:0] has disconnected
Oct 15 19:19:21 xxxxxxxx acpid: client 3575[0:0] has disconnected
Oct 15 19:19:21 xxxxxxxx acpid: client connected from 3792[0:0]
Oct 15 19:19:21 xxxxxxxx acpid: 1 client rule loaded
Oct 15 19:19:21 xxxxxxxx acpid: client connected from 3792[0:0]
Oct 15 19:19:21 xxxxxxxx acpid: 1 client rule loaded
Oct 15 19:20:57 xxxxxxxx ntpd[3570]: synchronized to 91.121.117.123, stratum 2
Oct 15 19:20:57 xxxxxxxx ntpd[3570]: kernel time sync status change 2001

Pascal S
Hankyu
Messages : 32
Inscription : lun. 20 nov. 2006, 12:26

Re: Cups 1.4 dans [Extra]

Message par Pascal S » jeu. 15 oct. 2009, 20:57

Je n'ai pas encore eu l'occasion d'essayer, mais le sujet m'intéresse...

astreides
Chu Ko Nu
Messages : 433
Inscription : dim. 27 janv. 2008, 09:37

Re: Cups 1.4 dans [Extra]

Message par astreides » ven. 16 oct. 2009, 09:29

Bonjour
Il semblerait que la dernière version de cups pose des soucis pour certains et pour d'autres pas.
J'ai donwn cups à la version antérieure et tout refonctionne impec.
Merci

Droopy 159
Hankyu
Messages : 11
Inscription : lun. 28 sept. 2009, 14:23
Localisation : Lyon

Re: Cups 1.4 dans [Extra]

Message par Droopy 159 » ven. 16 oct. 2009, 09:31

astreides a écrit :Bonjour
J'ai blacklisté le module et du coup j'ai plus accès à http://localhost:631/ me innacessible.
J'ai remis le module et accès possible sauf que je ne peux plus imprimer : suppression et réinstallation et ca marche tjrs pas.
Merci de votre aide
Pareil, j'ai tout fait : j'ai suivi le topic, rien. Supprimé réinstallé cups, rien. Supprimé réinstallé imprimante (Canon MP600), imprimante non détecté avec le module usblp blacklisté, mais détecté en le chargeant cependant l'instal se termine par
Bad device-uri "cnij_usb:/dev/usb/lp0"!
Help !!!!!!!!!!!!!!!!!

Droopy 159
Hankyu
Messages : 11
Inscription : lun. 28 sept. 2009, 14:23
Localisation : Lyon

Re: Cups 1.4 dans [Extra]

Message par Droopy 159 » ven. 16 oct. 2009, 10:14

astreides a écrit :Bonjour
Il semblerait que la dernière version de cups pose des soucis pour certains et pour d'autres pas.
J'ai donwn cups à la version antérieure et tout refonctionne impec.
Merci
Effectivement, tout refonctionne impec en downgradant. Cepedant peut-on exclure une mise à jour de cups automatiquement ? En faisant pacman -Suy il va redemander de le mettre a jour, il suffit de répondre non certes mais peut-on automatiquement exclure jusqu'à nouvel ordre ?

Merci

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: Cups 1.4 dans [Extra]

Message par ddup1 » ven. 16 oct. 2009, 13:20

Droopy 159 a écrit :
astreides a écrit :Bonjour
Il semblerait que la dernière version de cups pose des soucis pour certains et pour d'autres pas.
J'ai donwn cups à la version antérieure et tout refonctionne impec.
Merci
Effectivement, tout refonctionne impec en downgradant. Cepedant peut-on exclure une mise à jour de cups automatiquement ? En faisant pacman -Suy il va redemander de le mettre a jour, il suffit de répondre non certes mais peut-on automatiquement exclure jusqu'à nouvel ordre ?

Merci

Regarde dans ton fichier /etc/pacman.conf tu as une ligne pour les paquets que tu ne veux pas mettre à jour :

Code : Tout sélectionner

IgnorePkg= cups

Avatar de l’utilisateur
JPEC
yeomen
Messages : 223
Inscription : sam. 27 déc. 2008, 22:26
Localisation : Paris

Re: Cups 1.4 dans [Extra]

Message par JPEC » ven. 16 oct. 2009, 19:48

il suffit de générer le certificat ssl pour cups dans le répertoire /etc/cups/ssl/

Avatar de l’utilisateur
nimoinau
newbie
Messages : 9
Inscription : mar. 25 août 2009, 21:43

Re: Cups 1.4 dans [Extra]

Message par nimoinau » mer. 21 oct. 2009, 10:53

idem pour moi
canon i865
depuis la mise a jour de cups, cups est toujours en attente de dispo de l'imprimante et rien ne se passe.

edit2 : module usblp blacklisté, imprimante supprimer puis réinstaller et tout refonctionne.

Droopy 159
Hankyu
Messages : 11
Inscription : lun. 28 sept. 2009, 14:23
Localisation : Lyon

Re: Cups 1.4 dans [Extra]

Message par Droopy 159 » mer. 11 nov. 2009, 19:54

J'ai réessayé avec la mise à jour vers cups 1.4.2 cela ne marchait toujours pas : nouveau cups.conf, module usblp blacklisté dans rc.conf, supprimé et réinstallé l'imprimante. Rien !

Puis j'ai eu l'idée de jeter un coup d'oeil dans le wiki anglais archlinux.org :
http://wiki.archlinux.org/index.php/CUP ... shooting_2

En faisant lsusb j'avais
(...)
Bus 008 Device 002: ID 04a9:1718 Canon, Inc. MP600 Storage
(...)
Puis,
ls -l /dev/bus/usb/008/002
crw-rw-r-- 1 root scanner 189, 897 nov. 11 18:47 /dev/bus/usb/008/002
Ma MP600 était donc dans le groupe scanner et non lp, ce qui pour une multifonction peut paraitre normal

j'ai donc crée comme préconisé crée la règle : /etc/udev/rules.d/10-usbprinter.rules avec nano
ATTR{idVendor}=="04a9", ATTR{idProduct}=="1718", MODE:="0660", GROUP:="lp"
Puis supprimé et réinstallé l'imprimante après un redémarrage. Cups nouvelle version l'a enfin détecté et tout fonctionne à merveille. C'était donc en fin de compte une histoire de groupe !

Répondre