[kdm kdemod] impossible de lancer une session(résolu)

Le projet Chakra et ses outils (KDEmod, Shaman)
Règles du forum
Chakra n'étant plus compatible avec Arch Linux, cette section du forum est vérouillée
Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

[kdm kdemod] impossible de lancer une session(résolu)

Message par Rolinh » lun. 22 mars 2010, 22:17

Bonjour à tous!

j'ai fraichement installé Arch sur une machine et je rencontre quelques soucis...
En fait, j'avais installé kde via le paquet kde comme indiqué dans la doc. Mais je rencontrais plusieurs soucis d'applications qui plantaient et ne se lançaient même pas en fait (amarok etc...).

Donc je me suis dit: pourquoi pas essayer kdemod. Alors j'ai supprimé tout trace de kde puis ai rajouté les dépôts pour kdemod et installé le bazar. Seulement voilà: en essayant de me logger depuis kdm, je vois le premier icone du splashscreen puis après...retour à kdm... Je n'ai jamais réussi à finir sur le bureau alors que cela marchait avec kde "normal".

Quelqu'un aurait une idée?

au cas ou, mes démons:
DAEMONS=(syslog-ng @network netfs @crond alsa dbus hal @networkmanager @ntpd @pulseaudio @kdm)
Dernière modification par Rolinh le jeu. 25 mars 2010, 00:18, modifié 2 fois.

Avatar de l’utilisateur
tuxador
Hankyu
Messages : 25
Inscription : ven. 18 déc. 2009, 23:43
Localisation : Algerie

Re: [kdm kdemod]

Message par tuxador » lun. 22 mars 2010, 23:22

aha j'ai vu le meme probleme sur un autre forum! (ubuntu-fr pour ne pas le nommer)
commences deja par essayer de se logguer en root; sinon effacer le fichier /home/tonhome/.kdemod4 si tu n'as pas des données importantes (je suppose que non si c'est une fresh install)
j'espere que ça t'a servi
Happy Archer

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod]

Message par Rolinh » mar. 23 mars 2010, 16:34

Salut!

il y du mieux: en regardant les logs du .xsession-errors --> c'était qimageblitz qui posait problème. Avec un sudo pacman -Syyu && sudo pacman -S qimageblitz j'ai enfin pu lancer ma session.

Seulement, mes problèmes ne sont pas résolus pour autant: crash multiples (kwin, amarok, kwallet, lancelot...)... ça fait que de crasher :(

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod] impossible de lancer une session

Message par Rolinh » jeu. 25 mars 2010, 00:17

Bon, tout baigne maintenant :)

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par Rolinh » lun. 29 mars 2010, 20:32

Pour info: networkmanager faisait planter tout plasma :( (et je ne suis pas le seul à qui cela arrivait) alors un petit:

Code : Tout sélectionner

sudo pacman -Rd kdemod-networkmanagement-networkmanager-plasmoid
et installation de wicd à la place et plus vraiment de plantage maintenant.

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » ven. 02 avr. 2010, 13:03

alu
je remonte un peu le sujet
mais j'ai fait une MàJ de kdemod ce matin et j'ai sensiblement le même problème puisque après m'être logué je vois mon bureau 1 seconde et ça crache (écran noir) j'ai une fenêtre "gestionnaire de panne kde" avec comme panne
"exécutable : kdeinit4 pid : 2071 signal : 7 (bus error)
voilà ... je sais pas quoi faire, comme d'hab :|

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par Rolinh » ven. 02 avr. 2010, 13:51

Salut,

j'ai aussi des soucis depuis la mise à jour de kdemod en 4.2.2 (pour une version de correction de bugs, elle n'a fait que m'en apporter! mon clavier est en qwerty maintenant et je ne peux pas le changer!) :/

Mais à part ça: post le .xsession-errors que tu as dans ton /home, comme ça on pourra mettre la main sur le coupable.

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par Rolinh » ven. 02 avr. 2010, 14:01

Bon bah ils avaient du un petit peu se précipiter les gars de chez kdemod... Après une nouvelle mise à jour, tout est rentré dans l'ordre :)

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » ven. 02 avr. 2010, 19:08

mon .xsession-errors

Code : Tout sélectionner

...
QObject::connect: Cannot connect (null)::ejectPressed(QString) to SolidAutoEject::onEjectPressed(QString)
kded(2069)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
QObject::connect: Cannot connect (null)::ejectPressed(QString) to SolidAutoEject::onEjectPressed(QString)
knotify(2103)/kdeui (KIconLoader): Unable to access index when trying to discard cache 
QProcess: Destroyed while process is still running.
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
NepomukServer(2127)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
klauncher: Exiting on signal 1
klauncher(2067)/kio (KLauncher): SlavePool: No communication with slave. 

kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kdeinit4: Exit.
kglobalaccel: Fatal IO error: client killed
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
j'ai pas tout mis
Votre message contient 452647 caractères. Le nombre maximal de caractères autorisé est 60000.

Avatar de l’utilisateur
Rolinh
Chu Ko Nu
Messages : 392
Inscription : sam. 15 août 2009, 09:15
Localisation : Suisse
Contact :

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par Rolinh » ven. 02 avr. 2010, 19:18

Il en faudrait quand même un peu plus...
Mets ce que tu as depuis ta dernière session

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » ven. 02 avr. 2010, 19:58

j'ai booter sur ctkarch USB
et mon xsessions-errors et super long

Code : Tout sélectionner

 
kded4: Fatal IO error: client killed
kglobalaccel: Fatal IO error: client killed
QProcess: Destroyed while process is still running.
korgac: Fatal IO error: client killed
krunner: Fatal IO error: client killed
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
klauncher: Exiting on signal 1
kdeinit4: Fatal IO error: client killed
kdeinit4: sending SIGHUP to children.
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit.
kDebugStream called after destruction (from void sigterm_handler(int) file /home/phil/kdemod/core/kdebase-workspace/src/kdebase-workspace-4.4.2/kwrited/kwrited.cpp line 56)
Caught signal 15 , exiting... 
NepomukServer(2116)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
kdeinit4: sending SIGTERM to children.
kdeinit4: Exit
bon la c'est les 4 derniéres pages, y en a 121
Dernière modification par 101 le dim. 04 avr. 2010, 22:50, modifié 1 fois.

Avatar de l’utilisateur
tuxador
Hankyu
Messages : 25
Inscription : ven. 18 déc. 2009, 23:43
Localisation : Algerie

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par tuxador » sam. 03 avr. 2010, 12:35

Sherwood51 a écrit :Salut,

j'ai aussi des soucis depuis la mise à jour de kdemod en 4.4.2 (pour une version de correction de bugs, elle n'a fait que m'en apporter! mon clavier est en qwerty maintenant et je ne peux pas le changer!) :/

Mais à part ça: post le .xsession-errors que tu as dans ton /home, comme ça on pourra mettre la main sur le coupable.
bon la mise a jour de ce atin a resolu le probleme, et je constate un leger gain en performance pour cette mise a jour, cool :bravo:
Happy Archer

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » sam. 03 avr. 2010, 16:26

ouai, j'ai fais la MàJ aussi ça change rien pour moi,
bon j'ai installé openbox en parallèle, c'est cool, pas simple mais cool

Avatar de l’utilisateur
tuxador
Hankyu
Messages : 25
Inscription : ven. 18 déc. 2009, 23:43
Localisation : Algerie

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par tuxador » sam. 03 avr. 2010, 17:14

essaie de lancer ça en root

Code : Tout sélectionner

kbuildsycoca4 
ça devrait regler l'affaire
Happy Archer

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » sam. 03 avr. 2010, 19:01

bah non :cry: ça change rien, j'ai toujours un problème kdeinit4

Avatar de l’utilisateur
101
Chu Ko Nu
Messages : 403
Inscription : dim. 21 janv. 2007, 16:31

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par 101 » lun. 05 avr. 2010, 11:26

bon la solution à mon problème

Code : Tout sélectionner

pacman -Scc
:mur:

ArchIMEDE
Hankyu
Messages : 41
Inscription : lun. 05 janv. 2009, 15:32

Re: [kdm kdemod] impossible de lancer une session(résolu)

Message par ArchIMEDE » mer. 21 avr. 2010, 13:42

Sherwood51 a écrit :Pour info: networkmanager faisait planter tout plasma :( (et je ne suis pas le seul à qui cela arrivait) alors un petit:

Code : Tout sélectionner

sudo pacman -Rd kdemod-networkmanagement-networkmanager-plasmoid
et installation de wicd à la place et plus vraiment de plantage maintenant.
kdemod-networkmanagement-knetworkmanager-kde4 fonctionne également (pour ceux qui ne veulent pas de wicd)

Verrouillé