[LIVE CD]Écran noir

Le projet Chakra et ses outils (KDEmod, Shaman)
Règles du forum
Chakra n'étant plus compatible avec Arch Linux, cette section du forum est vérouillée
Avatar de l’utilisateur
pascal.lemazurier
Daikyu
Messages : 72
Inscription : mar. 02 nov. 2010, 12:09
Localisation : Lorient / France
Contact :

Re: [LIVE CD]Écran noir

Message par pascal.lemazurier » lun. 21 mars 2011, 19:24

Bon apparemment tu as réussi à l'installer c'est l'essentiel cette CtkArchLIve, sinon pour l'adresse internet il y en a une nouvelle qui devrait donc avoir une documentation et un support à jour ;)

http://ctkarch.org/

Pour les Live-CD Chakra c'est quand même dommage que tu n'y arrives pas, c'est plutôt une bonne distribution je trouve même si elle ne me convient pas et que j'utilise ArchLinux à la place... ^^ tu peux essayer différentes résolutions suivant ton écran, par exemple la résolution minimale en 640x480 pixels et avec 256 couleurs (vga=769) à plus de chance d'être pris en charge par Xorg et son pilote utilisé que si tu marques une résolution trop grande par rapport à ton écran...
Pascal Lemazurier
OpenAstro rocks on ArchLinux (http://openastro.org/) !

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Re: [LIVE CD]Écran noir

Message par Calimero » mar. 22 mars 2011, 11:37

Je ne vois pas l'intérêt de lancer VesaFB (vga=machin) quand on a des ennuis avec Xorg.
Non, la résolution donnée par le paramètre vga= ne sera pas prise par Xorg.
Sauf si tu utilises le pilote fbdev bien sûr, mais ça ne semble pas le cas.

En plus, souvent l'utilisation de VesaFB est en conflit avec le KMS du module i915 (intel) / nouveau (nvidia) / radeon (ati).
Ce qui résulte en un écran noir à cause de vga=machin.

Voilà, évite de galérer en jouant avec un paramètre qui n'a aucun rapport et met le bazar...
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

Avatar de l’utilisateur
pascal.lemazurier
Daikyu
Messages : 72
Inscription : mar. 02 nov. 2010, 12:09
Localisation : Lorient / France
Contact :

Re: [LIVE CD]Écran noir

Message par pascal.lemazurier » mar. 22 mars 2011, 14:03

Oui mais vu qu'il y a un écran noir sans appeler VesaFrameBuffer, l'appeller avec la résolution adéquate peut résoudre le problème d'affichage, enfin personnellement ça m'a déjà permis de pouvoir booter sur certains Live-CD sur mon portable... (et avec un écran qui ne devient pas tout noir...)
Pascal Lemazurier
OpenAstro rocks on ArchLinux (http://openastro.org/) !

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Re: [LIVE CD]Écran noir

Message par Calimero » mar. 22 mars 2011, 16:58

Généralement, l'écran tout noir c'est le KMS qui foire (et c'est rare).
Donc si tu lances un autre pilote d'affichage qui est en conflit (vesafb par exemple), ça peut arriver que tu évites le souci.
Mais c'est tout sauf fiable.
Vesafb étant dans le noyau, il est chargé avant l'initramfs ou même les uevents ; donc quand arrive le moment de charger radeon, nouveau ou i915, il crashe (violemment ou invisiblement, ton cas car tu as eu de la chance), et tu gardes ton vesafb jusqu'au bout.
C'est très crade.
Ensuite X se lance en Vesa. (mais PAS sur ton framebuffer vesafb !! il faudrait forcer l'utilisation du pilote fbdev pour ça, or c'est vesa par défaut)

La solution propre consiste à utiliser nomodeset sur la cmdline.
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

Avatar de l’utilisateur
pascal.lemazurier
Daikyu
Messages : 72
Inscription : mar. 02 nov. 2010, 12:09
Localisation : Lorient / France
Contact :

Re: [LIVE CD]Écran noir

Message par pascal.lemazurier » mar. 22 mars 2011, 19:43

Hum c'est pas faux pour tout ça, je ne connaissais pas la commande merci Calimero... ;)
Enfin ma solution peut aussi marcher, après oui c'est un peu du bricolage mais bon tant que ça boot correctement c'est l'essentiel après...
Pour ta solution la commande serait donc au final :

Code : Tout sélectionner

/boot/vmlinuz26 initrd=/boot/larch.img lang=fr nomodeset
Pascal Lemazurier
OpenAstro rocks on ArchLinux (http://openastro.org/) !

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Re: [LIVE CD]Écran noir

Message par Calimero » ven. 25 mars 2011, 23:30

Attention ici. Pour archbang ils avaient aveuglément décidé d'utiliser VESA parce que c'est soi-disant plus fiable, résultat : que des foirages à cause de ça.

nomodeset, je ne conseille de l'utiliser QUE sur les cartes ATI radeon qui foirent avec le KMS. (problème très fréquent)
Sur nvidia et intel, cette option va juste empêcher X de fonctionner, ou très mal, ou avec de la chance en VESA.

Pourquoi crois-tu que j'essaie d'utiliser et d'intégrer des pilotes bleeding edge uniquement sur ctkarch ?
Ça reste encore la solution la plus stable, n'en déplaise à ceux qui pensent comme des debianeux (dans le mauvais sens du terme).
Et puis c'est totalement inutile d'avoir un livecd qui certes fonctionne, mais ne te permet pas de savoir rapidement si le pilote libre avec support 3D et tout fonctionnera. (s'il faut se l'installer à la main c'est un peu bête…)
</ma philosophie>
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

Verrouillé