[Soucis configuration ALSA (et/ou pulseaudio)] et autres joyeusetés...

Architecture ARM, archlinuxarm, raspberrypi ...
RoKN
Hankyu
Messages : 38
Inscription : mer. 12 août 2015, 13:27

[Soucis configuration ALSA (et/ou pulseaudio)] et autres joyeusetés...

Message par RoKN » sam. 05 sept. 2015, 11:17

Bonjour !

Bon alors voilà, j'ai installé Archlinux sur mon Raspberry Pi 2 pour en faire mon ordi principal.
Après l'installation et la configuration de base, je me retrouve devant quelques petits soucis que je n'arrive pas a corriger tout seul :-(
Ces soucis concernent la configuration audio principalement.

Tout d'abord, j'ai suivi le tuto sur Alsa, et j'ai donc installé alsa-utils et alsa-oss.
Comme je fais un peu de MAO, j'ai également installé Qjackctl
J'ai ensuite installé pulseaudio, pulseaudio-jack et pavucontrol.

Ensuite, comme je l'utilise, j'ai installé puredata (pd), mais comme l'utilisation de jack comme périphérique audio me retournait un segmentation fault, je l'ai désinstallé au profit de pd-extended (via AUR), mais j'avais encore plus de soucis donc je l'ai également viré, et je suis bien embêtté car j'ai besoin d'un des 2 (de préférence pd-extended), mais cela est une autre histoire : d'abord la configuration audio :lol:

Déjà, lors du lancement de speaker-test, voici ce que ça me sort :

Code : Tout sélectionner

[ronan@archrpi2 ~]$ speaker-test

speaker-test 1.0.29

Le périphérique de lecture est default
Les paramètres du flux sont 48000Hz, S16_LE, 1 canaux
Utilisation de 16 octaves de 'pink noise'
ALSA lib pcm_dmix.c:1024:(snd_pcm_dmix_open) unable to open slave
Erreur d'ouverture à la lecture: -2,Aucun fichier ou dossier de ce type
[ronan@archrpi2 ~]$ 
La carte-son est bien reconnue...

Code : Tout sélectionner

[ronan@archrpi2 ~]$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: ALSA [bcm2835 ALSA], périphérique 0: bcm2835 ALSA [bcm2835 ALSA]
  Sous-périphériques: 8/8
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
  Sous-périphérique #2: subdevice #2
  Sous-périphérique #3: subdevice #3
  Sous-périphérique #4: subdevice #4
  Sous-périphérique #5: subdevice #5
  Sous-périphérique #6: subdevice #6
  Sous-périphérique #7: subdevice #7
carte 0: ALSA [bcm2835 ALSA], périphérique 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 1: U96k [UMC404 96k], périphérique 0: USB Audio [USB Audio]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
[ronan@archrpi2 ~]$
... mais je ne comprends pas ce que sont tout ces "subdevices"... :|
Sinon :

Code : Tout sélectionner

[ronan@archrpi2 ~]$ cat /proc/asound/cards 
 0 [ALSA           ]: bcm2835 - bcm2835 ALSA
                      bcm2835 ALSA
 1 [U96k           ]: USB-Audio - UMC404 96k
                      BEHRINGER UMC404 96k at usb-3f980000.usb-1.3, high speed
[ronan@archrpi2 ~]$ 
Bref, je suis un peu perdu, je n'ai jamais trop pigé le fonctionnement d'alsa et j'ai toujours eu quelques soucis de ce genre aussi bien sous Debian que sous Ubuntu :(

Merci d'avance pour votre aide, ça va me permettre de bien avancer :)

Avatar de l’utilisateur
ed0c
Chu Ko Nu
Messages : 327
Inscription : mer. 24 mars 2010, 10:02

Re: [Soucis configuration ALSA (et/ou pulseaudio)] et autres joyeusetés...

Message par ed0c » jeu. 21 janv. 2016, 00:36

Salut!

Je ne suis pas un expert concernant alsa, mais j'ai cru voir sur ta config que tu avais une carte son usb en plus. Tu voudrais faire sortir le son via cette carte.
Si j'ai bien compris en fouinant sur différents forums, il faudrait que tu actives cette carte audio usb et que tu désactives la carte audio principale en éditant le fichier /etc/modprobe.d/alsa-base.conf :

Pour activer la carte son usb:

Code : Tout sélectionner

options snd-usb-audio index=-0
(à la base ce paramètre est options snd-usb-audio index=-2)

et pour désactiver la carte son du pi il te faut ajouter:

Code : Tout sélectionner

options snd_bcm2835 index=1
En espérant t'avoir filé un coup de main

Répondre