[pacman] ALPM-SCRIPTLET (Résolu)

Architecture ARM, archlinuxarm, raspberrypi ...
Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

[pacman] ALPM-SCRIPTLET (Résolu)

Message par alh54 » mer. 24 févr. 2016, 17:21

Bonjour,

Chaque fois que j'installe un paquet ou mets à jour le système j'ai ces 3 lignes qui s'affichent:

Code : Tout sélectionner

ldconfig: Fichier /usr/lib/libcc1.so.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcc1.so.0.0.0 est vide, n'a pas été vérifié.
ldconfig: Fichier /usr/lib/libcc1.so est vide, n'a pas été vérifié.

Code : Tout sélectionner

[root@alarmpi alarm]# pacman -Qo /usr/lib/libcc1.so.0
erreur : aucun paquet ne contient /usr/lib/libcc1.so.0
De quoi peut-il s'agir?
Dernière modification par alh54 le sam. 27 févr. 2016, 16:32, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pacman] ALPM-SCRIPTLET

Message par benjarobin » mer. 24 févr. 2016, 17:50

Bonjour,
Toi tu as ton système de fichier de corrompu... Et ainsi la base de donnée de pacman corrompu (d'après l'autre sujet : viewtopic.php?f=26&t=17939)
Tu n'aurais pas éteint brutalement la machine juste après une mise jour ou pire pendant une mise à jour ?

Bref pour réparer, il va falloir réinstaller tous les paquets qui était installés (en forçant la mise à jour)...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

Re: [pacman] ALPM-SCRIPTLET

Message par alh54 » mer. 24 févr. 2016, 18:14

Oui, j'ai eu une coupure de courant en pleine installation de paquets.
Je vais essayer de sauvegarder la liste des paquets installés et les réinstaller par la suite.
Merci.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pacman] ALPM-SCRIPTLET

Message par benjarobin » mer. 24 févr. 2016, 21:29

Inutile de faire une telle chose, il y a bien plus simple :

Code : Tout sélectionner

pacman -S $(pacman -Qq)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

Re: [pacman] ALPM-SCRIPTLET

Message par alh54 » mer. 24 févr. 2016, 22:00

J'ai appliqué la commande pacman -S $(pacman -Qq), puis quand je lance pacman -Syu, retour à la case départ.

Code : Tout sélectionner

gcc : /usr/share/man/man3/std::wstringbuf.3.gz est déjà présent dans le système de fichiers
gcc : /usr/share/man/man3/std::wstringstream.3.gz est déjà présent dans le système de fichiers
gcc : /usr/share/man/man7/fsf-funding.7.gz est déjà présent dans le système de fichiers
gcc : /usr/share/man/man7/gfdl.7.gz est déjà présent dans le système de fichiers
gcc : /usr/share/man/man7/gpl.7.gz est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n’a été mis à jour.
et plein d'autres lignes du même genre concernant gcc.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pacman] ALPM-SCRIPTLET

Message par benjarobin » mer. 24 févr. 2016, 22:18

Comme je l'avais (plus ou moins) indiqué, tu dois forcer la mise à jour de chaque paquet dont la base de donnée est corrompu :

Code : Tout sélectionner

pacman -S --force gcc
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

Re: [pacman] ALPM-SCRIPTLET

Message par alh54 » mer. 24 févr. 2016, 22:51

oui ça passe avec l'option force.
Je ne marque pas encore en résolu, j'attends de voir comment cela évolue.

Merci pour ton aide très efficace dans ce forum.

Répondre