[kernel] No modules were added to the image.

Architecture ARM, archlinuxarm, raspberrypi ...
Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

[kernel] No modules were added to the image.

Message par alh54 » dim. 23 avr. 2017, 17:45

Bonjour,

Suite à une mise à jour de linux-raspberry jai eu ceci:
:: Exécution des crochets de post-transaction...
(1/2) Updating linux-raspberrypi initcpios
==> Building image from preset: /etc/mkinitcpio.d/linux-raspberrypi.preset: 'default'
-> -k 4.9.23-1-ARCH -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.9.23-1-ARCH
-> Running build hook: [base]
-> Running build hook: [udev]
-> Running build hook: [autodetect]
-> Running build hook: [modconf]
-> Running build hook: [block]
-> Running build hook: [filesystems]
-> Running build hook: [keyboard]
-> Running build hook: [fsck]
==> WARNING: No modules were added to the image. This is probably not what you want.
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(2/2) Arming ConditionNeedsUpdate...
Si je comprends bien les hook n'ont pas été ajoutés à l'image.
J'ai pensé un moment que c'était du à une modification de /boot/config.txt avec l'emission de /boot/config.txt.pacnew qui contient une nouvelle ligne:
initramfs initramfs-linux.img followkernel
J'adopte ce .pacnew, je reboote, je réinstalle linux-raspberry, toujours le même avertissement.
A priori je n'ai pas dysfonctionnement mais j'aimerai comprendre ce qui se passe.
J'ai googlé un peu mais rien de probant.
Merci.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel] No modules were added to the image.

Message par benjarobin » dim. 23 avr. 2017, 18:09

Bonjour,
Les hooks ont bien été ajoutés, c'est juste qu'il n'y a aucun module kernel qui a été jouté. Ce qui est tout à fait possible dans le cas du RPI (désolé rien pour vérifier), tout dépend comment et avec quel option le kernel a été compilé. Si tous les modules "importants" ont été compilé dans le kernel et non en tant que module alors c'est tout à fait normal d'avoir ce warning
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

Re: [kernel] No modules were added to the image.

Message par alh54 » dim. 23 avr. 2017, 23:02

Je viens de consulter le forum de archarm, j'ai trouvé un fil identique au mien. Dans les réponse on dit que l'initramfs n'a pas besoin de nouveaux modules ce qui confirme ta supposition.
Tout semble normal. Merci pour l’éclaircissement.

Répondre