[Archlinux32] partitionnement - Vieilles partitions et problème avec sda

Questions autour de l'architecture 32 bits (i686)
Répondre
Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

[Archlinux32] partitionnement - Vieilles partitions et problème avec sda

Message par Matows » ven. 20 avr. 2018, 13:59

Bonjour !
Bon petite mise au point :
- je suis tout nouveau sous arch.
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
- Je voudrais utiliser le script Archlinux Ultimate Installator (aui) pour ma première fois, mais j'ai pas de problème à faire sans (j'ai essayé de partitionner avec fdisk en suivant ce tutoriel.

J'avais avant une installation ubuntu-server que j'avais du installer avec LVM (ne sachant pas trop ce que c'était à l'époque) ce qui est complètement innutile pour mon usage. Je me retrouve donc avec des partitions "parasites" : /dev/mapper/ubuntu--server--vg-root et /dev/mapper/ubuntu--server--vg-swap_1, qui me prenne tout de même 74 GiB (je ne connais d’ailleurs pas ma capacité initial :oops:).

Je voudrais donc les supprimés, voir même effacer tout le disque dur.

J'ai un autre problème : une fois le partitionnement de sda fait (en suivant le turoriel), j'ai essayé de formater sda3 en ext4 et j'ai reçu une erreur comme quoi la partition n'existait pas (alors que j'ai fait sda1>boot, sda2>swap et sda3>root). fdisk -l renvoi bien le partitionnement sda1/sda2/sda3.

Cordialement,
M'.
Dernière édition par FoolEcho le sam. 21 avr. 2018, 09:19, édité 1 fois.
Raison : précision: Arch32

Avatar de l’utilisateur
averellb
Hankyu
Messages : 26
Inscription : mar. 29 mai 2012, 11:39
Localisation : Bordeaux

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par averellb » ven. 20 avr. 2018, 14:10

Bonjour,

Une remarque préliminaire, il est vivement conseillé de préférer le wiki à toute autre source de documentation sur Archlinux. Un tuto de 2015 a peu de chances d'être encore valable 3 ans après. Pour le partitionnement passe encore, mais d’une manière générale c’est à éviter.

Commençons par la fin : peux tu donner la sortie exacte de mkfs pour comprendre ce qui fait échouer le formatage ? Car en effet si fdisk dit que la partition existe on ne voit pas pourquoi elle n'existerait pas.

Quant à tes anciennes partitions lvm, si tu as re-partitionné comme tu l'indiques elles ont dû disparaître toutes seules, sinon je veux bien voir la sortie complète de fdisk -l /dev/sda.

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » ven. 20 avr. 2018, 14:49

Bon ba c'est bon, je me sent déjà bête : entre temps j'ai redémarrer le pc (toujours sur la live USB) et ce qu'il m'affiche est correct... :oops:
http://paste.ubuntu.com/p/BdFtRnhk5R/

Donc normalement ça devrait être tout bon...
Je vous dit si j'ai un vrai problème durant l'installation.

Et merci tu conseil pour archlinux et la doc :D

M'

Shade
Hankyu
Messages : 26
Inscription : sam. 31 mars 2018, 19:26

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Shade » ven. 20 avr. 2018, 14:58

Bonjour,

T'es sur que t'as bien suivi cette page https://wiki.archlinux.fr/Installation# ... partitions
100Mo ça me parait un peu juste
PC fixe Core I5 - gtx1050 8G ram | Arch 4.16-2 - KDE

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » ven. 20 avr. 2018, 15:18

Shade a écrit :
ven. 20 avr. 2018, 14:58
Bonjour,

T'es sur que t'as bien suivi cette page https://wiki.archlinux.fr/Installation# ... partitions
100Mo ça me parait un peu juste
Et bien j'avais regardé l'autre lien justement. Mais je referai avec 300M

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1924
Inscription : jeu. 15 mars 2012, 05:08

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par waitnsea » ven. 20 avr. 2018, 16:27

Matows a écrit :
ven. 20 avr. 2018, 13:59
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
Bonjour,
L'Architecture 32b n'est plus supportée officiellement, vois cette annonce et le lien pour la branche communautaire 32b.
Quant à un tutoriel de 2014 ! tant de choses ont changé depuis, va sur le site de la nouvelle branche 32b...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » ven. 20 avr. 2018, 17:16

waitnsea a écrit :
ven. 20 avr. 2018, 16:27
Matows a écrit :
ven. 20 avr. 2018, 13:59
- J'utilise une vieille machine sur laquelle je compte installer archlinux 32bit (celle soutenu par la communauté).
Bonjour,
L'Architecture 32b n'est plus supportée officiellement, vois cette annonce et le lien pour la branche communautaire 32b.
Quant à un tutoriel de 2014 ! tant de choses ont changé depuis, va sur le site de la nouvelle branche 32b...
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
Il y a tant de chose que ça qui on changer pour le partitionnement ?

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1924
Inscription : jeu. 15 mars 2012, 05:08

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par waitnsea » ven. 20 avr. 2018, 18:31

Le partitionnement a un peu changé : il n'y a vraiment aucun intérêt à une partition /boot séparée, (que des ennuis en fait)
Puis il y a la suite du tuto, au rayon fstab déjà: utiliser les UUID donc genstab -U et non -L , etc...
Dis-nous la taille de ton HDD et ce que tu envisages pour tes partitions 2 (swap et / ) ou 3 (/home séparé en +), et leur taille
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » ven. 20 avr. 2018, 18:46

waitnsea a écrit :
ven. 20 avr. 2018, 18:31
Le partitionnement a un peu changé : il n'y a vraiment aucun intérêt à une partition /boot séparée, (que des ennuis en fait)
Puis il y a la suite du tuto, au rayon fstab déjà: utiliser les UUID donc genstab -U et non -L , etc...
Dis-nous la taille de ton HDD et ce que tu envisages pour tes partitions 2 (swap et / ) ou 3 (/home séparé en +), et leur taille
Étant donné que je suis débutant et que c'est une machine pour testé, j'ai opté pour un partitionnement simple (sda1 pour /, sda2 pour swap (2Go)). J'ai alloué tout le reste du disque à / (72.5G).

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1924
Inscription : jeu. 15 mars 2012, 05:08

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par waitnsea » ven. 20 avr. 2018, 19:17

Sur un petit HDD c'est ce qu'il y a de mieux en plus.

Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10400
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par FoolEcho » sam. 21 avr. 2018, 09:30

Matows a écrit :
ven. 20 avr. 2018, 17:16
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
En passant, je demande à nos admins de rajouter une section pour le 32 bits niveau forum (j'ai modifié ton titre en conséquence aussi), qu'on gagne en lisibilité. :moderationok:
«The following statement is not true. The previous statement is true.» :nage:

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » sam. 21 avr. 2018, 14:42

waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Sur un petit HDD c'est ce qu'il y a de mieux en plus.

Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Le disque fait 80Go (model : ATA Maxtor 6L080M0)
FoolEcho a écrit :
sam. 21 avr. 2018, 09:30
Matows a écrit :
ven. 20 avr. 2018, 17:16
J'ai justement dit que j'utilisais cette version (https://archlinux32.org/).
En passant, je demande à nos admins de rajouter une section pour le 32 bits niveau forum (j'ai modifié ton titre en conséquence aussi), qu'on gagne en lisibilité. :moderationok:
Merci :)

Une fois l'installation faite, j'ai utilisé lilo de AUI pour installer l'environnement graphique, serveur X etc. Mais l'affichage plante en démarrant le système et je ne peux pas accéder à la ligne de commande. Je peux me connecter au système via la live USB et arch-chroot mais je ne sais pas comment désactiver le démarrage automatique du serveur X.
Une idée ?

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1924
Inscription : jeu. 15 mars 2012, 05:08

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par waitnsea » sam. 21 avr. 2018, 16:21

Matows a écrit :
sam. 21 avr. 2018, 14:42
waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Une idée ?
Pourquoi ne donnes-tu pas les retours de commande quand on te les demande ? Tu reprends le cd-live d'installation, tout simplement...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10400
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par FoolEcho » dim. 22 avr. 2018, 09:17

Matows a écrit :
sam. 21 avr. 2018, 14:42
Une fois l'installation faite, j'ai utilisé lilo de AUI pour installer l'environnement graphique, serveur X etc. Mais l'affichage plante en démarrant le système et je ne peux pas accéder à la ligne de commande. Je peux me connecter au système via la live USB et arch-chroot mais je ne sais pas comment désactiver le démarrage automatique du serveur X.
Une idée ?
De la même façon qu'il a été activé... Faut désactiver le service systemd qui va bien, typiquement ton gestionnaire de connexion, gdm ou autre ( https://wiki.archlinux.fr/Systemd#Services ) ou modifier la ligne du kernel au moment du démarrage pour passer en niveau 3 ( https://wiki.archlinux.fr/Systemd#Target ; https://wiki.archlinux.fr/Syslinux#Options_temporaires ).
«The following statement is not true. The previous statement is true.» :nage:

Matows
newbie
Messages : 7
Inscription : ven. 20 avr. 2018, 12:51

Re: [Partitionnement] Vieilles partitions et problème avec sda

Message par Matows » dim. 22 avr. 2018, 18:30

waitnsea a écrit :
sam. 21 avr. 2018, 16:21
Matows a écrit :
sam. 21 avr. 2018, 14:42
waitnsea a écrit :
ven. 20 avr. 2018, 19:17
Donne, stp le retour de

Code : Tout sélectionner

# parted -l /dev/sda
Une idée ?
Pourquoi ne donnes-tu pas les retours de commande quand on te les demande ? Tu reprends le cd-live d'installation, tout simplement...
Parce que je n'avais pas assez de temps pour upload ça via curl sur paste.ubuntu.com (je sais pas si il y a un équivalent pour arch) et copier à la main le code ici. Mais maintenant que je peux, le voici : http://paste.ubuntu.com/p/myPVXHsj9c/

Et merci FoolEcho cela fonctionne :)

Avatar de l’utilisateur
Piczel
Chu Ko Nu
Messages : 314
Inscription : dim. 03 mai 2015, 19:17
Localisation : Terre du Milieu

Re: [Archlinux32] partitionnement - Vieilles partitions et problème avec sda

Message par Piczel » lun. 11 juin 2018, 17:49

Salut, pour paste du code, j'utilise ptpb qui a l'avantage d'être ultra facilement utilisable depuis la ligne de commande.

J'utilise cette fonction, via un simple appel de pbx <commande>

Code : Tout sélectionner

pbx () {
	curl -sF "c=@${1:--}" -w "%{redirect_url}" 'https://ptpb.pw/?r=1' -o /dev/stderr | xsel -l /dev/null -b
}
En plus, elle te met l'URL généré dans ton clipboard directement, m'enfin, un must-have
lili : Lenovo E540 | ArchLinux
abraham : RaspBerry Pi 3 B | ArchLinux
isaac : RaspBerry Pi 3 B | ArchLinux
Github
The best way to accelerate a computer running Windows is at 9.81m/s²
10 types de geeks, ceux qui savent compter en binaire, et les autres.

Répondre