[Mise à jour du sytème] Problème installation Libmariadbclient

Questions autour de l'architecture 32 bits (i686)
Répondre
tonio_31
Hankyu
Messages : 24
Inscription : jeu. 28 juil. 2016, 21:39

[Mise à jour du sytème] Problème installation Libmariadbclient

Message par tonio_31 » lun. 09 avr. 2018, 15:00

Bonjour,

J'ai un souci avec la mise à jour d'un paquet : libmariadbclient.

Code : Tout sélectionner

 erreur\u202f: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: mariadb-clients\u202f: installer libmariadbclient (10.1.32-1.0) casse la dépendance «\u202flibmariadbclient=10.1.31\u202f»
J'ai cherché sur Pacman, par Google. Mais pas trouvé de réponses.

Merci
Antoine

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2046
Inscription : jeu. 15 mars 2012, 05:08

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par waitnsea » lun. 09 avr. 2018, 17:16

tonio_31 a écrit :
lun. 09 avr. 2018, 15:00
J'ai un souci avec la mise à jour d'un paquet : libmariadbclient.

Code : Tout sélectionner

 erreur\u202f: la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: mariadb-clients\u202f: installer libmariadbclient (10.1.32-1.0) casse la dépendance «\u202flibmariadbclient=10.1.31\u202f»
J'ai cherché sur Pacman, par Google. Mais pas trouvé de réponses.
J'avoue ne trouver non plus aucune référence à u202flibmariadbclient
Tu as ce paquet dans ton /var/lib/pacman/local/ ?

JuanicoV
Daikyu
Messages : 68
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par JuanicoV » lun. 09 avr. 2018, 18:14

bonjour,

\u202F est un code unicode que l'on retrouve a 4 reprises dans ton message ( NARROW NO-BREAK SPACE) .

tu as un truc mal configuré sur le jeux de caractères dans ton systeme, je dirai que ça n'a rien a voir avec libmariadbclient.

tu as fait des modifications sur ce sujet dernierement?
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

tonio_31
Hankyu
Messages : 24
Inscription : jeu. 28 juil. 2016, 21:39

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par tonio_31 » lun. 09 avr. 2018, 18:30

Merci pour vos réponses. Je pense que cela est dû à un mauvais copier / coller du message d'erreur. J'ai bien le paquet libmariadbclient 10.1.32-1.0 qui doit remplacer libmariadbclient 10.1.31 mais cela bloque car cela casse la dépendance 10.1.31. C'est bizarre car c'est finalement une mise à jour classique, je ne vois pas pourquoi ça bloque. J'ai essayé pacman --force -Syyu mais j'ai toujours le même souci (et puis je ne sais pas si cette commande est appropriée).

Antoine

JuanicoV
Daikyu
Messages : 68
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par JuanicoV » lun. 09 avr. 2018, 19:16

\u202F est un code unicode que l'on retrouve a 4 reprises dans ton message ( NARROW NO-BREAK SPACE) .

tu as un truc mal configuré sur le jeux de caractères dans ton systeme, je dirai que ça n'a rien a voir avec libmariadbclient.
Je pense que cela est dû à un mauvais copier / coller du message d'erreur.

Souvent les explications les plus simples.... :lol:

sinon que donne

Code : Tout sélectionner

pacman -Qs maria
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par benjarobin » lun. 09 avr. 2018, 19:22

Bonjour, essaye de nouveau, ou change de mirroir...
Sinon je ne pense pas que les \u202f ne soit dû à un mauvais copier coller, mais plus à un problème de console ne gérant pas l'unicode...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

tonio_31
Hankyu
Messages : 24
Inscription : jeu. 28 juil. 2016, 21:39

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par tonio_31 » lun. 09 avr. 2018, 19:24

Le retour de la commande pacman -Qs maria est le suivant :

Code : Tout sélectionner

local/libmariadbclient 10.1.31-1.0
    MariaDB client libraries
local/mariadb 10.1.31-1.0
    Fast SQL database server, drop-in replacement for MySQL
local/mariadb-clients 10.1.31-1.0
    MariaDB client tools

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par benjarobin » lun. 09 avr. 2018, 19:25

La sortie de pacman -Ss maria aurait été bien plus interessante.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

tonio_31
Hankyu
Messages : 24
Inscription : jeu. 28 juil. 2016, 21:39

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par tonio_31 » lun. 09 avr. 2018, 19:30

OK juste une chose je suis en architecture 32 bits donc sur les dépôts dédiés à cette configuration. Y a-t-il plusieurs miroirs ?
Pour le terminal je vais regarder cela de plus près.

La commande pacman -Ss maria retourne :

Code : Tout sélectionner

extra/galera 25.3.23-1.0
    write set replication (WSREP) provider for MariaDB cluster
extra/libmariadbclient 10.1.32-1.0 [installé: 10.1.31-1.0]
    MariaDB client libraries
extra/mariadb 10.1.31-1.0 [installé]
    Fast SQL database server, drop-in replacement for MySQL
extra/mariadb-clients 10.1.31-1.0 [installé]
    MariaDB client tools
extra/mytop 10.1.31-1.0
    Top clone for MariaDB
community/innotop 1.11.4-2
    A powerful "top" clone for MySQL (MariaDB)
community/percona-server 5.7.20_19-1.0
    Drop-in replacement for MySQL that provides improved performance, diagnostics, instrumentation and TokuDB storage engine
community/percona-server-clients 5.7.20_19-1.0
    Percona Server client tools
Antoine

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par benjarobin » lun. 09 avr. 2018, 19:55

Ah, OK, en effet les dépots pour Arch Linux 32 sont juste "cassés": https://mirror.archlinux32.org/i686/extra/
Pour rappel Arch Linux 32 n'est plus officielement supporté, je te conseil de faire un rapport de bug sur le site dédié : https://archlinux32.org/

PS: Il est ultra important de préciser ce genre de détail (car ce n'est pas du tout un détail), archlinux32 n'est pas Arch Linux !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

tonio_31
Hankyu
Messages : 24
Inscription : jeu. 28 juil. 2016, 21:39

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par tonio_31 » lun. 09 avr. 2018, 20:01

D'accord merci ton retour et ta précision. Je n'ai pas vu sur le forum de section Archlinux32 qui permettrait de séparer les posts dédiés à cette architecture.

Antoine

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2046
Inscription : jeu. 15 mars 2012, 05:08

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par waitnsea » lun. 09 avr. 2018, 20:48

tonio_31 a écrit :
lun. 09 avr. 2018, 20:01
D'accord merci ton retour et ta précision. Je n'ai pas vu sur le forum de section Archlinux32 qui permettrait de séparer les posts dédiés à cette architecture.
les applis 32 mulitilib/ ne sont pas concernées mais l'architecture 32b... : https://archlinux.fr/accueil/fin-du-support-i686

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10576
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Mise à jour du sytème] Problème installation Libmariadbclient

Message par FoolEcho » mar. 10 avr. 2018, 09:06

tonio_31 a écrit :
lun. 09 avr. 2018, 20:01
Je n'ai pas vu sur le forum de section Archlinux32 qui permettrait de séparer les posts dédiés à cette architecture.
Arch ne supportant plus cette architecture nous n'avons pas vraiment de raison pour une telle rubrique (tu me diras qu'il existait bien à une époque chakra mais qui a pris son envol depuis ou arm plus récemment... et qu'on peut donner un coup de main sur tout ce qui est basé sur Arch). :P

Mais à court/moyen terme de toutes manières les distributions Linux 32 bits tendront aussi à disparaître.


P.S. Pour info, création d'une rubrique pour i686.
«The following statement is not true. The previous statement is true.» :nage:

Répondre