[reseau] systemd-networkd[clos]

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
fran
yeomen
Messages : 232
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

[reseau] systemd-networkd[clos]

Message par fran » dim. 12 janv. 2020, 19:05

bonjour
je viens de passer à systemd-networkd à la place de networkmanager ( pour tester)
J'ai une connexion en ethernet eno1
j'ai crée le fichier en suivant le wiki

Code : Tout sélectionner

/etc/systemd/network/eno1.network

[Match]
Name=eno1

[Network]
DHCP=yes
j'ai activé les services :

Code : Tout sélectionner

systemctl enable systemd-networkd.service
systemctl start systemd-networkd.service
et j'ai aussi désactivé networkmanager

Code : Tout sélectionner

systemctl disable NetworkManager
ensuite il est noté "Et puis c'est tout"
ça fonctionne très bien

Mais en bas de page du wiki , je vois une partie sur resolv.conf
est ce que je dois aussi faire cette partie du wiki ?
Si jamais je reviens à networkmanager?

Merci
Dernière modification par fran le jeu. 16 janv. 2020, 23:26, modifié 1 fois.
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

laurent85
Elfe
Messages : 613
Inscription : mar. 16 oct. 2018, 21:05

Re: [reseau] systemd-networkd

Message par laurent85 » dim. 12 janv. 2020, 21:02

Bonjour,
fran a écrit :
dim. 12 janv. 2020, 19:05
Mais en bas de page du wiki , je vois une partie sur resolv.conf
est ce que je dois aussi faire cette partie du wiki ?
Vérifie où pointe actuellement /etc/resolv.conf , et fais-le si ça ne pointe pas sur le bon fichier de configuration.

Code : Tout sélectionner

readlink /etc/resolv.conf
Si jamais je reviens à networkmanager?
Si NM ne corrige pas il faudra le faire manuellement, pointer sur le bon fichier sous /run/NetworkManager
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

Avatar de l’utilisateur
fran
yeomen
Messages : 232
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [reseau] systemd-networkd

Message par fran » lun. 13 janv. 2020, 12:27

bonjour
quand je fais

Code : Tout sélectionner

readlink /etc/resolv.conf
ça ne me retourne rien
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1140
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [reseau] systemd-networkd

Message par karhu » lun. 13 janv. 2020, 16:19

C'est parce c'est un fichier et non un lien symbolique. :P
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
fran
yeomen
Messages : 232
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [reseau] systemd-networkd

Message par fran » lun. 13 janv. 2020, 18:38

Bon , j'ai trouvé une réponse à ma question initiale .
J'ai fait une copie.bak du fichier resolv.conf de networkmanager .
puis

Code : Tout sélectionner

systemctl stop systemd-networkd
systemctl disable systemd-networkd
et en refaisant

Code : Tout sélectionner

systemctl enable systemd-networkd
systemctl start systemd-networkd
ça m'a crée un nouveau fichier /etc/resolv.conf
et j'ai ensuite lancé

Code : Tout sélectionner

systemctl enable systemd-resolved.service
systemctl start systemd-resolved.service
rm /etc/resolv.conf
ln -s /run/systemd/resolve/resolv.conf /etc/resolv.conf
et donc ça devrait etre bon

Code : Tout sélectionner

[franck@intelnuc ~]$ readlink /etc/resolv.conf
/run/systemd/resolve/resolv.conf
[franck@intelnuc ~]$ 
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

Avatar de l’utilisateur
fran
yeomen
Messages : 232
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [reseau] systemd-networkd

Message par fran » jeu. 16 janv. 2020, 11:13

Finalement je suis revenu sur networkmanager .
Avec systemd-networkd , les pages mettaient un laps de temps de environ 10 à 20 secondes pour s'ouvrir , même pour accéder à archlinux.fr par exemple .
Je n'en connais pas la cause
ça fonctionne plus normalement avec networkmanager .
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

Répondre