[subversion] Pb migration dépôt windows vers dépôt linux

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
cassyb
Chu Ko Nu
Messages : 310
Inscription : jeu. 04 janv. 2007, 09:07

[subversion] Pb migration dépôt windows vers dépôt linux

Message par cassyb » mar. 17 janv. 2012, 04:45

Bonjour,

Je souhaite migrer un serveur subvserion de windows vers linux (Red Hat).
On travaille sur des postes windows, on utilise soit Tortoise, soit Subclispe en client svn (plugin subversion pour Eclipse). Nos EDI sont configurés pour utiliser l'encodage utf-8.

Le problème quand on fait un checkout en pointant vers le nouveau dépôt subversion sur le serveur linux, on a des problèmes d'accents.
Ce problème d'accent disparait si on configure nos EDI en ISO-8859-1

La commande

Code : Tout sélectionner

locale
sur linux renvoie:
LANG=fr_FR
LC_CTYPE="fr_FR"
LC_NUMERIC="fr_FR"
LC_TIME="fr_FR"
LC_COLLATE="fr_FR"
LC_MONETARY="fr_FR"
LC_MESSAGES="fr_FR"
LC_PAPER="fr_FR"
LC_NAME="fr_FR"
LC_ADDRESS="fr_FR"
LC_TELEPHONE="fr_FR"
LC_MEASUREMENT="fr_FR"
LC_IDENTIFICATION="fr_FR"
LC_ALL=
et la commande

Code : Tout sélectionner

cat /etc/sysconfig/i18n
LANG="fr_FR"
SUPPORTED="fr_FR.UTF-8:fr_FR:fr"
SYSFONT="latarcyrheb-sun16"
Quand on édite un fichier, ou en exportant un fichier du dépôt, il n'y a aucun problème d'accent sur le serveur linux même si la commande

Code : Tout sélectionner

file -i
ne renvoie aucun encoding.
Si je crée un nouveau fichier encodé en utf-8 à l'export je n'ai aucun soucis.

Mon problème vient du svnadmin dump qui semble perdre l'encodage...
Je vais essayer d'utiliser iconv pour convertir le dump en utf-8, voir si ça un impact sur les binaires.
Mais si vous voyez d'autres pistes...
Merci pour votre aide.

Avatar de l’utilisateur
la_poigne
yeomen
Messages : 215
Inscription : dim. 22 févr. 2009, 09:20

Re: [subversion] Pb migration dépôt windows vers dépôt linux

Message par la_poigne » mar. 17 janv. 2012, 07:23

Salut,

ton serveur linux n'est pas en utf8, donc c'est normal.
En utf8 tu devrais avoir partout fr_FR.UTF-8.

Avatar de l’utilisateur
cassyb
Chu Ko Nu
Messages : 310
Inscription : jeu. 04 janv. 2007, 09:07

Re: [subversion] Pb migration dépôt windows vers dépôt linux

Message par cassyb » mar. 17 janv. 2012, 08:40

en faisant ça, les accents en console ne passent plus (double encodage utf8 genre é pour é)
J'ai fait un checkout, j'ai toujours le même problème.
Du coup j'ai crée un nouveau dépôt, j'ai réimporté mon dump, puis fait un checkout...toujours ce problème d'accent.

Avatar de l’utilisateur
xanataz
archer de cavalerie
Messages : 155
Inscription : mar. 04 août 2009, 23:30

Re: [subversion] Pb migration dépôt windows vers dépôt linux

Message par xanataz » mer. 18 janv. 2012, 22:04

Code : Tout sélectionner

windows vers linux (Red Hat).
? Es-tu sur d'avoir posté sur le bon forum ?
"Plus les choses sont carré, plus elles tournent rond"

Répondre