[Logiciel] Installation DVD Styler (Résolu)

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
tos69400
Daikyu
Messages : 98
Inscription : sam. 07 juil. 2012, 15:02

[Logiciel] Installation DVD Styler (Résolu)

Message par tos69400 »

Bonjour,
Je viens vers vous car suite à mon retour de vacances, je veux réaliser le dvd de mariage d'amis à moi.
La vidéo est prête mais reste à réaliser le dvd. Et là, c'est le drame : impossible d'installer DVD Styler.
Voici l'erreur lors de la compilation :

Code : Tout sélectionner

checking for wxSVG library with FFMPEG support... no
configure: error: 
    DVDStyler requires the wxSVG library with FFMPEG support.
J'ai parcouru le dépôt sur AUR et pas trouvé d'informations dans les commentaires.
J'ai essayé avec l'installation de libav et ffmpeg-git et toujours des erreurs.

Help please.
Dernière modification par tos69400 le mar. 21 août 2012, 12:46, modifié 1 fois.
ArchLinux + CK Kernel + Gnome.
Systemd en cours de transition ...
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10624
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Logiciel] Installation DVD Styler

Message par FoolEcho »

Je n'ai pas cherché plus que ça pour ce qui est des versions proposées sur Aur (avec juste les dépendances indiquées: ffmepg, pas de libav) mais je n'ai pas ton erreur en tous cas, même si ça ne compile pas:

Code : Tout sélectionner

mediaenc_ffmpeg.cpp: In member function ‘virtual bool wxFfmpegMediaEncoder::BeginEncode(const wxString&, VideoFormat, AudioFormat, AspectRatio, int)’:
mediaenc_ffmpeg.cpp:95:41: erreur: ‘av_set_parameters’ was not declared in this scope
mediaenc_ffmpeg.cpp:110:53: erreur: ‘URL_WRONLY’ was not declared in this scope
mediaenc_ffmpeg.cpp:116:15: erreur: ‘struct AVFormatContext’ has no member named ‘mux_rate’
mediaenc_ffmpeg.cpp:117:15: erreur: ‘struct AVFormatContext’ has no member named ‘preload’
mediaenc_ffmpeg.cpp:119:29: erreur: ‘av_write_header’ was not declared in this scope
Peu importe.

Par contre, j'ai fait l'essai avec la version de développement de dvdstyler (2.3) et wxsvg (1.1.9), ça compile chez moi.
Tu peux essayer en modifiant le PKGBUILD de wxsvg:

Code : Tout sélectionner

pkgver=1.1.9
...
md5sums=('f84f5d4f04db36712c7d7f5cb620efe0')
et celui de dvdstyler:

Code : Tout sélectionner

pkgname=dvdstyler-devel
pkgver=2.3rc2
source=(http://sourceforge.net/projects/dvdstyler/files/dvdstyler-devel/${pkgver}/DVDStyler-${pkgver}.tar.bz2)
sha1sums=('6df396b76054ed6b3c8ebf2c96775efe09e7657e')
provides=('dvdstyler')
conflicts=('dvdstyler')
replaces=('dvdstyler')

#dans build(): j'ai enlevé tous les seds sauf celui traitant de libwxvilla/libjpeg
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
tos69400
Daikyu
Messages : 98
Inscription : sam. 07 juil. 2012, 15:02

Re: [Logiciel] Installation DVD Styler

Message par tos69400 »

Merci Foolecho, je testerai dès que je serais sur le PC.
Pour mon info : où trouver les md5sums. Je cherche à modifier le PKGBuild de heimdall (afin d'utiliser la 1.3.1) mais comment trouver le md5sums ?
(J'éditerai mon post ce soir après test des manips proposées).

Edit (comme convenu) : la manip pour compilation de wxsvg n'a pas fonctionné. Erreur lors de la compilation du paquet :
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.1/../../../../lib/libavformat.a: could not read symbols: Bad value

Message complet lors de la compilation : http://pastebin.archlinux.fr/449560

Bien entendu pas possible de compiler DVD Styler car wxsvg en version 1.1.9 est une dépendance non satisfaite.
Je suis donc bloqué.
Dernière modification par tos69400 le lun. 20 août 2012, 21:19, modifié 1 fois.
ArchLinux + CK Kernel + Gnome.
Systemd en cours de transition ...
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10624
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Logiciel] Installation DVD Styler

Message par FoolEcho »

Les sommes de contrôle peuvent être disponibles depuis le site d'où provient l'archive, ou sinon tu utilises makepkg -g ou directement md5sum.
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
tos69400
Daikyu
Messages : 98
Inscription : sam. 07 juil. 2012, 15:02

Re: [Logiciel] Installation DVD Styler

Message par tos69400 »

Edit de mon message car erreur lors de la compilation.

Il semblerait que l'erreur de compilation de wxsvg vienne de la version de ffmpeg installée.
Trouvé dans le code lors de la compilation : recompile with -fPIC

Faut-il donc que je recompile ffmpeg ?
J'avais la version ffmpeg-git d'installée lors de ce premier essai. Je le désinstalle et install ffmpeg (depuis le dépôt officiel pour tester).

Je continue à me battre et je ne compte pas laisser tomber. Compilation et installation réussi de wxsvg en v1.1.9 (avec ffmpeg depuis les dépôts).
Maintenant toujours pas possible de compiler dvdstyler : http://pastebin.archlinux.fr/449562
ArchLinux + CK Kernel + Gnome.
Systemd en cours de transition ...
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10624
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Logiciel] Installation DVD Styler

Message par FoolEcho »

tos69400 a écrit : Compilation et installation réussi de wxsvg en v1.1.9 (avec ffmpeg depuis les dépôts).
C'est ce que j'ai dit, ffmpeg des dépôts.
tos69400 a écrit :Maintenant toujours pas possible de compiler dvdstyler
Pareil, je l'ai dit. Je l'ai compilé en faisant sauter les différents sed sauf un:

Code : Tout sélectionner

build() {
  cd "${srcdir}/DVDStyler-${pkgver}"
  ./configure --prefix=/usr
  sed -i 's/libwxvilla.a/libwxvilla.a \/usr\/lib\/libjpeg.so.8/' src/Makefile
  make
}
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
tos69400
Daikyu
Messages : 98
Inscription : sam. 07 juil. 2012, 15:02

Re: [Logiciel] Installation DVD Styler

Message par tos69400 »

1000 merci.
En fait j'avais supprimé les sed se trouvant avant celui à conserver mais pas ceux après.

Installation réussie enfin.
ArchLinux + CK Kernel + Gnome.
Systemd en cours de transition ...
Répondre