[DHCPCD CIFS] Erreur au démarrage

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
Tetsumaki
archer
Messages : 141
Inscription : jeu. 06 mai 2010, 05:44
Contact :

[DHCPCD CIFS] Erreur au démarrage

Message par Tetsumaki » lun. 07 janv. 2013, 00:48

Contexte :
- Une installation toute fraîche ArchLinux x86_64
- Serveur DHCP de la Freebox Révolution.
- Systemd
- Un raid sous samba

Les logs :

# journalctl -b -p err

Code : Tout sélectionner

-- Logs begin at mar., 2013-01-01 22:51:59 CET, end at lun., 2013-01-07 00:54:06 CET. --
janv. 07 00:52:21 tetsu-arch dhcpcd[316]: eth0: sendmsg: Cannot assign requested address
janv. 07 00:52:22 tetsu-arch kernel: CIFS VFS: Error connecting to socket. Aborting operation
janv. 07 00:52:22 tetsu-arch kernel: CIFS VFS: cifs_mount failed w/return code = -101
janv. 07 00:52:22 tetsu-arch systemd[1]: Failed to mount /mnt/raid.
janv. 07 00:52:22 tetsu-arch systemd[1]: Dependency failed for Remote File Systems.
janv. 07 00:52:26 tetsu-arch gdm-launch-environment][434]: GLib-CRITICAL: g_variant_compare: assertion `!g_variant_is_container (a)' failed
janv. 07 00:52:26 tetsu-arch gdm-launch-environment][434]: GLib-CRITICAL: g_variant_compare: assertion `!g_variant_is_container (a)' failed
janv. 07 00:52:36 tetsu-arch kernel: radeon 0000:01:00.0: object_init failed for (9338880, 0x00000006)
janv. 07 00:52:36 tetsu-arch kernel: [drm:radeon_gem_object_create] *ERROR* Failed to allocate GEM object (9338880, 4, 8192, -12)
janv. 07 00:52:36 tetsu-arch kernel: [drm:radeon_cs_ioctl] *ERROR* Failed to parse relocation -12!
janv. 07 00:53:54 tetsu-arch gnome-session[446]: CRITICAL: gsm_manager_set_phase: assertion `GSM_IS_MANAGER (manager)' failed
janv. 07 00:53:55 tetsu-arch pulseaudio[689]: [pulseaudio] pid.c: Daemon already running.
# systemctl status mnt-raid.mount

Code : Tout sélectionner

mnt-raid.mount - /mnt/raid
	  Loaded: loaded (/etc/fstab)
	  Active: failed (Result: exit-code) since lun., 2013-01-07 00:23:11 CET; 13min ago
	   Where: /mnt/raid
	    What: //192.168.1.2/raid
	 Process: 352 ExecMount=/bin/mount //192.168.1.2/raid /mnt/raid -t cifs -o _netdev,uid=tetsumaki,credentials=/etc/cifs.credentials (code=exited, status=32)
	  CGroup: name=systemd:/system/mnt-raid.mount
Après le boot je dois donc monter mon raid à la main systemctl start mnt-raid.mount.
De l'aide serait bien sympa.
Merci d'avance.

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [DHCPCD CIFS] Erreur au démarrage

Message par benjarobin » lun. 07 janv. 2013, 09:29

Donc ce n'est pas un RAID que tu monte mais un disque réseau. Ton autre message portait à confusion.

Comment tu te connectes au réseau, quel daemon tu utilises ? Et peux tu donner le : "systemctl status" de ce daemon (en root pour avoir les logs)

Mais sinon une solution est de rajouter les options

Code : Tout sélectionner

noauto,x-systemd.automount
à la ligne de ton fstab, cela aurait pour effet de monter la partition uniquement lors de la première tentative d'accès au disque
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
z3bra
archer
Messages : 127
Inscription : jeu. 28 juin 2012, 23:17

Re: [DHCPCD CIFS] Erreur au démarrage

Message par z3bra » lun. 07 janv. 2013, 13:44

Tiens, j'utilise « systemd.automount » moi… C’est quoi la différence avec x-systemd ?
archlinux - 2bwm [ blog | git ]

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [DHCPCD CIFS] Erreur au démarrage

Message par benjarobin » lun. 07 janv. 2013, 13:46

Tu veux dire comment=systemd.automount ? Si oui je crois que c'est la même chose, sinon aucune idée, j'ai juste regardé le Wiki
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
z3bra
archer
Messages : 127
Inscription : jeu. 28 juin 2012, 23:17

Re: [DHCPCD CIFS] Erreur au démarrage

Message par z3bra » lun. 07 janv. 2013, 13:49

Ouais c'est ça. J'utilise ça pour monter des partages windows justement (en CIFS donc).
archlinux - 2bwm [ blog | git ]

Avatar de l’utilisateur
Tetsumaki
archer
Messages : 141
Inscription : jeu. 06 mai 2010, 05:44
Contact :

Re: [DHCPCD CIFS] Erreur au démarrage

Message par Tetsumaki » dim. 27 janv. 2013, 03:03

benjarobin excuses de ne répondre que maintenant, j'ai cru qu'on m'avait oublié étant donné que je n'avais pas coché la case magique "M'avertir lorsqu'une réponse a été publiée" ! oups :oops:

Ta solution a parfaitement fonctionné en ajoutant noauto,x-systemd.automount dans mon /etc/fstab
Ca qui donne pour la ligne du montage dans /etc/fstab :

Code : Tout sélectionner

//192.168.1.2/raid      /mnt/raid       cifs    _netdev,noauto,x-systemd.automount,sec=ntlmv2,uid=tetsumaki,credentials=/etc/cifs.credentials      0 0
Comme tu me l'a demandé plus haut voici le rapport de systemctl status dhcpcd@eth0 :

Code : Tout sélectionner

dhcpcd@eth0.service - dhcpcd on eth0
	  Loaded: loaded (/usr/lib/systemd/system/dhcpcd@.service; enabled)
	  Active: active (running) since dim. 2013-01-27 02:44:42 CET; 2min 21s ago
	 Process: 320 ExecStart=/usr/sbin/dhcpcd -q -w %I (code=exited, status=0/SUCCESS)
	Main PID: 392 (dhcpcd)
	  CGroup: name=systemd:/system/dhcpcd@.service/eth0
		  └─392 /usr/sbin/dhcpcd -q -w eth0

janv. 27 02:44:38 tetsu-arch dhcpcd[320]: eth0: waiting for carrier
janv. 27 02:44:40 tetsu-arch dhcpcd[320]: eth0: carrier acquired
janv. 27 02:44:40 tetsu-arch dhcpcd[320]: eth0: sending IPv6 Router Solicitation
janv. 27 02:44:40 tetsu-arch dhcpcd[320]: eth0: sendmsg: Cannot assign requested address
janv. 27 02:44:40 tetsu-arch dhcpcd[320]: eth0: rebinding lease of 192.168.1.1
janv. 27 02:44:42 tetsu-arch dhcpcd[320]: eth0: Router Advertisement from fe80::f6ca:e5ff:fe45:bcf7
janv. 27 02:44:42 tetsu-arch systemd[1]: Started dhcpcd on eth0.
janv. 27 02:44:45 tetsu-arch dhcpcd[392]: eth0: acknowledged 192.168.1.1 from 192.168.1.254
janv. 27 02:44:45 tetsu-arch dhcpcd[392]: eth0: checking for 192.168.1.1
janv. 27 02:44:50 tetsu-arch dhcpcd[392]: eth0: leased 192.168.1.1 for 43200 seconds
J'ai le message en rouge : eth0: sendmsg: Cannot assign requested address
Tout m'a l'air de fonctionner correctement tout de même mais faut t'il y faire quelque chose tout de même ?

Répondre