[Samba partage local] Problème de configuration samba simple

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

[Samba partage local] Problème de configuration samba simple

Message par Seym » ven. 27 sept. 2013, 13:43

Bonjour tout le monde,

En suivant le wiki et d'autres documentations sur le net, j'ai configuré mon serveur samba pour partager des dossier entre les ordis connectés sur ma freebox.
Ça a marché à un moment donné, mais plus maintenant, et je n'arrive pas à savoir pourquoi. Voici mon smbd.conf :

Code : Tout sélectionner

#======================= Global Settings =====================================
[global]
 workgroup = WORKGROUP
 server string = GokuSamba
 security = user
 map to guest = Bad User
 netbios name = goku
 name resolve order = hosts wins bcast
 wins support = yes
#============================ Share Definitions ==============================
[public]
 path = /home/seym/Public
 available = yes
 browsable = yes
 public = yes
 writable = yes
Smbd est bien lancé, et lorsque j'essaye de monter le partage via la commande suivante :

Code : Tout sélectionner

gvfs-mount smb://GOKU/public
J'ai le message d'erreur suivant :

Code : Tout sélectionner

Erreur lors du montage de l'emplacement : Impossible de monter le partage Windows : Argument invalide
Merci d'avance

Edit : Titre édité
Dernière modification par Seym le lun. 25 nov. 2013, 17:31, modifié 2 fois.

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: Problème de configuration samba simple

Message par Ypnose » ven. 27 sept. 2013, 13:48

Commençons avec de bonnes bases: http://wiki.archlinux.fr/Forum#Format_du_titre

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [Samba partage local] Problème de configuration samba si

Message par Seym » lun. 25 nov. 2013, 17:32

Un petit up car je n'ai toujours pas la solution.

lm28
Hankyu
Messages : 41
Inscription : mer. 13 nov. 2013, 10:45

Re: [Samba partage local] Problème de configuration samba si

Message par lm28 » lun. 25 nov. 2013, 19:00

salut, j'avais le même problème que toi, des que je redémarrer plus rien !!!!!!, les fichiers mis en partages ne voulait plus se partager (film, musiques,doc)...........mais le problème doit certainement venir de samba, parceque lorsque j’étais sur la famille debian, ubunt, mint c’était la même choses, donc comme je n'est jamais trouver de solution j'ai installer XBMC pour contourner le problème, une fois XBMC installer, tu vas dans "systeme", "services" et "upnp" tu coche les 3 cases, et la va sur ta freebox dans section mon disque et tu va voir apparaitre XBMC en dessous du disque dure dans le player.......j’espère que cela peut aider.......

menthe
newbie
Messages : 8
Inscription : lun. 25 nov. 2013, 14:45

Re: [Samba partage local] Problème de configuration samba si

Message par menthe » lun. 25 nov. 2013, 20:17

Salut

voilà un fichier de configuration plus propre :

Code : Tout sélectionner

[global]
   workgroup = WORKGROUP
   server string = %h server
   netbios name = GOKU
   dns proxy = no
   log file = /var/log/samba/log.%m
   max log size = 1000
   syslog = 0
   panic action = /usr/share/samba/panic-action %d
   security = user
   encrypt passwords = true 
   passdb backend = tdbsam
   obey pam restrictions = yes
   unix password sync = yes
   passwd program = /usr/bin/passwd %u
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   pam password change = yes
   map to guest = bad user
   usershare allow guests = yes

[Public]
   path =/home/seym/Public
   read only = no
   locking = no
   guest ok = yes
   force user = seym
ensuite rentre cette commande :

Code : Tout sélectionner

sudo smbpasswd -a seym
sudo systemctl stop smbd
sudo systemctl stop nmbd
sudo systemctl start nmbd
sudo systemctl start smbd
pour les démarrer automatiquement au boot :

Code : Tout sélectionner

sudo systemctl enable nmbd
sudo systemctl enable smbd
ça devrait ensuite fonctionner proprement.

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [Samba partage local] Problème de configuration samba si

Message par Seym » mar. 26 nov. 2013, 11:38

En effet, ça marche nickel maintenant, merci beaucoup!

Tu as une idée de ce qui n'allait pas en particulier? Par ce que dans les exemples de la doc ils ne donnaient pas autant de paramètres, de plus avant ça marchait.


EDIT : Par contre mon partage n'est pas visible depuis Windows, vous savez comment y remédier?

menthe
newbie
Messages : 8
Inscription : lun. 25 nov. 2013, 14:45

Re: [Samba partage local] Problème de configuration samba si

Message par menthe » mar. 26 nov. 2013, 12:39

Salut :)

D'après moi la cause du dysfonctionnement peut venir soit de la casse dans le netbios name, soit de ton name resolve order (c'est un peu casse gueule ce paramètre si la configuration des services annexes n'est pas rigoureuse parce que parfois une simple mise à jour peut tout casser) et enfin dernière possibilité tu a peut-être démarré le deamon smbd mais pas nmdb.

Bien sûr ce sont des présomptions, et j'opterais plutôt pour la première possibilité ^_^

Pour information tu peux partir de ce fichier de configuration comme base pour un serveur NAS maison avec partage samba :)

PS : simple suggestion mais si tu veux un bon système de partage de fichiers regarde aussi du côté de NFS (http://wiki.archlinux.fr/NFS) c'est un bon complément de samba, notamment pour un NAS.

Voilà voilà je suis content d'avoir pu t'aider et je te souhaite une bonne journée :)

EDIT : j'ai changé le paramètre Server string dans le fichier de config donc sur ton réseau windows ton partage devrait porter le nom %h server (Goku) avec %h le hostname de ta machine que tu devrais avoir toi même défini et que tu trouveras avec la commande :

Code : Tout sélectionner

cat /etc/hostname
si tu ne l'a pas encore défini (ce dont je doute (^^), utilise la commande suivante en remplaçant %h par le nom que tu veux donner à ta machine :

Code : Tout sélectionner

sudo echo %h > /etc/hostname
dis moi si ça résout ton soucis.

Avatar de l’utilisateur
Seym
Hankyu
Messages : 27
Inscription : sam. 09 avr. 2011, 13:14

Re: [Samba partage local] Problème de configuration samba si

Message par Seym » mer. 27 nov. 2013, 15:06

Salut,

J'ai enlevé la ligne renseignant le netbios name, celui prenant donc par défault la valeur de mon hostname, qui est bien tout en minuscule, les démons smbd et nmbd sont bien activés, et j'utilise NFS via avahi.
Pourtant, sur le réseau de mon labo, même si j'arrive bien à voir les autres postes connectés, je n'arrive toujours pas à être visible depuis un poste Windows. Je n'ai pas encore essayé chez moi, je le ferai ce soir.

Pour samba, j'ai lu sur le net qu'a partir de Windows 7, il fallait faire une manip sur le registre Windows pour que le poste concerné puisse voir le partage. Mais ça ne m'intéresse pas car je veux que n'importe qui sur le réseau puisse voir mes fichiers sans faire de manip de geek. Après je ne sais pas si ce problème est toujours d'actualité ou si j'ai juste un problème dans ma config.
Après il y a wins support, mais il me semble que c'est plutôt pour un réseau domestique (et je veux que ça marche aussi à mon taf).

Après il y a NFS, que j'ai configuré sans souci, mais apparemment (dites-moi si je me trompe), il faut monter explicitement mon partage depuis un poste Windows pour y accéder, or je veux que le partage soit directement visible dans le réseau.

Voilà, désolé pour le pavé. En tout cas merci, je suis déjà content de pouvoir accéder au réseau au taf et de partager des fichiers entre mes postes linux chez moi. Mais c'est sur qu si je pouvais être visible directement depuis W7 ça serait cool.

menthe
newbie
Messages : 8
Inscription : lun. 25 nov. 2013, 14:45

Re: [Samba partage local] Problème de configuration samba si

Message par menthe » sam. 30 nov. 2013, 11:37

Salut,

bizarre depuis mon poste win 7 j'arrive à accéder à mon partage samba sans rien toucher à la configuration :d
Essaie de rajouter la ligne ci dessous à ton fichier de configuration dans la partie [global] :

Code : Tout sélectionner

wins support = yes
Ensuite pour valider les changements fais un restart sur samba avec :

Code : Tout sélectionner

sudo systemctl restart smbd
sudo systemctl restart nmbd
Tiens moi au courant sur ce que ça te donne :)

Cordialement.

Répondre