[Internet] Connexion eth0 une fois sur deux

Applications, problèmes de configuration réseau
Répondre
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

[Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Bonjour à tous !

Ayant réussi avec succès mon installation d'Arch, je choisi de prendre NetworkManager comme gestionnaire de connexion. Tout marche bien pour l'installation et la configuration. Mais cependant, l'interface eth0 (enp2s0 en vrai...) ne démarre pas toujours. Le wifi est par contre correctement pris en compte à chaque fois.

Lorsqu'eth0 n'est pas présent
Pour le ifconfig -a :

Code : Tout sélectionner

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.13  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::7e4f:b5ff:fe91:bf03  prefixlen 64  scopeid 0x20<link>
        ether 7c:4f:b5:91:bf:03  txqueuelen 1000  (Ethernet)
        RX packets 6914  bytes 5088289 (4.8 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6514  bytes 937740 (915.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Pas de eth0 donc...
Pour lspci j'ai :

Code : Tout sélectionner

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 315M] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
La carte wifi est donc bien prise en compte.


Et lorsque eth0 est détécté j'ai
ifconfig -a

Code : Tout sélectionner

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.11  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::ba70:f4ff:fe63:2fb1  prefixlen 64  scopeid 0x20<link>
        ether b8:70:f4:63:2f:b1  txqueuelen 1000  (Ethernet)
        RX packets 126  bytes 131791 (128.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 136  bytes 18679 (18.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.13  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::7e4f:b5ff:fe91:bf03  prefixlen 64  scopeid 0x20<link>
        ether 7c:4f:b5:91:bf:03  txqueuelen 1000  (Ethernet)
        RX packets 76  bytes 12939 (12.6 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 45  bytes 4385 (4.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
et lspci :

Code : Tout sélectionner

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 315M] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
Quelqu'un aurait-il une idée sur la raison de la présence ou non de

Code : Tout sélectionner

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
?

Merci bien !

Est-ce que la réponse est à chercher dans le wiki https://wiki.archlinux.fr/NetworkManager, sur le Networkmanager-wait-online ? J'ai pas bien compris ce passage du wiki.

Ps : ce n'est pas comme ce sujet topic6039.html, mais bien un autre problème.
Dernière modification par GwendalDurdik le mar. 26 août 2014, 15:11, modifié 2 fois.
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Internet] Connexion eth0 une fois sur deux

Message par benjarobin »

Bonsoir,
Sujet intéressant... Alors ton problème n'est absolument pas lié à un gestionnaire de connexion (par exemple Networkmanager).
Que ton interface n’apparaisse pas via ifconfig n'est pas ma plus grosse inquiétude : souvent la raison et le non chargement du module réseau associé. En effet mon inquiétude se porte sur la disparition du contrôleur réseau, du point de vue de lspci : 02:00.0 Ethernet controller...
Et si la carte réseau n'est pas listé par lspci, le kernel ne la voyant pas, aucune interface "eth0" n'apparaitra...

Peux tu donner (via pastebin ou service du même genre) la sortie de dmesg quand cela fonctionne et inversement ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

OK donc bon signe pour moi ca si c'est pas lié à networkmanager ou dhcpcd/etc. J'avais peur de m'être planté dans une manip'.

Quand eth0 fonctionne :
dmesg (ou la commande qui fait peur)
http://pastebin.com/Lb87ZbPt

Quand eth0 fonctionne pas :
http://pastebin.com/sw8eRnYh
(le nom de la page est "avec eth0" mais c'est bien sans eth0 fonctionnel, erreur de ma part.)
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Internet] Connexion eth0 une fois sur deux

Message par benjarobin »

Les différences importantes sont :
Tu as cette ligne en plus quand cela ne fonctionne pas

Code : Tout sélectionner

ACPI : EC: GPE storm detected(9 GPEs), transactions will use polling mode
Sinon quand tout fonctionne normalement

Code : Tout sélectionner

pci 0000:02:00.0: [10ec:8136] type 00 class 0x020000
pci 0000:02:00.0: reg 0x10: [io  0xd000-0xd0ff]
pci 0000:02:00.0: reg 0x18: [mem 0xf2104000-0xf2104fff 64bit pref]
pci 0000:02:00.0: reg 0x20: [mem 0xf2100000-0xf2103fff 64bit pref]
pci 0000:02:00.0: supports D1 D2
pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:02:00.0: System wakeup disabled by ACPI
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Pour moi, dmseg c'est de l'ancien russe traduit par un chinois martien.

Sinon, depuis un check up lors d'un reboot (qui se fait tout les X reboot), je n'ai visiblement plus de problème. Ca a à voir ?
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Internet] Connexion eth0 une fois sur deux

Message par benjarobin »

Non... Sinon je ne saurais expliquer ton problème... Sinon dmseg ce n'est que de l'anglais :copain:
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1507
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [Internet] Connexion eth0 une fois sur deux

Message par mimile »

Salut,

Je ne sais si cela joue un rôle mais mon eth0 est devenu enp3s0 (et non enp2s0).

Je signale que je n'ai qu'une seule carte ethernet qui voici quelques mois s'appelait eth0.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Je n'ai plus de problème. Je ne sais pas comment ni pourquoi ca remarche bien...

Je mets en résolu. Je ré-ouvrirai le sujet si le problème se représente.

Mon eth0 est bien toujours enp2s0 par contre. (Mais wlan0 est wlp3s0). La magie des réseaux <3

Merci Benjarobin et mimile :)


EDIT : Ah bah non en faite c'est pas résolue x) Ca m'a refait le coup juste là.
Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [Internet] Connexion eth0 une fois sur deux

Message par Moviuro »

Donne nous la sortie de lsmod dans les deux cas (modules noyaux) (aucune idée si ça aidera vraiment, mais bon, ça va faire remonter le sujet dans les sujets actifs ;) )
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Internet] Connexion eth0 une fois sur deux

Message par benjarobin »

Non cela n'aidera pas (enfin je pense) car le scan du lien PCI est indépendant du chargement des modules (sauf si je ne vois pas un truc...)
Hors ici le problème c'est que le contrôleur réseau n'est même pas vu sur le lien PCI...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Visiblement, ce n'est pas que lors du boot que la reconnaissance ne se fait pas.
En cours de session, sans connexion, je lance ifconfig et j'ai les 3 OK (eth0, lo, wlan0). Je me connecte au Wifi sans problème. Puis plus tard je branche un câble : absence de eth0... Pas de reconnaisance du câble. Comme si le branchement "effacait" la reconnaissance de eth0. Ca se peut un truc comme ca ou c'est un hazard ?
Et quand je lance :

Code : Tout sélectionner

sudo ifconfig enp2s0 up
j'obtiens :

Code : Tout sélectionner

enp2s0: ERROR while getting interface flags: No such device
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Une nouvelle information : ca me fait pareil sous ubuntu, en trial boot.

Sinon, est-ce qu'il existe un moyen de refaire un tour des périphériques (ou je sais pas comment ca s'apelle) qui permette de "voir" ma carte ethernet sans avoir à reboot à chaque fois ?

PS : désolé pour le double post.
Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [Internet] Connexion eth0 une fois sur deux

Message par Moviuro »

Regarde ce que dit dmesg -w ou journalctl -f quand ça plante.
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Bonjour,

Tout marchait depuis mon dernier post, jusqu'à ce qu'aujourd'hui je décide de "suspendre" ma session (avec xfce4). Au retour, plus de enp2s0... Reboot : ca remarche.
Et là, après un nouvel allumage, ca ne remarchait plus.

Le dmesg -w quand pas eth0 :
http://pastebin.com/xr59DLRG

Le journalctl -f quand pas eth0 :
http://pastebin.com/Q6fHE5sj
Les dernières lignes sont je pense parce que j'ai ouvert un autre terminal en même temps. (raah mon identité est percée !!)

D'après ce que je vois, dhcpcd n'est pas vraiment absent, alors que je l'ai bien normalement désactivé au démarrage (systemctl disable dhcpcd). C'est normal ca ?
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Y'a du nouveau :bravo: Depuis le changement d'heure je ne peux plus du tout me connecter ! :D Même quand eth0 est là...
Mon truc de connexion tourne, mais n'arrive pas à obtenir d'adresse IP. Je reçoit bien toute les requêtes qui passe sur le réseaux par contre, mais j'envoie rien.
Est-ce que le changement d'heure peux avoir un impact la dessus ?

Même sous windows ca marche plus... Rien de rien pour internet maintenant... C'est bien y'a du progès.
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Internet] Connexion eth0 une fois sur deux

Message par benjarobin »

Franchement cela à tous les symptômes d'un problème matériel... Mais difficile d'en être 100% sure.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

C'est revenu à la normale...
En effet je penche de plus en plus vers le problème matériel tant c'est illogique.
Sujet mi-clos, si quelqu'un a une idée... Sinon je vais vivre avec pas de problème, un reboot ca prend pas trop de temps x)

Merci à tous en tout cas !
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Visiblement ce n'était pas un problème matériel. Depuis que j'ai désinstallé laptop-mode-tool ca marche nickel. Un rapport ? pourquoi ? mauvaise config de laptop mode ? (Arpès réflection les problèmes sont apparu à peu près en même temps que l'installation de laptop mode tool, mais je ne me souviens plus exactement)
Il ne subsiste qu'un problème : quand par manque de batterie l'ordi se met en veille (ok normal), lorsque je le "rallume" impossible de se connecté à Eth0 ("Device not found") et je dois redémarrer pour qu'elle soit réactivée.
Moviuro
Elfe
Messages : 765
Inscription : dim. 17 juin 2012, 22:49
Contact :

Re: [Internet] Connexion eth0 une fois sur deux

Message par Moviuro »

Laptop-mode-tools doit faire entrer eth0 en mode économie d'énergie (et donc, ça coupe).
psycho : Latitude E6430 ; BTRFS over LUKS, UEFI & secureboot
schizo : Acer 8942G ; KDE 4, BTRFS over LUKS ; W7 (prend la poussière)
toxo : i5-6600K, bspwm, VM W10 en PCI-passthrough
deadman : Lenovo Thinkcenter, OpenBSD 6.0-stable
popho.be : Kimsufi KS-3, FreeBSD 11.0
Loi de Murphy : Le jour où tu as besoin d'une backup, tu te dis que tu aurais dû en mettre en place
Venez sur IRC en plus du forum !
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [Internet] Connexion eth0 une fois sur deux

Message par GwendalDurdik »

Pas vraiment... parceque même lorsque j'étais branché au secteur ca merdait des fois. (et normalement laptop mode était "bien" configuré x) mais je suis loin d'être infaillible. Je vais checker ca.)


EDIT : c'était pas que ca.
Quand mon ordi se met en veille suite à plus de courant => la connexion disparait à la sortie de veille. Necessité d'un reboot.
Répondre