[phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Applications, problèmes de configuration réseau
stephan08
Daikyu
Messages : 93
Inscription : jeu. 19 nov. 2015, 23:18

[phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par stephan08 »

Bonjour,

J'ai suivi comme il faut la documentation afin d'installer phpMyAdmin sous Archlinux. Par contre, je tombe sur cette erreur lorsque je vais sur http://localhost/phpmyadmin:

Code : Tout sélectionner

Access forbidden!
You don't have permission to access the requested object. It is either read-protected or not readable by the server.
If you think this is a server error, please contact the webmaster.
Error 403
localhost
Pourtant, j'ai bien fait tout ce qui se trouve dans la page:
https://wiki.archlinux.fr/Phpmyadmin

1) Dans /etc/httpd/conf/extra/httpd-phpmyadmin.conf, j'ai bien mis:

Code : Tout sélectionner

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"
<Directory "/usr/share/webapps/phpMyAdmin">
    DirectoryIndex index.html index.php
    AllowOverride All
    Options FollowSymlinks
    Require all granted
</Directory>
2) Dans /etc/httpd/conf/httpd.conf, j'ai bien ajouté:
Include conf/extra/httpd-phpmyadmin.conf

3) Dans /etc/webapps/phpmyadmin/.htaccess, j'ai bien commenté la ligne suivante avec un #:
#deny from all

4) Dans /etc/php/php.ini, j'ai bien décommenter les lignes suivantes afin que ces fonctionnalités soient prises en compte:
extension=mcrypt.so
extension=mysqli.so

5) Enfin, dans /etc/php/php.ini, j'ai bien:
open_basedir = /srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/:/etc/webapps/

Pouvez vous m'aider à terminer l'installation s'il vous plaît?

Je vous remercie par avance,
aminnairi
archer de cavalerie
Messages : 187
Inscription : lun. 10 août 2015, 13:50
Localisation : France
Contact :

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par aminnairi »

Salut,

Peut être que tu n'as pas bien configuré le nom d'hôte lors de l'installation de ta machine archlinux (j'imagine que c'est sur une machine archlinux).

Je voulais te donner un bout de l'article concernant l'installation d'Archlinux en français, mais je n'ai pas trouvé le point concernant les noms d'hôtes (de toute façon, je regarde toujours la documentation en anglais, que je trouve pour le coup un peu plus fournie).

J'espère que ça n'est que ça, parce que je ne vois pas trop quoi d'autre pourrait empêcher phpMyAdmin de fonctionner. Je n'avais pas eu de soucis quand je l'ai installé donc je ne pourrais pas t'aider plus malheuresement.

Regarde aussi du coté de tes iptables si tu as bien pensé à ouvrir la boucle locale (si tu y a touchcé bien sûr).
Arch Linux x86_64 UEFI
7,3 Gio RAM
Intel® Core™ i5-4200U CPU @ 1.60GHz × 4
Intel® Haswell Mobile + NVIDIA GeForce 840M 2 Gio vRAM
KDE Plasma + SDDM
benjarobin
Maître du Kyudo
Messages : 15971
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par benjarobin »

Si tu as une telle erreur c'est qu'il y a une règle qui interdit l'accès à ce dossier (et non iptables ou une mauvaise configuration du nom d'hôte ne peut pas provoquer une telle chose)
Peux tu donner la sortie de :

Code : Tout sélectionner

find /usr/share/webapps /etc/webapps -name .htaccess | while read f ; do grep -EHv "^ *$" "$f" ; done
Voir même aussi

Code : Tout sélectionner

grep -HEvr "^ *$|^ *#" /etc/httpd/conf/*.conf /etc/httpd/conf/extra/*.conf
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
stephan08
Daikyu
Messages : 93
Inscription : jeu. 19 nov. 2015, 23:18

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par stephan08 »

Re,

La commande:

Code : Tout sélectionner

find /usr/share/webapps /etc/webapps -name .htaccess | while read f ; do grep -EHv "^ *$" "$f" ; done
me donne:

Code : Tout sélectionner

/usr/share/webapps/phpMyAdmin/.htaccess:#deny from all
/usr/share/webapps/phpMyAdmin/test/.htaccess:# This folder does NOT need to be accessible over HTTP
/usr/share/webapps/phpMyAdmin/test/.htaccess:# In most cases the tests included here will be run from a command line interface.
/usr/share/webapps/phpMyAdmin/test/.htaccess:# (the following directive denies access by default)
/usr/share/webapps/phpMyAdmin/test/.htaccess:# For more information see: http://httpd.apache.org/docs/current/mod/mod_authz_host.html#allow
/usr/share/webapps/phpMyAdmin/test/.htaccess:Order allow,deny
/etc/webapps/phpmyadmin/.htaccess:#deny from all
Et la commande:

Code : Tout sélectionner

grep -HEvr "^ *$|^ *#" /etc/http/conf/*.conf /etc/httpd/conf/extra/*.conf
me donne

Code : Tout sélectionner

grep: /etc/http/conf/*.conf: No such file or directory
/etc/httpd/conf/extra/httpd-autoindex.conf:IndexOptions FancyIndexing HTMLTable VersionSort
/etc/httpd/conf/extra/httpd-autoindex.conf:Alias /icons/ "/usr/share/httpd/icons/"
/etc/httpd/conf/extra/httpd-autoindex.conf:<Directory "/usr/share/httpd/icons">
/etc/httpd/conf/extra/httpd-autoindex.conf:    Options Indexes MultiViews
/etc/httpd/conf/extra/httpd-autoindex.conf:    AllowOverride None
/etc/httpd/conf/extra/httpd-autoindex.conf:    Require all granted
/etc/httpd/conf/extra/httpd-autoindex.conf:</Directory>
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIconByType (TXT,/icons/text.gif) text/*
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIconByType (IMG,/icons/image2.gif) image/*
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIconByType (SND,/icons/sound2.gif) audio/*
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIconByType (VID,/icons/movie.gif) video/*
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/binary.gif .bin .exe
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/binhex.gif .hqx
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/tar.gif .tar
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/a.gif .ps .ai .eps
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/layout.gif .html .shtml .htm .pdf
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/text.gif .txt
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/c.gif .c
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/p.gif .pl .py
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/f.gif .for
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/dvi.gif .dvi
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/uuencoded.gif .uu
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/tex.gif .tex
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/bomb.gif core
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/back.gif ..
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/hand.right.gif README
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/folder.gif ^^DIRECTORY^^
/etc/httpd/conf/extra/httpd-autoindex.conf:AddIcon /icons/blank.gif ^^BLANKICON^^
/etc/httpd/conf/extra/httpd-autoindex.conf:DefaultIcon /icons/unknown.gif
/etc/httpd/conf/extra/httpd-autoindex.conf:ReadmeName README.html
/etc/httpd/conf/extra/httpd-autoindex.conf:HeaderName HEADER.html
/etc/httpd/conf/extra/httpd-autoindex.conf:IndexIgnore .??* *~ *# HEADER* README* RCS CVS *,v *,t
/etc/httpd/conf/extra/httpd-dav.conf:DavLockDB "/etc/httpd/var/DavLock"
/etc/httpd/conf/extra/httpd-dav.conf:Alias /uploads "/etc/httpd/uploads"
/etc/httpd/conf/extra/httpd-dav.conf:<Directory "/etc/httpd/uploads">
/etc/httpd/conf/extra/httpd-dav.conf:    Dav On
/etc/httpd/conf/extra/httpd-dav.conf:    AuthType Digest
/etc/httpd/conf/extra/httpd-dav.conf:    AuthName DAV-upload
/etc/httpd/conf/extra/httpd-dav.conf:    AuthUserFile "/etc/httpd/user.passwd"
/etc/httpd/conf/extra/httpd-dav.conf:    AuthDigestProvider file
/etc/httpd/conf/extra/httpd-dav.conf:    <RequireAny>
/etc/httpd/conf/extra/httpd-dav.conf:        Require method GET POST OPTIONS
/etc/httpd/conf/extra/httpd-dav.conf:        Require user admin
/etc/httpd/conf/extra/httpd-dav.conf:    </RequireAny>
/etc/httpd/conf/extra/httpd-dav.conf:</Directory>
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "MS FrontPage" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "^WebDrive" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "^WebDAVFS/1.[01234]" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "^gnome-vfs/1.0" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "^XML Spy" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully
/etc/httpd/conf/extra/httpd-dav.conf:BrowserMatch " Konqueror/4" redirect-carefully
/etc/httpd/conf/extra/httpd-default.conf:Timeout 60
/etc/httpd/conf/extra/httpd-default.conf:KeepAlive On
/etc/httpd/conf/extra/httpd-default.conf:MaxKeepAliveRequests 100
/etc/httpd/conf/extra/httpd-default.conf:KeepAliveTimeout 5
/etc/httpd/conf/extra/httpd-default.conf:UseCanonicalName Off
/etc/httpd/conf/extra/httpd-default.conf:AccessFileName .htaccess
/etc/httpd/conf/extra/httpd-default.conf:ServerTokens Full
/etc/httpd/conf/extra/httpd-default.conf:ServerSignature Off
/etc/httpd/conf/extra/httpd-default.conf:HostnameLookups Off
/etc/httpd/conf/extra/httpd-default.conf:<IfModule reqtimeout_module>
/etc/httpd/conf/extra/httpd-default.conf:  RequestReadTimeout header=20-40,MinRate=500 body=20,MinRate=500
/etc/httpd/conf/extra/httpd-default.conf:</IfModule>
/etc/httpd/conf/extra/httpd-info.conf:<Location /server-status>
/etc/httpd/conf/extra/httpd-info.conf:    SetHandler server-status
/etc/httpd/conf/extra/httpd-info.conf:    Require host .example.com
/etc/httpd/conf/extra/httpd-info.conf:    Require ip 127
/etc/httpd/conf/extra/httpd-info.conf:</Location>
/etc/httpd/conf/extra/httpd-info.conf:<Location /server-info>
/etc/httpd/conf/extra/httpd-info.conf:    SetHandler server-info
/etc/httpd/conf/extra/httpd-info.conf:    Require host .example.com
/etc/httpd/conf/extra/httpd-info.conf:    Require ip 127
/etc/httpd/conf/extra/httpd-info.conf:</Location>
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage ca .ca
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage cs .cz .cs
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage da .dk
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage de .de
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage el .el
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage en .en
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage eo .eo
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage es .es
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage et .et
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage fr .fr
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage he .he
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage hr .hr
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage it .it
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage ja .ja
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage ko .ko
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage ltz .ltz
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage nl .nl
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage nn .nn
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage no .no
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage pl .po
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage pt .pt
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage pt-BR .pt-br
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage ru .ru
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage sv .sv
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage tr .tr
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage zh-CN .zh-cn
/etc/httpd/conf/extra/httpd-languages.conf:AddLanguage zh-TW .zh-tw
/etc/httpd/conf/extra/httpd-languages.conf:LanguagePriority en ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR ru sv tr zh-CN zh-TW
/etc/httpd/conf/extra/httpd-languages.conf:ForceLanguagePriority Prefer Fallback
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset us-ascii.ascii .us-ascii
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-1  .iso8859-1  .latin1
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-2  .iso8859-2  .latin2 .cen
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-3  .iso8859-3  .latin3
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-4  .iso8859-4  .latin4
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-5  .iso8859-5  .cyr .iso-ru
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-6  .iso8859-6  .arb .arabic
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-7  .iso8859-7  .grk .greek
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-8  .iso8859-8  .heb .hebrew
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-9  .iso8859-9  .latin5 .trk
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-10  .iso8859-10  .latin6
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-13  .iso8859-13
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-14  .iso8859-14  .latin8
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-15  .iso8859-15  .latin9
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-8859-16  .iso8859-16  .latin10
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-2022-JP .iso2022-jp .jis
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-2022-KR .iso2022-kr .kis
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-2022-CN .iso2022-cn .cis
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset Big5.Big5   .big5 .b5
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset cn-Big5 .cn-big5
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset WINDOWS-1251 .cp-1251   .win-1251
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset CP866   .cp866
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset KOI8  .koi8
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset KOI8-E  .koi8-e
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset KOI8-r  .koi8-r .koi8-ru
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset KOI8-U  .koi8-u
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset KOI8-ru .koi8-uk .ua
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-10646-UCS-2 .ucs2
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset ISO-10646-UCS-4 .ucs4
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-7   .utf7
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-8   .utf8
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-16  .utf16
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-16BE .utf16be
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-16LE .utf16le
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-32  .utf32
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-32BE .utf32be
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset UTF-32LE .utf32le
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset euc-cn  .euc-cn
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset euc-gb  .euc-gb
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset euc-jp  .euc-jp
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset euc-kr  .euc-kr
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset EUC-TW  .euc-tw
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset gb2312  .gb2312 .gb
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset iso-10646-ucs-2 .ucs-2 .iso-10646-ucs-2
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset iso-10646-ucs-4 .ucs-4 .iso-10646-ucs-4
/etc/httpd/conf/extra/httpd-languages.conf:AddCharset shift_jis   .shift_jis .sjis
/etc/httpd/conf/extra/httpd-manual.conf:AliasMatch ^/manual(?:/(?:da|de|en|es|fr|ja|ko|pt-br|ru|tr|zh-cn))?(/.*)?$ "/usr/share/httpd/manual$1"
/etc/httpd/conf/extra/httpd-manual.conf:<Directory "/usr/share/httpd/manual">
/etc/httpd/conf/extra/httpd-manual.conf:    Options Indexes
/etc/httpd/conf/extra/httpd-manual.conf:    AllowOverride None
/etc/httpd/conf/extra/httpd-manual.conf:    Require all granted
/etc/httpd/conf/extra/httpd-manual.conf:    <Files *.html>
/etc/httpd/conf/extra/httpd-manual.conf:        SetHandler type-map
/etc/httpd/conf/extra/httpd-manual.conf:    </Files>
/etc/httpd/conf/extra/httpd-manual.conf:    <Files *.html.tr.utf8>
/etc/httpd/conf/extra/httpd-manual.conf:        ForceType "text/html; charset=utf-8"
/etc/httpd/conf/extra/httpd-manual.conf:    </Files>
/etc/httpd/conf/extra/httpd-manual.conf:    AddLanguage da .da
/etc/httpd/conf/extra/httpd-manual.conf:    SetEnvIf Request_URI ^/manual/(da|de|en|es|fr|ja|ko|pt-br|ru|tr|zh-cn)/ prefer-language=$1
/etc/httpd/conf/extra/httpd-manual.conf:    RedirectMatch 301 ^/manual(?:/(da|de|en|es|fr|ja|ko|pt-br|ru|tr|zh-cn)){2,}(/.*)?$ /manual/$1$2
/etc/httpd/conf/extra/httpd-manual.conf:    LanguagePriority en da de es fr ja ko pt-br ru tr
/etc/httpd/conf/extra/httpd-manual.conf:    ForceLanguagePriority Prefer Fallback
/etc/httpd/conf/extra/httpd-manual.conf:</Directory>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule !mpm_netware_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    PidFile "/run/httpd/httpd.pid"
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_prefork_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    StartServers             5
/etc/httpd/conf/extra/httpd-mpm.conf:    MinSpareServers          5
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxSpareServers         10
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxRequestWorkers      250
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_worker_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    StartServers             3
/etc/httpd/conf/extra/httpd-mpm.conf:    MinSpareThreads         75
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxSpareThreads        250 
/etc/httpd/conf/extra/httpd-mpm.conf:    ThreadsPerChild         25
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxRequestWorkers      400
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_event_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    StartServers             3
/etc/httpd/conf/extra/httpd-mpm.conf:    MinSpareThreads         75
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxSpareThreads        250
/etc/httpd/conf/extra/httpd-mpm.conf:    ThreadsPerChild         25
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxRequestWorkers      400
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_netware_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    ThreadStackSize      65536
/etc/httpd/conf/extra/httpd-mpm.conf:    StartThreads           250
/etc/httpd/conf/extra/httpd-mpm.conf:    MinSpareThreads         25
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxSpareThreads        250
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxThreads            1000
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_mpmt_os2_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    StartServers             2
/etc/httpd/conf/extra/httpd-mpm.conf:    MinSpareThreads          5
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxSpareThreads         10
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_winnt_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    ThreadsPerChild        150
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxConnectionsPerChild   0
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule !mpm_netware_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxMemFree            2048
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-mpm.conf:<IfModule mpm_netware_module>
/etc/httpd/conf/extra/httpd-mpm.conf:    MaxMemFree             100
/etc/httpd/conf/extra/httpd-mpm.conf:</IfModule>
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:Alias /error/ "/usr/share/httpd/error/"
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:<Directory "/usr/share/httpd/error">
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    AllowOverride None
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    Options IncludesNoExec
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    AddOutputFilter Includes html
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    AddHandler type-map var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    Require all granted
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    LanguagePriority en cs de es fr it ja ko nl pl pt-br ro sv tr
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:    ForceLanguagePriority Prefer Fallback
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:</Directory>
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 410 /error/HTTP_GONE.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 415 /error/HTTP_UNSUPPORTED_MEDIA_TYPE.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
/etc/httpd/conf/extra/httpd-multilang-errordoc.conf:ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var
/etc/httpd/conf/extra/httpd-ssl.conf:Listen 443
/etc/httpd/conf/extra/httpd-ssl.conf:SSLCipherSuite HIGH:MEDIUM:!MD5:!RC4
/etc/httpd/conf/extra/httpd-ssl.conf:SSLProxyCipherSuite HIGH:MEDIUM:!MD5:!RC4
/etc/httpd/conf/extra/httpd-ssl.conf:SSLHonorCipherOrder on 
/etc/httpd/conf/extra/httpd-ssl.conf:SSLProtocol all -SSLv3
/etc/httpd/conf/extra/httpd-ssl.conf:SSLProxyProtocol all -SSLv3
/etc/httpd/conf/extra/httpd-ssl.conf:SSLPassPhraseDialog  builtin
/etc/httpd/conf/extra/httpd-ssl.conf:SSLSessionCache        "shmcb:/run/httpd/ssl_scache(512000)"
/etc/httpd/conf/extra/httpd-ssl.conf:SSLSessionCacheTimeout  300
/etc/httpd/conf/extra/httpd-ssl.conf:<VirtualHost _default_:443>
/etc/httpd/conf/extra/httpd-ssl.conf:DocumentRoot "/srv/http"
/etc/httpd/conf/extra/httpd-ssl.conf:ServerName www.example.com:443
/etc/httpd/conf/extra/httpd-ssl.conf:ServerAdmin you@example.com
/etc/httpd/conf/extra/httpd-ssl.conf:ErrorLog "/var/log/httpd/error_log"
/etc/httpd/conf/extra/httpd-ssl.conf:TransferLog "/var/log/httpd/access_log"
/etc/httpd/conf/extra/httpd-ssl.conf:SSLEngine on
/etc/httpd/conf/extra/httpd-ssl.conf:SSLCertificateFile "/etc/httpd/conf/server.crt"
/etc/httpd/conf/extra/httpd-ssl.conf:SSLCertificateKeyFile "/etc/httpd/conf/server.key"
/etc/httpd/conf/extra/httpd-ssl.conf:<FilesMatch "\.(cgi|shtml|phtml|php)$">
/etc/httpd/conf/extra/httpd-ssl.conf:    SSLOptions +StdEnvVars
/etc/httpd/conf/extra/httpd-ssl.conf:</FilesMatch>
/etc/httpd/conf/extra/httpd-ssl.conf:<Directory "/srv/http/cgi-bin">
/etc/httpd/conf/extra/httpd-ssl.conf:    SSLOptions +StdEnvVars
/etc/httpd/conf/extra/httpd-ssl.conf:</Directory>
/etc/httpd/conf/extra/httpd-ssl.conf:BrowserMatch "MSIE [2-5]" \
/etc/httpd/conf/extra/httpd-ssl.conf:         nokeepalive ssl-unclean-shutdown \
/etc/httpd/conf/extra/httpd-ssl.conf:         downgrade-1.0 force-response-1.0
/etc/httpd/conf/extra/httpd-ssl.conf:CustomLog "/var/log/httpd/ssl_request_log" \
/etc/httpd/conf/extra/httpd-ssl.conf:          "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
/etc/httpd/conf/extra/httpd-ssl.conf:</VirtualHost>                                  
/etc/httpd/conf/extra/httpd-userdir.conf:UserDir public_html
/etc/httpd/conf/extra/httpd-userdir.conf:<Directory "/home/*/public_html">
/etc/httpd/conf/extra/httpd-userdir.conf:    AllowOverride FileInfo AuthConfig Limit Indexes
/etc/httpd/conf/extra/httpd-userdir.conf:    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
/etc/httpd/conf/extra/httpd-userdir.conf:    Require method GET POST OPTIONS
/etc/httpd/conf/extra/httpd-userdir.conf:</Directory>
/etc/httpd/conf/extra/httpd-vhosts.conf:<VirtualHost *:80>
/etc/httpd/conf/extra/httpd-vhosts.conf:    ServerAdmin webmaster@dummy-host.example.com
/etc/httpd/conf/extra/httpd-vhosts.conf:    DocumentRoot "/etc/httpd/docs/dummy-host.example.com"
/etc/httpd/conf/extra/httpd-vhosts.conf:    ServerName dummy-host.example.com
/etc/httpd/conf/extra/httpd-vhosts.conf:    ServerAlias www.dummy-host.example.com
/etc/httpd/conf/extra/httpd-vhosts.conf:    ErrorLog "/var/log/httpd/dummy-host.example.com-error_log"
/etc/httpd/conf/extra/httpd-vhosts.conf:    CustomLog "/var/log/httpd/dummy-host.example.com-access_log" common
/etc/httpd/conf/extra/httpd-vhosts.conf:</VirtualHost>
/etc/httpd/conf/extra/httpd-vhosts.conf:<VirtualHost *:80>
/etc/httpd/conf/extra/httpd-vhosts.conf:    ServerAdmin webmaster@dummy-host2.example.com
/etc/httpd/conf/extra/httpd-vhosts.conf:    DocumentRoot "/etc/httpd/docs/dummy-host2.example.com"
/etc/httpd/conf/extra/httpd-vhosts.conf:    ServerName dummy-host2.example.com
/etc/httpd/conf/extra/httpd-vhosts.conf:    ErrorLog "/var/log/httpd/dummy-host2.example.com-error_log"
/etc/httpd/conf/extra/httpd-vhosts.conf:    CustomLog "/var/log/httpd/dummy-host2.example.com-access_log" common
/etc/httpd/conf/extra/httpd-vhosts.conf:</VirtualHost>
/etc/httpd/conf/extra/php7_module.conf:<IfModule dir_module>
/etc/httpd/conf/extra/php7_module.conf:	<IfModule php7_module>
/etc/httpd/conf/extra/php7_module.conf:		DirectoryIndex index.php index.html
/etc/httpd/conf/extra/php7_module.conf:		<FilesMatch "\.php$">
/etc/httpd/conf/extra/php7_module.conf:			SetHandler application/x-httpd-php
/etc/httpd/conf/extra/php7_module.conf:		</FilesMatch>
/etc/httpd/conf/extra/php7_module.conf:		<FilesMatch "\.phps$">
/etc/httpd/conf/extra/php7_module.conf:			SetHandler application/x-httpd-php-source
/etc/httpd/conf/extra/php7_module.conf:		</FilesMatch>
/etc/httpd/conf/extra/php7_module.conf:	</IfModule>
/etc/httpd/conf/extra/php7_module.conf:</IfModule>
/etc/httpd/conf/extra/phpmyadmin.conf:Alias /phpmyadmin "usr/share/webapps/phpMyAdmin"
/etc/httpd/conf/extra/phpmyadmin.conf:<Directory "usr/share/webapps/phpMyAdmin">
/etc/httpd/conf/extra/phpmyadmin.conf:	DirectoryIndex index.php
/etc/httpd/conf/extra/phpmyadmin.conf:	AllowOverride All
/etc/httpd/conf/extra/phpmyadmin.conf:	Options FollowSymlinks
/etc/httpd/conf/extra/phpmyadmin.conf:	Require all granted
/etc/httpd/conf/extra/phpmyadmin.conf:</Directory>
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	a		href
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	area		href
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	link		href
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	img		src longdesc usemap
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	object		classid codebase data usemap
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	q		cite
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	blockquote	cite
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	ins		cite
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	del		cite
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	form		action
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	input		src usemap
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	head		profile
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	base		href
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLLinks	script		src for
/etc/httpd/conf/extra/proxy-html.conf:ProxyHTMLEvents	onclick ondblclick onmousedown onmouseup \
/etc/httpd/conf/extra/proxy-html.conf:		onmouseover onmousemove onmouseout onkeypress \
/etc/httpd/conf/extra/proxy-html.conf:		onkeydown onkeyup onfocus onblur onload \
/etc/httpd/conf/extra/proxy-html.conf:		onunload onsubmit onreset onselect onchange
benjarobin
Maître du Kyudo
Messages : 15971
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par benjarobin »

Tu t'es planté dans la 2ième commande : http != httpd... Donne donc la sortie de

Code : Tout sélectionner

grep -HEvr "^ *$|^ *#" /etc/httpd/conf/*.conf
Et tant que tu y es tu peux supprimer ces 2 fichiers qui ne servent à rien et n’appartiennent à aucun paquet:

Code : Tout sélectionner

rm /usr/share/webapps/phpMyAdmin/.htaccess /etc/webapps/phpmyadmin/.htaccess
Edit:
stephan08 a écrit :1) Dans /etc/httpd/conf/extra/httpd-phpmyadmin.conf, j'ai bien mis:
Ce n'est pas bien de mentir... Non tu n'as pas mit ceci !!! Et donc cela ne peut pas fonctionner
=> usr/share/webapps/phpMyAdmin c'est différent de /usr/share/webapps/phpMyAdmin
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
stephan08
Daikyu
Messages : 93
Inscription : jeu. 19 nov. 2015, 23:18

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par stephan08 »

Re,

Effectivement, j'avais changé httpd-phpmyadmin.conf en phpmyadmin.conf, mais même avec le nom d'avant ça faisait la même erreur.

J'ai mis à jour le dossier /etc/httpd/conf/extra/phpmyadmin.conf en /etc/httpd/conf/extra/httpd-phpmyadmin.conf
Du coup, j'ai bien remodifié l'include dans /etc/httpd/conf/httpd.conf:

Code : Tout sélectionner

Include conf/extra/httpd-phpmyadmin.conf
Comme tu m'as demandé, j'ai bien supprimé les deux fichiers .htaccess via un:

Code : Tout sélectionner

rm /usr/share/webapps/phpMyAdmin/.htaccess /etc/webapps/phpmyadmin/.htaccess
La commande:

Code : Tout sélectionner

grep -HEvr "^ *$|^ *#" /etc/httpd/conf/*.conf
me donne:

Code : Tout sélectionner

/etc/httpd/conf/httpd.conf:ServerRoot "/etc/httpd"
/etc/httpd/conf/httpd.conf:Listen 80
/etc/httpd/conf/httpd.conf:LoadModule authn_file_module modules/mod_authn_file.so
/etc/httpd/conf/httpd.conf:LoadModule authn_core_module modules/mod_authn_core.so
/etc/httpd/conf/httpd.conf:LoadModule authz_host_module modules/mod_authz_host.so
/etc/httpd/conf/httpd.conf:LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
/etc/httpd/conf/httpd.conf:LoadModule authz_user_module modules/mod_authz_user.so
/etc/httpd/conf/httpd.conf:LoadModule authz_core_module modules/mod_authz_core.so
/etc/httpd/conf/httpd.conf:LoadModule access_compat_module modules/mod_access_compat.so
/etc/httpd/conf/httpd.conf:LoadModule auth_basic_module modules/mod_auth_basic.so
/etc/httpd/conf/httpd.conf:LoadModule reqtimeout_module modules/mod_reqtimeout.so
/etc/httpd/conf/httpd.conf:LoadModule include_module modules/mod_include.so
/etc/httpd/conf/httpd.conf:LoadModule filter_module modules/mod_filter.so
/etc/httpd/conf/httpd.conf:LoadModule mime_module modules/mod_mime.so
/etc/httpd/conf/httpd.conf:LoadModule log_config_module modules/mod_log_config.so
/etc/httpd/conf/httpd.conf:LoadModule env_module modules/mod_env.so
/etc/httpd/conf/httpd.conf:LoadModule headers_module modules/mod_headers.so
/etc/httpd/conf/httpd.conf:LoadModule setenvif_module modules/mod_setenvif.so
/etc/httpd/conf/httpd.conf:LoadModule version_module modules/mod_version.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_module modules/mod_proxy.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_connect_module modules/mod_proxy_connect.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_http_module modules/mod_proxy_http.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_fcgi_module modules/mod_proxy_fcgi.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_scgi_module modules/mod_proxy_scgi.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_ajp_module modules/mod_proxy_ajp.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
/etc/httpd/conf/httpd.conf:LoadModule proxy_express_module modules/mod_proxy_express.so
/etc/httpd/conf/httpd.conf:LoadModule slotmem_shm_module modules/mod_slotmem_shm.so
/etc/httpd/conf/httpd.conf:LoadModule lbmethod_byrequests_module modules/mod_lbmethod_byrequests.so
/etc/httpd/conf/httpd.conf:LoadModule lbmethod_bytraffic_module modules/mod_lbmethod_bytraffic.so
/etc/httpd/conf/httpd.conf:LoadModule lbmethod_bybusyness_module modules/mod_lbmethod_bybusyness.so
/etc/httpd/conf/httpd.conf:LoadModule lbmethod_heartbeat_module modules/mod_lbmethod_heartbeat.so
/etc/httpd/conf/httpd.conf:LoadModule mpm_prefork_module modules/mod_mpm_prefork.so
/etc/httpd/conf/httpd.conf:LoadModule unixd_module modules/mod_unixd.so
/etc/httpd/conf/httpd.conf:LoadModule status_module modules/mod_status.so
/etc/httpd/conf/httpd.conf:LoadModule autoindex_module modules/mod_autoindex.so
/etc/httpd/conf/httpd.conf:<IfModule !mpm_prefork_module>
/etc/httpd/conf/httpd.conf:	#LoadModule cgid_module modules/mod_cgid.so
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<IfModule mpm_prefork_module>
/etc/httpd/conf/httpd.conf:	#LoadModule cgi_module modules/mod_cgi.so
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:LoadModule negotiation_module modules/mod_negotiation.so
/etc/httpd/conf/httpd.conf:LoadModule dir_module modules/mod_dir.so
/etc/httpd/conf/httpd.conf:LoadModule userdir_module modules/mod_userdir.so
/etc/httpd/conf/httpd.conf:LoadModule alias_module modules/mod_alias.so
/etc/httpd/conf/httpd.conf:LoadModule php7_module modules/libphp7.so
/etc/httpd/conf/httpd.conf:<IfModule unixd_module>
/etc/httpd/conf/httpd.conf:User http
/etc/httpd/conf/httpd.conf:Group http
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:ServerAdmin you@example.com
/etc/httpd/conf/httpd.conf:<Directory />
/etc/httpd/conf/httpd.conf:    AllowOverride none
/etc/httpd/conf/httpd.conf:    Require all denied
/etc/httpd/conf/httpd.conf:</Directory>
/etc/httpd/conf/httpd.conf:DocumentRoot "/srv/http"
/etc/httpd/conf/httpd.conf:<Directory "/srv/http">
/etc/httpd/conf/httpd.conf:    Options Indexes FollowSymLinks
/etc/httpd/conf/httpd.conf:    AllowOverride None
/etc/httpd/conf/httpd.conf:    Require all granted
/etc/httpd/conf/httpd.conf:</Directory>
/etc/httpd/conf/httpd.conf:<Directory "/home/stephan/projects/php/Booklist">
/etc/httpd/conf/httpd.conf:        Options Indexes FollowSymLinks MultiViews
/etc/httpd/conf/httpd.conf:        AllowOverride all
/etc/httpd/conf/httpd.conf:        Order Deny,Allow
/etc/httpd/conf/httpd.conf:        Allow from all
/etc/httpd/conf/httpd.conf:        Require all granted
/etc/httpd/conf/httpd.conf:</Directory>
/etc/httpd/conf/httpd.conf:<Directory "/home/stephan/projects/php/Dactylo">
/etc/httpd/conf/httpd.conf:        Options Indexes FollowSymLinks MultiViews
/etc/httpd/conf/httpd.conf:        AllowOverride all
/etc/httpd/conf/httpd.conf:        Order Deny,Allow
/etc/httpd/conf/httpd.conf:        Allow from all
/etc/httpd/conf/httpd.conf:        Require all granted
/etc/httpd/conf/httpd.conf:</Directory>
/etc/httpd/conf/httpd.conf:<IfModule dir_module>
/etc/httpd/conf/httpd.conf:    DirectoryIndex index.html
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<Files ".ht*">
/etc/httpd/conf/httpd.conf:    Require all denied
/etc/httpd/conf/httpd.conf:</Files>
/etc/httpd/conf/httpd.conf:ErrorLog "/var/log/httpd/error_log"
/etc/httpd/conf/httpd.conf:LogLevel warn
/etc/httpd/conf/httpd.conf:<IfModule log_config_module>
/etc/httpd/conf/httpd.conf:    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
/etc/httpd/conf/httpd.conf:    LogFormat "%h %l %u %t \"%r\" %>s %b" common
/etc/httpd/conf/httpd.conf:    <IfModule logio_module>
/etc/httpd/conf/httpd.conf:      LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio
/etc/httpd/conf/httpd.conf:    </IfModule>
/etc/httpd/conf/httpd.conf:    CustomLog "/var/log/httpd/access_log" common
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<IfModule alias_module>
/etc/httpd/conf/httpd.conf:    ScriptAlias /cgi-bin/ "/srv/http/cgi-bin/"
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<IfModule cgid_module>
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<Directory "/srv/http/cgi-bin">
/etc/httpd/conf/httpd.conf:    AllowOverride None
/etc/httpd/conf/httpd.conf:    Options None
/etc/httpd/conf/httpd.conf:    Require all granted
/etc/httpd/conf/httpd.conf:</Directory>
/etc/httpd/conf/httpd.conf:<IfModule mime_module>
/etc/httpd/conf/httpd.conf:    TypesConfig conf/mime.types
/etc/httpd/conf/httpd.conf:    AddType application/x-compress .Z
/etc/httpd/conf/httpd.conf:    AddType application/x-gzip .gz .tgz
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-mpm.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-multilang-errordoc.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-autoindex.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-languages.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-userdir.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-default.conf
/etc/httpd/conf/httpd.conf:<IfModule proxy_html_module>
/etc/httpd/conf/httpd.conf:Include conf/extra/proxy-html.conf
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:<IfModule ssl_module>
/etc/httpd/conf/httpd.conf:SSLRandomSeed startup builtin
/etc/httpd/conf/httpd.conf:SSLRandomSeed connect builtin
/etc/httpd/conf/httpd.conf:</IfModule>
/etc/httpd/conf/httpd.conf:Include conf/extra/php7_module.conf
/etc/httpd/conf/httpd.conf:Include conf/extra/httpd-phpmyadmin.conf
stephan08
Daikyu
Messages : 93
Inscription : jeu. 19 nov. 2015, 23:18

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par stephan08 »

C'est bon, ça marche.

Effectivement, le bloc présent dans /etc/httpd/conf/extra/httpd-phpmyadmin.conf n'étaient pas bon.

j'avais mis:

Code : Tout sélectionner

Alias /phpmyadmin "usr/share/webapps/phpMyAdmin"
<Directory "usr/share/webapps/phpMyAdmin">
	DirectoryIndex index.php
	AllowOverride All
	Options FollowSymlinks
	Require all granted
</Directory>
au lieu de:

Code : Tout sélectionner

Alias /phpmyadmin "/usr/share/webapps/phpMyAdmin"
<Directory "/usr/share/webapps/phpMyAdmin">
	DirectoryIndex index.php
	AllowOverride All
	Options FollowSymlinks
	Require all granted
</Directory>
Je te remercie encore
Avatar de l’utilisateur
Tebo
Chu Ko Nu
Messages : 368
Inscription : sam. 17 mars 2007, 23:24

Re: [phpMyAdmin] Error 403 lorsque je lance phpMyAdmin

Message par Tebo »

De passage je tombe sur ton topic et je viens te dire que j'utilise adminer.
C'est tout léger et simple, pour un serveur perso peut-être pas besoin de phpmyadmin ;)

https://www.adminer.org/
Répondre