[smplayer] refuse de lire certains médias (contourné)

Applications, problèmes de configuration réseau
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

[smplayer] refuse de lire certains médias (contourné)

Message par Skwad »

Bonjour, :)

Depuis quelques jours, je rencontre un bug assez gênant. Seul smplayer est concerné ! mplayer n'est pas affecté.

Si le fichier audio ou vidéo dont le nom possède au moins un caractère accentué; et/ou si dans le chemin absolu, un nom de répertoire possède au moins un caractère accentué, smplayer renvoie une erreur.

Code : Tout sélectionner

Code de sortie 2
Playing: /home/skwad/Vid??os/movie.avi
[file] Cannot open file '/home/skwad/Vid??os/my_movie.avi': No such file or directory
Failed to open /home/skwad/Vid??os/my_movie.avi.
Exiting... (Errors when loading file)

Si je le lance en ligne de commande, j'obtiens:

Code : Tout sélectionner

SMPlayer v. 17.9.0 (r?vision 8645) fonctionnant sur Linux
r?vision ? Le logiciel en lui-même semble bogué ?

Renommer ~/.config/smplayer a bien réinitialisé la configuration mais le problème reste entier.
Je n'ai aucun problème d'affichage ailleurs, que ce soit en console sans serveur graphique ou bien avec VLC, Libreoffice, etc.

Je sèche un peu pour le moment alors si quelqu'un a une idée...
Merci. :)
Dernière modification par Skwad le lun. 06 nov. 2017, 16:39, modifié 1 fois.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Bonjour,
Tu n'aurais pas un problème de configuration de tes locales ?

Code : Tout sélectionner

env | grep -E "LANG|LC"
locale
locale -a
localectl
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Bonsoir benjarobin,

Toujours aussi prompt à intervenir à ce que je vois. :D

Code : Tout sélectionner

$ env | grep -E "LANG|LC"
LC_MESSAGES=
LC_TELEPHONE=
LANG=fr_FR.UTF-8
LC_CTYPE=
LC_NAME=
LANGUAGE=
LC_MEASUREMENT=
LC_PAPER=
LC_NUMERIC=
LC_MONETARY=
LC_IDENTIFICATION=
LC_TIME=
LC_COLLATE=
LC_ADDRESS=

Code : Tout sélectionner

$ locale
LANG=fr_FR.UTF-8
LC_CTYPE=
LC_NUMERIC=
LC_TIME=
LC_COLLATE=
LC_MONETARY=
LC_MESSAGES=
LC_PAPER=
LC_NAME=
LC_ADDRESS=
LC_TELEPHONE=
LC_MEASUREMENT=
LC_IDENTIFICATION=
LC_ALL=

Code : Tout sélectionner

$ locale -a
C
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX

Code : Tout sélectionner

$ localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-pc
      X11 Layout: n/a
Voilà. Mais un problème de locales n'affecterait pas uniquement un programme ?
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Tu as définitivement un gros problème de locale... Je ne sais pas comment tu as fait, mais tout ceci n'est pas normal !

Ceci est ma configuration, tu devrais avoir quelque chose de très très proche

Code : Tout sélectionner

localectl 
   System Locale: LANG=fr_FR.UTF-8
                  LC_COLLATE=C
       VC Keymap: fr-latin9
      X11 Layout: fr
       X11 Model: pc105
     X11 Variant: latin9
     X11 Options: terminate:ctrl_alt_bksp
Ta configuration ne montre pas une configuration système du layout du clavier (c'est un autre sujet / problème)

Code : Tout sélectionner

$ locale -a
C
en_US
en_US.iso88591
en_US.utf8
french
fr_FR
fr_FR.iso88591
fr_FR.utf8
POSIX

Code : Tout sélectionner

$ locale 
LANG=fr_FR.utf8
LC_CTYPE="fr_FR.utf8"
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE="fr_FR.utf8"
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=

Code : Tout sélectionner

$ env | grep -E "LANG|LC"
LANG=fr_FR.utf8
LANGUAGE=
Ta configuration déclare des variables d'environnement qu'elle ne devrait pas ! (tous les LC_*)

Peux tu donner les sorties (en root) de

Code : Tout sélectionner

grep -r LC_IDENTIFICATION /etc /home/*/.[^.]*
cat /etc/locale.conf
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Bonjour,

Code : Tout sélectionner

# cat /etc/locale.conf 
## /etc/locale.conf

LANG=fr_FR.UTF-8
[root@arch ~]#

Code : Tout sélectionner

[root@arch ~]# grep -r LC_IDENTIFICATION /etc /home/*/[^.]*
/etc/profile.d/locale.sh:[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
J'avais un vieux fichier moisi /etc/profile.d/locale.sh.old datant de la période rc.conf qui apparaissait dans le résultat. Je l'ai déplacé temporairement ailleurs et j'ai relancé. La commande n'aboutit pas après un bon quart d'heure: pas de retour au prompt.
Je suis sur un disque dur mécanique datant de plus de 7 ans puisque arch y est installé depuis tout ce temps.


Edit:

Je sais pas si j'ai bien fait, mais

Code : Tout sélectionner

[root@arch ~]# localectl set-locale LANG=fr_FR.UTF-8
[root@arch ~]# localectl 
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-pc
      X11 Layout: n/a
      
[root@arch ~]# locale -a
C
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX
[root@arch ~]# locale

LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=

[root@arch ~]# env | grep -E "LANG|LC"
LANG=fr_FR.UTF-8
[root@arch ~]#
et smplayer ne fonctionne toujours pas. J'essaie après redémarrage du système.
Idem après redémarrage.

To be continued... :D
Dernière modification par Skwad le ven. 22 sept. 2017, 21:43, modifié 1 fois.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Ne lance pas les commandes depuis le compte root. Ton problème est très certainement dans la configuration de ton home.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

J'ai crée un utilisateur "test", l'ai intégré dans le groupe "users" qui est commun aux 2 utilisateurs, permis les droits de lecture sur /home/skwad/Vidéos à ce groupe et depuis une session X, j'obtiens la même erreur.

Je creuse encore... à moins qu'on ait touché le fond ? :roll:
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Quels sont les sorties des commandes demandées dans mon premier message avec ton utilisateur de test, sous Xorg et depuis un tty ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Bingo!

Code : Tout sélectionner

$ env | grep -E "LANG|LC"
LC_MESSAGES=
LC_TELEPHONE=
LANG=fr_FR.UTF-8
LC_CTYPE=
LC_NAME=
LANGUAGE=
LC_MEASUREMENT=
LC_PAPER=
LC_NUMERIC=
LC_MONETARY=
LC_IDENTIFICATION=
LC_TIME=
LC_COLLATE=
LC_ADDRESS=

Code : Tout sélectionner

$ locale
LANG=fr_FR.UTF-8
LC_CTYPE=
LC_NUMERIC=
LC_TIME=
LC_COLLATE=
LC_MONETARY=
LC_MESSAGES=
LC_PAPER=
LC_NAME=
LC_ADDRESS=
LC_TELEPHONE=
LC_MEASUREMENT=
LC_IDENTIFICATION=
LC_ALL=

Code : Tout sélectionner

$ locale -a
C
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX

Code : Tout sélectionner

$ localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-pc
      X11 Layout: n/a
Et même résultat sous Xorg.

Comment faire en sorte que la locale soit correct pendant le processus de création d'utilisateur ?
Quels paquets, fichiers vérifier ?
/etc/gpasswd, /etc/shadow, /etc/profile* ??
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Normalement avec une recherche uniquement sur l'utilisateur de test cela devrait être instantanée comme commande :

Code : Tout sélectionner

grep -r LC_IDENTIFICATION /etc /home/test
Peux tu donner aussi le contenu de :

Code : Tout sélectionner

cat /etc/profile.d/locale.sh
Et la sortie de

Code : Tout sélectionner

bash -x /etc/profile.d/locale.sh
Tout ceci avec ton utilisateur de test.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Code : Tout sélectionner

[test@arch ~]$ grep -r LC_IDENTIFICATION /etc/ /home/test/
grep: /etc/dhcpcd.secret: Permission non accordée
grep: /etc/crypttab: Permission non accordée
grep: /etc/gshadow: Permission non accordée
grep: /etc/lvm/cache: Permission non accordée
grep: /etc/mail/spamassassin/sa-update-keys: Permission non accordée
grep: /etc/gshadow-: Permission non accordée
grep: /etc/.pwd.lock: Permission non accordée
/etc/profile.d/locale.sh:[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
grep: /etc/mtab.fuselock: Permission non accordée
grep: /etc/gshadow.pacnew: Permission non accordée
grep: /etc/shadow.pacnew: Permission non accordée
grep: /etc/NetworkManager/system-connections: Permission non accordée
grep: /etc/wicd/wired-settings.conf: Permission non accordée
grep: /etc/wicd/wireless-settings.conf: Permission non accordée
grep: /etc/wicd/manager-settings.conf: Permission non accordée
grep: /etc/cups/printers.conf.pacsave: Permission non accordée
grep: /etc/cups/printers.conf: Permission non accordée
grep: /etc/cups/classes.conf: Permission non accordée
grep: /etc/cups/snmp.conf: Permission non accordée
grep: /etc/cups/printers.conf.O: Permission non accordée
grep: /etc/cups/cupsd.conf.default: Permission non accordée
grep: /etc/cups/cupsd.conf.O: Permission non accordée
grep: /etc/cups/cupsd.conf.pacnew: Permission non accordée
grep: /etc/cups/cups-files.conf: Permission non accordée
grep: /etc/cups/classes.conf.O: Permission non accordée
grep: /etc/cups/subscriptions.conf: Permission non accordée
grep: /etc/cups/cupsd.conf: Permission non accordée
grep: /etc/cups/ssl: Permission non accordée
grep: /etc/cups/ppd/Canon_MP170.ppd.O: Permission non accordée
grep: /etc/cups/ppd/Canon_MP170.ppd: Permission non accordée
grep: /etc/cups/cups-files.conf.default: Permission non accordée
grep: /etc/cups/subscriptions.conf.O: Permission non accordée
grep: /etc/cups/snmp.conf.default: Permission non accordée
grep: /etc/shadow-: Permission non accordée
grep: /etc/ppp/pap-secrets: Permission non accordée
grep: /etc/ppp/connect-errors: Permission non accordée
grep: /etc/ppp/chap-secrets: Permission non accordée
grep: /etc/shadow: Permission non accordée
grep: /etc/openvpn/server: Permission non accordée
grep: /etc/openvpn/client: Permission non accordée
grep: /etc/pacman.d/gnupg/private-keys-v1.d: Permission non accordée
grep: /etc/pacman.d/gnupg/crls.d: Permission non accordée
grep: /etc/pacman.d/gnupg/random_seed: Permission non accordée
grep: /etc/pacman.d/gnupg/secring.gpg: Permission non accordée
grep: /etc/polkit-1/rules.d: Permission non accordée
grep: /etc/polkit-1/localauthority: Permission non accordée
/home/test/tty_locale:LC_IDENTIFICATION=
/home/test/tty_env:LC_IDENTIFICATION=
[test@arch ~]$
Effectivement, il n'a fallu que quelques secondes.

Code : Tout sélectionner

[test@arch ~]$ cat /etc/profile.d/locale.sh
#!/bin/sh

if [ -z "$LANG" ]; then
  if [ -n "$XDG_CONFIG_HOME" ] && [ -r "$XDG_CONFIG_HOME/locale.conf" ]; then
    . "$XDG_CONFIG_HOME/locale.conf"
  elif [ -n "$HOME" ] && [ -r "$HOME/.config/locale.conf" ]; then
    . "$HOME/.config/locale.conf"
  elif [ -r /etc/locale.conf ]; then
    . /etc/locale.conf
  fi
fi

LANG=${LANG:-C}
export LANG
[ -n "$LC_CTYPE" ]          && export LC_CTYPE
[ -n "$LC_NUMERIC" ]        && export LC_NUMERIC
[ -n "$LC_TIME" ]           && export LC_TIME
[ -n "$LC_COLLATE" ]        && export LC_COLLATE
[ -n "$LC_MONETARY" ]       && export LC_MONETARY
[ -n "$LC_MESSAGES" ]       && export LC_MESSAGES
[ -n "$LC_PAPER" ]          && export LC_PAPER
[ -n "$LC_NAME" ]           && export LC_NAME
[ -n "$LC_ADDRESS" ]        && export LC_ADDRESS
[ -n "$LC_TELEPHONE" ]      && export LC_TELEPHONE
[ -n "$LC_MEASUREMENT" ]    && export LC_MEASUREMENT
[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
[test@arch ~]$

Code : Tout sélectionner

[test@arch ~]$ bash -x /etc/profile.d/locale.sh
+ '[' -z fr_FR.UTF-8 ']'
+ LANG=fr_FR.UTF-8
+ export LANG
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
[test@arch ~]$
Voilou.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Je ne comprend vraiment plus rien... Comment depuis le compte de test tu peux avoir LC_IDENTIFICATION listé via env | grep -E "LANG|LC" et avoir une telle sortie de bash -x /etc/profile.d/locale.sh
Peux tu redonner depuis le compte de test la sortie de

Code : Tout sélectionner

env | grep -E "LANG|LC"
echo $LC_IDENTIFICATION
bash -x /etc/profile.d/locale.sh
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Code : Tout sélectionner

[test@arch ~]$ env | grep -E "LANG|LC"
LC_MEASUREMENT=
LC_PAPER=
LC_MONETARY=
LANG=fr_FR.UTF-8
LC_NAME=
LC_COLLATE=
LC_CTYPE=
LC_ADDRESS=
LC_NUMERIC=
LC_MESSAGES=
LANGUAGE=
LC_TELEPHONE=
LC_IDENTIFICATION=
LC_TIME=
[test@arch ~]$ echo $LC_IDENTIFICATION

[test@arch ~]$ bash -x /etc/profile.d/locale.sh 
+ '[' -z fr_FR.UTF-8 ']'
+ LANG=fr_FR.UTF-8
+ export LANG
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
[test@arch ~]$
...

Bon je m'arrête là pour ce soir. Ça a l'air bien tordu.
Bonne soirée.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Hum, je n'étais pas bien réveillé lors de mon dernier message, bon au moins cela éclaircie le point. Je ne vois pas d'où ces variables d’environnements sont définis à une valeur vide...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Bonjour,

Jetons un oeil à mon répertoire /etc/
https://pastebin.com/bJhersEb
C'est le résultat de la commande ls -alR /etc/

/etc/environment est vide hormis les lignes de description commentés.

/etc/group-
/etc/gshadow-
/etc/shadow-
/etc/passwd-
Que signifie le "-" à ces fichiers ? Étant donné la spécificité de ces fichiers de configuration, faut-il utiliser les .pacnew à la place des actuels ?
Pourquoi n'ont-ils aucun droit ?

/etc/skel/ est vide ?
J'utilise zsh.


J'ai paramétré le layout du clavier.

Code : Tout sélectionner

$ localectl
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-pc
      X11 Layout: fr
     X11 Variant: latin9
Ça n'a pas eu d'incidence sur les locales de mon utilisateur principal.


Je continue les tests et recherches...
Dernière modification par Skwad le lun. 25 sept. 2017, 13:12, modifié 1 fois.
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Il ne faut surtout pas utiliser les pacnew (pour ce cas là) ! Et les fichiers finissant par un - sont des sauvegardes.
Ces fichiers sont assez critiques pour le fonctionnement du système
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Skwad
archer de cavalerie
Messages : 195
Inscription : mar. 14 déc. 2010, 20:00

Re: [smplayer] refuse de lire certains médias (en cours)

Message par Skwad »

Je pensais à ça mais qui peut faire des sauvegardes sans aucun droit ? root peut malgré tout ?




Edit:

Code : Tout sélectionner

$ locale 
LANG=fr_FR.utf8
LC_CTYPE="fr_FR.utf8"
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE="fr_FR.utf8"
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=
J'ai fr_FR.UTF-8 alors que tu as"fr_FR.utf8". Cela a-t-il une importance ?

Je suis en train de jouer avec localectl et l'option set-locale.
https://wiki.archlinux.org/index.php/Lo ... tem_locale
J'ai l'impression que ça ne conserve pas les modifications après redémarrage.

Aussi un $ systemctl status systemd-localed.service renvoie

Code : Tout sélectionner

● systemd-localed.service - Locale Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-localed.service; static; vendor preset: d
   Active: inactive (dead)
     Docs: man:systemd-localed.service(8)
           man:locale.conf(5)
           man:vconsole.conf(5)
           https://www.freedesktop.org/wiki/Software/systemd/localed
Active: inactive (dead) ?




Après avoir paramétré /etc/locale.conf comme suit:

Code : Tout sélectionner

LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.utf8" 
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE="fr_FR.utf8"
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=
J'obtiens après redémarrage

Code : Tout sélectionner

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=fr_FR.UTF-8
LC_CTYPE=fr_FR.utf8
LC_NUMERIC=fr_FR.utf8
LC_TIME=fr_FR.utf8
LC_COLLATE=fr_FR.utf8
LC_MONETARY=fr_FR.utf8
LC_MESSAGES=fr_FR.utf8
LC_PAPER=fr_FR.utf8
LC_NAME=fr_FR.utf8
LC_ADDRESS=fr_FR.utf8
LC_TELEPHONE=fr_FR.utf8
LC_MEASUREMENT=fr_FR.utf8
LC_IDENTIFICATION=fr_FR.utf8
LC_ALL=
Je n'arrive pas à savoir quels fichiers sont manquants.
Et smplayer refonctionne en attendant.

Par contre

Code : Tout sélectionner

su -
Password: 
-bash: avertissement :setlocale : LC_CTYPE : impossible de changer le paramètre de langue (fr_FR.utf8) : Aucun fichier ou dossier de ce type
-bash: avertissement :setlocale : LC_NUMERIC : impossible de changer le paramètre de langue (fr_FR.utf8) : Aucun fichier ou dossier de ce type
-bash: avertissement :setlocale : LC_TIME : impossible de changer le paramètre de langue (fr_FR.utf8) : Aucun fichier ou dossier de ce type
-bash: avertissement :setlocale : LC_COLLATE : impossible de changer le paramètre de langue (fr_FR.utf8) : Aucun fichier ou dossier de ce type
-bash: avertissement :setlocale : LC_MESSAGES : impossible de changer le paramètre de langue (fr_FR.utf8) : Aucun fichier ou dossier de ce type
et nano apparaît en anglais.

Code : Tout sélectionner

[root@arch ~]# pacman -Qkk filesystem 
warning: filesystem: /etc/arch-release (Modification time mismatch)
warning: filesystem: /etc/arch-release (Size mismatch)
backup file: filesystem: /etc/fstab (Modification time mismatch)
backup file: filesystem: /etc/fstab (Size mismatch)
backup file: filesystem: /etc/group (Modification time mismatch)
backup file: filesystem: /etc/group (Size mismatch)
warning: filesystem: /etc/gshadow (Permissions mismatch)
backup file: filesystem: /etc/gshadow (Modification time mismatch)
backup file: filesystem: /etc/gshadow (Size mismatch)
backup file: filesystem: /etc/hosts (Modification time mismatch)
backup file: filesystem: /etc/hosts (Size mismatch)
backup file: filesystem: /etc/passwd (Modification time mismatch)
backup file: filesystem: /etc/passwd (Size mismatch)
backup file: filesystem: /etc/resolv.conf (Modification time mismatch)
backup file: filesystem: /etc/resolv.conf (Size mismatch)
warning: filesystem: /etc/shadow (Permissions mismatch)
backup file: filesystem: /etc/shadow (Modification time mismatch)
backup file: filesystem: /etc/shadow (Size mismatch)
backup file: filesystem: /etc/shells (Modification time mismatch)
backup file: filesystem: /etc/shells (Size mismatch)
filesystem: 105 total files, 3 altered files
3 fichiers modifiés à la main qui n'aurait pas dû ? C'est ça ?
Peut-on y remédier ?

Désolé de vous embêter avec toutes ces questions ! :oops:
OS : Archlinux / Debian
DE : Gnome / KDE
Serveur : OpenMediaVault
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Je crains avoir dis des conneries... Je suis vraiment désolé, je crois que je suis parti sur une mauvaise piste... Oups... Car depuis un tty j'ai absolument les mêmes sorties que toi.
Donc déjà remet la configuration d'origine de /etc/locale.conf

Après avoir tout remit d'aplomb, peux tu essayer ceci dans un terminal graphique avec un utilisateur normal :

Code : Tout sélectionner

unset LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION LC_ALL
export LANG=fr_FR.UTF-8
export LC_COLLATE=C
smplayer
Il ne faut jamais définir LC_ALL, et dans /etc/locale.conf tu ne devrais pas définir tout ceci !
Par contre, ton test apporte une information très très intéressante, car ces messages d'erreurs ne sont pas du tout normaux.
Peux tu donner la sortie de

Code : Tout sélectionner

grep -Ev "^ *$|^ *#" /etc/locale.conf /etc/locale.gen
Peux tu aussi relancer en root

Code : Tout sélectionner

locale-gen
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2079
Inscription : jeu. 15 mars 2012, 05:08

Re: [smplayer] refuse de lire certains médias (en cours)

Message par waitnsea »

Skwad a écrit :
mer. 20 sept. 2017, 20:24
Bonjour, :)

Depuis quelques jours, je rencontre un bug assez gênant. Seul smplayer est concerné ! mplayer n'est pas affecté.

Si le fichier audio ou vidéo dont le nom possède au moins un caractère accentué; et/ou si dans le chemin absolu, un nom de répertoire possède au moins un caractère accentué, smplayer renvoie une erreur.
Bonsoir,
Je n'ai pas cette erreur: smplayer fonctionne parfaitement avec les caractères accentués.
Mais la sortie de $ locale donne :

Code : Tout sélectionner

LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE=C
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
Tu remarqueras les UTF en majuscules... est-ce que ça suffit à expliquer ?
benjarobin
Maître du Kyudo
Messages : 16123
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [smplayer] refuse de lire certains médias (en cours)

Message par benjarobin »

Pour information fr_FR.UTF-8, fr_FR.utf-8 et fr_FR.utf8 représentent la même chose, bien que cela soit recommandé d'avoir la notation suivante : fr_FR.utf-8
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Répondre