[Résolu] Redshift

Applications, problèmes de configuration réseau
Répondre
obelix1502
Daikyu
Messages : 59
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

[Résolu] Redshift

Message par obelix1502 » mer. 31 janv. 2018, 00:47

Bonsoir,

J'essaie, après avoir lu le wiki, d'installer et de lancer redshift.

Mais la commande sudo systemctl start redshift-gtk me renvoit :

Code : Tout sélectionner

Failed to start redshift-gtk.service: Unit redshift-gtk.service not found.
Or, il existe bien dans /usr/lib/systemd/user/redshift-gtk.service
Il est bien installé aussi.
Quand j'essaie sudo /usr/bin/redshift-gtk
Le retour est :

Code : Tout sélectionner

Traceback (most recent call last):
  File "/usr/bin/redshift-gtk", line 26, in <module>
    from redshift_gtk.statusicon import run
  File "/usr/lib/python3.6/site-packages/redshift_gtk/statusicon.py", line 44, in <module>
    from . import utils
  File "/usr/lib/python3.6/site-packages/redshift_gtk/utils.py", line 23, in <module>
    from xdg import BaseDirectory as base
ModuleNotFoundError: No module named 'xdg'
Et xdg-menu est installé lui-aussi ainsi que xdg-gtk.

Que puis-je faire de plus ?

Merci.
Dernière modification par obelix1502 le ven. 02 févr. 2018, 00:20, modifié 1 fois.
System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-E v: Rev X.0x
Bios: American Megatrends v: 0706 date: 11/11/2015
Quad core Intel Core i5-5675C
Card: NVIDIA GM107 [GeForce GTX 750]
ID-1: /dev/sdb model: ST3000DM001 size: 3000.6GB
ID-2: /dev/sdc model: WDC_WD3003FZEX size: 3000.6GB
ID-3: /dev/sdd model: KINGSTON_SV300S3 size: 240.1GB
ID-4: /dev/sde model: WDC_WD3003FZEX size: 3000.6GB
ID-5: USB /dev/sda model: Backup+_Desk size: 4000.8GB
Ram : 16 Go

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [erreur] Redshift

Message par waitnsea » mer. 31 janv. 2018, 06:11

obelix1502 a écrit :
mer. 31 janv. 2018, 00:47
Que puis-je faire de plus ?
Bonjour,
Ce n'est pas une bonne idée de vouloir lancer une appli GTK par un service en root, root n'a pas droit aux applications graphiques sur Arch. Vois plutôt Systemd/User
Et de fait :
$ systemctl --user enable redshift-gtk
Created symlink /home/waitnsea/.config/systemd/user/default.target.wants/redshift-gtk.service → /usr/lib/systemd/user/redshift-gtk.service.
$ systemctl --user start redshift-gtk
fonctionnent du premier coup...
Ceci dit, sur Plasma, redshift se passe très bien de service : il suffit de mettre l'applet plasma5-applets-redshift-control dans la barre des tâches avec simplement "Démarrage automatique" coché.
Mais il faut modérer un peu les réglages pour ne pas voir rouge...
> Transition douces, > échelon 25 > step 0.05, et dans 'Avancé' > échelle de T° 5500 Jour 4500 nuit me suffisent amplement...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

obelix1502
Daikyu
Messages : 59
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [erreur] Redshift

Message par obelix1502 » mer. 31 janv. 2018, 17:30

Merci,
Les commandes systemctl fonctionnent, mais redshift ne se lance toujours pas.
L'applet plasma5-applets-redshift-control est bien installé lui aussi, mais ne se lance pas non plus.
System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-E v: Rev X.0x
Bios: American Megatrends v: 0706 date: 11/11/2015
Quad core Intel Core i5-5675C
Card: NVIDIA GM107 [GeForce GTX 750]
ID-1: /dev/sdb model: ST3000DM001 size: 3000.6GB
ID-2: /dev/sdc model: WDC_WD3003FZEX size: 3000.6GB
ID-3: /dev/sdd model: KINGSTON_SV300S3 size: 240.1GB
ID-4: /dev/sde model: WDC_WD3003FZEX size: 3000.6GB
ID-5: USB /dev/sda model: Backup+_Desk size: 4000.8GB
Ram : 16 Go

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [erreur] Redshift

Message par waitnsea » mer. 31 janv. 2018, 17:49

obelix1502 a écrit :
mer. 31 janv. 2018, 17:30
Les commandes systemctl fonctionnent, mais redshift ne se lance toujours pas.
L'applet plasma5-applets-redshift-control est bien installé lui aussi, mais ne se lance pas non plus.
Tu as lancé l'un puis l'autre, j'imagine, pas les 2 ensemble
Commence avec l'applet seule, et donne le retour de $ ps -ux |grep redshift avant et après avoir cliqué sur l'icône, ainsi que celui de $ systemctl --user status redshift
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

obelix1502
Daikyu
Messages : 59
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [erreur] Redshift

Message par obelix1502 » mer. 31 janv. 2018, 22:20

Avant : bruno 10350 0.0 0.0 10888 2200 pts/0 S+ 22:16 0:00 grep redshift

Après : bruno 10383 0.0 0.0 10888 2304 pts/0 S+ 22:18 0:00 grep redshift

La troisième (mais j'avais stoppé systemctl) :

Code : Tout sélectionner

● redshift.service - Redshift display colour temperature adjustment
   Loaded: loaded (/usr/lib/systemd/user/redshift.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: http://jonls.dk/redshift/
Puis lorsque je "kill" le processus et que je relance, j'ai toujours la même erreur :

Code : Tout sélectionner

[bruno@bruno ~]$ redshift-gtk
Traceback (most recent call last):
  File "/usr/bin/redshift-gtk", line 26, in <module>
    from redshift_gtk.statusicon import run
  File "/usr/lib/python3.6/site-packages/redshift_gtk/statusicon.py", line 44, in <module>
    from . import utils
  File "/usr/lib/python3.6/site-packages/redshift_gtk/utils.py", line 23, in <module>
    from xdg import BaseDirectory as base
ModuleNotFoundError: No module named 'xdg'
System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-E v: Rev X.0x
Bios: American Megatrends v: 0706 date: 11/11/2015
Quad core Intel Core i5-5675C
Card: NVIDIA GM107 [GeForce GTX 750]
ID-1: /dev/sdb model: ST3000DM001 size: 3000.6GB
ID-2: /dev/sdc model: WDC_WD3003FZEX size: 3000.6GB
ID-3: /dev/sdd model: KINGSTON_SV300S3 size: 240.1GB
ID-4: /dev/sde model: WDC_WD3003FZEX size: 3000.6GB
ID-5: USB /dev/sda model: Backup+_Desk size: 4000.8GB
Ram : 16 Go

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [erreur] Redshift

Message par waitnsea » jeu. 01 févr. 2018, 07:31

obelix1502 a écrit :
mer. 31 janv. 2018, 22:20
Puis lorsque je "kill" le processus et que je relance, j'ai toujours la même erreur :
Le processus n'est pas lancé, n’apparaît que le lancement de recherche avec grep. Une bonne réponse aurait été :

Code : Tout sélectionner

waitnsea       1389  0.0  0.0  69444  5004 ?        S    07:02   0:00 /usr/bin/redshift -l 43.34 7.04 -t 5500 4500 -b 1 1 -g 1 1 1
waitnsea       1658  0.0  0.0  10884  2348 pts/2    S+   07:04   0:00 grep --color=auto redshift
Si tu as bien installé :

Code : Tout sélectionner

community/plasma5-applets-redshift-control 1.0.18-1 [installed]
community/redshift 1.11-5 [installed]
tu n'as pas besoin de lancer quoique ce soit en commande, tu mets l'applet dans la barre des tâches par le réglage du contenu de celle-ci, puis tu accèdes aux réglages par un clic-droit sur l’icône puis clic-gauche sur Paramètres...
Le service existe, "disabled", ce qui est normal si tu lances uniquement par l'icône (si tu cumules les 2 tu aurais des clignotements indésirables).
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
vv221
Hankyu
Messages : 32
Inscription : ven. 16 déc. 2016, 14:52
Contact :

Re: [erreur] Redshift

Message par vv221 » jeu. 01 févr. 2018, 08:45

obelix1502 a écrit :
mer. 31 janv. 2018, 22:20

Code : Tout sélectionner

[bruno@bruno ~]$ redshift-gtk
Traceback (most recent call last):
  File "/usr/bin/redshift-gtk", line 26, in <module>
    from redshift_gtk.statusicon import run
  File "/usr/lib/python3.6/site-packages/redshift_gtk/statusicon.py", line 44, in <module>
    from . import utils
  File "/usr/lib/python3.6/site-packages/redshift_gtk/utils.py", line 23, in <module>
    from xdg import BaseDirectory as base
ModuleNotFoundError: No module named 'xdg'
Le paquet 'python-xdg' semble manquant ou mal installé chez toi, mais il est nécessaire pour utiliser redshift-gtk.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [erreur] Redshift

Message par waitnsea » jeu. 01 févr. 2018, 09:02

vv221 a écrit :
jeu. 01 févr. 2018, 08:45
[Le paquet 'python-xdg' semble manquant ou mal installé chez toi, mais il est nécessaire pour utiliser redshift-gtk.
C'est donc bien le paquet community/redshift qu'il faut installer et il n'y aura pas de problèmes de dépendances
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

obelix1502
Daikyu
Messages : 59
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [erreur] Redshift

Message par obelix1502 » ven. 02 févr. 2018, 00:19

Merci à vous tous ;)

C'est résolu. C'était bien ce bête paquet python-xdg qui n'était pas installé.
Je me demande toujours pourquoi d'ailleurs...
Mais je ne comprends pas le Wiki non plus : pourquoi parler de lancer un .service avec systemctl alors qu'avec le redshift-gtk, c'est si facile (quand on n'est pas un co....d comme moi qui n'installe pas toutes les dépendances ;) ).
System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-E v: Rev X.0x
Bios: American Megatrends v: 0706 date: 11/11/2015
Quad core Intel Core i5-5675C
Card: NVIDIA GM107 [GeForce GTX 750]
ID-1: /dev/sdb model: ST3000DM001 size: 3000.6GB
ID-2: /dev/sdc model: WDC_WD3003FZEX size: 3000.6GB
ID-3: /dev/sdd model: KINGSTON_SV300S3 size: 240.1GB
ID-4: /dev/sde model: WDC_WD3003FZEX size: 3000.6GB
ID-5: USB /dev/sda model: Backup+_Desk size: 4000.8GB
Ram : 16 Go

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [erreur] Redshift

Message par waitnsea » ven. 02 févr. 2018, 02:37

obelix1502 a écrit :
ven. 02 févr. 2018, 00:19
Mais je ne comprends pas le Wiki non plus : pourquoi parler de lancer un .service avec systemctl alors qu'avec le redshift-gtk, c'est si facile (quand on n'est pas un co....d comme moi qui n'installe pas toutes les dépendances ;) ).
Pourquoi tu attaques le Wiki alors que tu n'as pas utilisé les paquets officiels ?!
Pourquoi tu utilises des paquets AUR sans avoir essayé d'abord les dépôts maintenus officiellement ?
Et rien ne t'interdit, bien au contraire, de corriger le Wiki, si tu précises bien "dans le cas de l'utilisation du paquet AUR/..."
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

obelix1502
Daikyu
Messages : 59
Inscription : dim. 09 oct. 2016, 18:54
Localisation : Belgique
Contact :

Re: [Résolu] Redshift

Message par obelix1502 » ven. 02 févr. 2018, 03:28

Mais je n'attaque pas le Wiki, bien du contraire, c'est une source inépuisable de renseignements.
Je dis juste que parfois, il est trop prefectionniste. Dans ce cas-ci, en tous cas.
Je n'ai pas utilisé les paquets AUR avant ceux des dépôts offficiels. J'avais juste installé ce logiciel via la logithèque. Et il ne fonctionnait pas, c'est tout...
Pourquoi lors de l'installation sudo pacman -S redshift-gtk, le paquet python-xdg, ne s'installe-t-il pas ? Maintenant, j'ai compris, il faut aller voir plus loin.
Il est vrai que je suis un noob chez Arch, moi qui vien du monde Debian tout en étant passé aussi sous Manjaro. Vous comprenez bien que ce n'est pas un noob comme moi qui vais aller modifier le wiki... non,mais... avec 10 ans d'expérience, je ne dis pas... ;)
System: ASUS product: All Series
Mobo: ASUSTeK model: Z97-E v: Rev X.0x
Bios: American Megatrends v: 0706 date: 11/11/2015
Quad core Intel Core i5-5675C
Card: NVIDIA GM107 [GeForce GTX 750]
ID-1: /dev/sdb model: ST3000DM001 size: 3000.6GB
ID-2: /dev/sdc model: WDC_WD3003FZEX size: 3000.6GB
ID-3: /dev/sdd model: KINGSTON_SV300S3 size: 240.1GB
ID-4: /dev/sde model: WDC_WD3003FZEX size: 3000.6GB
ID-5: USB /dev/sda model: Backup+_Desk size: 4000.8GB
Ram : 16 Go

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1986
Inscription : jeu. 15 mars 2012, 05:08

Re: [Résolu] Redshift

Message par waitnsea » ven. 02 févr. 2018, 03:45

obelix1502 a écrit :
ven. 02 févr. 2018, 03:28
Il est vrai que je suis un noob chez Arch, moi qui vien du monde Debian tout en étant passé aussi sous Manjaro. Vous comprenez bien que ce n'est pas un noob comme moi qui vais aller modifier le wiki... non,mais... avec 10 ans d'expérience, je ne dis pas... ;)
Faux, tes ajouts et corrections seront bienvenus et relus, dans le cas du Wiki inter en particulier où ils n'acceptent une modification que si tu y ajoutes la raison (et éventuellement les sources)
Tu peux essayer de remplacer le paquet AUR par les 2 paquet Community (redshift + l'applet), car plus tu as de paquets AUR plus tes mises à jour demandent des interventions manuelles, et plus tu as de chance qu'un paquet non maintenu pose problème.
C'est une bonne politique de n'utiliser AUR qu'en cas d'absence d'un programme ou de dysfonctionnement du paquet officiel (et dans ce cas faire un rapport de bug)
C'est aussi une bonne chose de voter pour un paquet que tu juges nécessaire
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Répondre