Page 1 sur 1

[bash] Erreurs inconnues (pour moi) !

Publié : jeu. 05 avr. 2018, 05:37
par obelix1502
Bonjour,

J'ai un problème avec mon bash. J'utilise comme émulateur de terminal Tilix et tout d'une fois (il a toujours fonctionné), j'ai plusieurs problèmes avec l'écriture dans le terminal.
Exemples :
Tous les mots qui composent mon /home et qui sont accentués font l'objet d'un espace vide après celui-ci. (Vidéos => Vidé os, Téléchargements => Té lé chargements). Mais pas dans Thunar.
Je ne peux deleter une commande jusqu'au bout : il me laisse une ou deux lettre après le $ et ne veut plus les effacer.
Lorsque je me déplace avec les flèches du clavier, je ne peux pas non plus aller jeusqu'au bout : je ne peux aller jusqu'au $...
Parfois, lorsque j'emploie delete ou la flèche de suppression, il se comporte comme si j'employais les flèches de direction du clavier :( :o :o

Quelqu'un a-t-il déjà eu ce cas ?
Si oui, comment y remédier ?
Merci. :D

Re: [bash] Erreurs inconnues (pour moi) !

Publié : jeu. 05 avr. 2018, 06:32
par waitnsea
Bonjour,
Tu as fait une mise à jour ce matin ? Tilix fonctionne à nouveau normalement chez moi depuis ...
À ce sujet, où est passé le fichier de conf de Tilix ? Auparavant c'était .config/Terminix, mais maintenant il est dit que c'est dans dconf, mais dconf/user est illisible...

Re: [bash] Erreurs inconnues (pour moi) !

Publié : jeu. 05 avr. 2018, 15:11
par obelix1502
Merci.

Mais non, je n'ai pas eu de mise à jour.
J'ai désinstallé Tilix et installé Tilix-git depuis AUR, mais pas de changement.
Avec le terminal XFCE, aucun problème. Donc, ça vient bien de Tilix.
dconf est illisible chez moi aussi et plus de terminix.

Re: [bash] Erreurs inconnues (pour moi) !

Publié : ven. 06 avr. 2018, 13:59
par sukolyn
ce n'est donc pas un problème venant de bash, mais du terminal.

le sujet devrait être :
[Xorg][terminal][tilix] espace après caractères accentués

tu as eu la bonne attitude : tester un autre terminal.
problème de police ? à pas fixe, ou non ?

Re: [bash] Erreurs inconnues (pour moi) !

Publié : ven. 06 avr. 2018, 14:14
par waitnsea
sukolyn a écrit :
ven. 06 avr. 2018, 13:59
ce n'est donc pas un problème venant de bash, mais du terminal.
Non, je dirais plutôt un problème avec les applis Gnome, j'ai eu transitoirement des problèmes d'affichage avec toutes mes applis Gnome et GTK (synapse, cherrytree, tilix,...) dans mon environnement Plasmashell
Il y a aussi sûrement conflit Kwin/Nvidia, tout ça est apparu au passage au noyau 4.15 et nvidia 390 et s'est arrangé progressivement au fur et à mesure des MaJ
J'attends la même chose pour le passage au 4.16 - mais je ferai une grosse pause dans les MaJ, pas envie de me prendre la tête comme cette fois-ci... :lol:

Re: [bash] Erreurs inconnues (pour moi) !

Publié : mer. 25 avr. 2018, 23:41
par obelix1502
Mais moi, j'ai bien une Nvidia GTX750, mais je ne l'ai pas activée (peur de faire ddes bêtises :( )
Mais avec le pilote libre Xorg, il y a aussi ce genre de problèmes ?

Re: [bash] Erreurs inconnues (pour moi) !

Publié : jeu. 26 avr. 2018, 07:07
par waitnsea
obelix1502 a écrit :
mer. 25 avr. 2018, 23:41
Mais moi, j'ai bien une Nvidia GTX750, mais je ne l'ai pas activée (peur de faire ddes bêtises :( )
Mais avec le pilote libre Xorg, il y a aussi ce genre de problèmes ?
Tu veux parler de xf86-video-nouveau ? No se, je ne l'utilise pas.
Le passage au noyau 4.16 s'est bien passé (il y aura bientôt un upgrade 4.16.4-1, actuellement en testing)
Je continue à avoir des petits freeze et des sessions qui se corrompent à la longue avec les applis GTK mais surtout avec Firefox, bien qu'il y ait de moins en moins d'erreurs avec les nouveaux onglets.
De toute évidence il y a des dev qui bossent dur et qui progressent, restons zen