[Navigateurs] Problème de chargement de pages (Résolu)

Applications, problèmes de configuration réseau
Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

[Navigateurs] Problème de chargement de pages (Résolu)

Message par Harashi » sam. 15 sept. 2018, 16:33

Bonjour à tous,

Depuis maintenant une bonne semaine (mais je ne me souviens plus si c'est suite à une mise à jour ou non), j'ai des difficultés à charger des pages web sur Arch, et ce quel que soit le navigateur (firefox ou epiphany/gnome-web). Ce problème ne m'arrive pas avec Ubuntu (voir signature), donc ce n'est ni l'ordinateur ni la box (que j'ai quand même éteint et rallumé, sans succès).

Détails du problème:

- Les images ne se chargent pas immédiatement, voire pas du tout
- Le début des vidéos se charge (une dizaine de secondes en général) puis elles affichent un chargement infini
- Le navigateur affiche une page blanche et indique un chargement qui dure une bonne minute, puis s'arrête. Si ensuite j'appuie sur "actualiser", la page se charge vite et normalement.
- Ce problème est aléatoire, il se manifeste ou non sur n'importe quel type de page et peut ne pas se manifester pendant une demi-heure ou carrément empêcher toute navigation.

Solutions envisagées:

- Éteindre et rallumer la box, suite à ce fil
- Réinstaller Network-manager
- Passer au noyau linux-lts

Aucune n'a fonctionné, et comme vous vous en doutez c'est du tâtonnement. Je n'y connais pas grand chose en réseau (et je ne suis pas certain que le problème vienne de là) et en plus je n'ai que peu de temps en cemoment pour m'en occuper. Si une bonne âme pouvait m'aider à trouver ne serait-ce que l'origine du problème je lui en serait reconnaissant.
Dernière édition par Harashi le dim. 16 sept. 2018, 15:22, édité 1 fois.
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

jean_no
yeomen
Messages : 277
Inscription : dim. 09 sept. 2007, 12:19

Re: [Navigateurs] Problème de chargement de pages

Message par jean_no » sam. 15 sept. 2018, 18:04

Salut

Essayes la proposition de ce fil:
viewtopic.php?f=5&t=20211&p=167672#p167672

A+

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Navigateurs] Problème de chargement de pages

Message par Harashi » dim. 16 sept. 2018, 09:59

jean_no a écrit :
sam. 15 sept. 2018, 18:04
Essayes la proposition de ce fil:
viewtopic.php?f=5&t=20211&p=167672#p167672
Salut,

Effectivement cela semble venir de là, après un

Code : Tout sélectionner

# sysctl net.ipv4.tcp_ecn=2
tout semble remarcher normalement. J'avais vu ce fil rapidement mais n'avais pas investigué au-delà du premier message car mon problème se produisait en wi-fi et seulement sur navigateur. Mais j'ai aussi une Bbox, donc l'origine est probablement la même.

De ce que j'ai vu, on peut donc espérer une correction du "bug" dans les dépôts Arch à l'avenir ?

En tout cas merci pour cette solution
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Navigateurs] Problème de chargement de pages

Message par benjarobin » dim. 16 sept. 2018, 10:54

Techniquement ce n'est pas un bug de Linux, mais de la Box...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Navigateurs] Problème de chargement de pages

Message par Harashi » dim. 16 sept. 2018, 14:05

benjarobin a écrit :
dim. 16 sept. 2018, 10:54
Techniquement ce n'est pas un bug de Linux, mais de la Box...
Oui, c'est pourquoi j'ai mis des guillemets à "bug". Je voulais en fait savoir si on pouvait espérer une solution à ce problème externe dans les dépôts de Arch ou bien attendre un mouvement de la part de Bouygues (parce que dans ce dernier cas cela sera probablement assez long...)
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15216
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Navigateurs] Problème de chargement de pages

Message par benjarobin » dim. 16 sept. 2018, 14:25

La solution de contournement a été donnée... Il suffit de l'appliquer. Pour automatiser la chose il suffit de créer un fichier dans /etc/sysctl.d/ avec la bonne configuration
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Navigateurs] Problème de chargement de pages

Message par Harashi » dim. 16 sept. 2018, 15:22

J'en déduis donc que la réponse est non ^^ Je vais automatiser tout ça et mettre le sujet en résolu.
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Répondre