Page 1 sur 1

[x265] update

Publié : lun. 08 oct. 2018, 16:44
par Frenzer
Bonjour, lors de la mise à jour j'ai ce message : l’installation de x265 (2.9-1) casse la dépendance « libx265.so=160-64 » requise par ffmpeg

Pourtant j'ai toujours fait les mises à jour complètes, de quoi ça peut venir et comment je peux régler ça ?

Merci

Re: [x265] update

Publié : lun. 08 oct. 2018, 17:02
par benjarobin
Bonjour,
Peux tu donner la sortie de :

Code : Tout sélectionner

pacman -Qs ffmpeg
pacman -Qdt
pacman -Qm

Re: [x265] update

Publié : mer. 10 oct. 2018, 17:05
par jimarch
Bonjour !
Même problème pour moi.

En ce qui me concerne, les réponses aux questions posées par Benjarobin sont les suivantes :
jimarch@jimarch-cl1:~ [11:53:27] #6
$ pacman -Qs ffmpeg
local/ffmpeg 1:4.0.2-3
Complete solution to record, convert and stream audio and video
local/ffmpeg-compat-57 3.4.2-2
Compatibility package for ffmpeg to provide versions 57 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package
local/ffmpegthumbs 18.08.1-1 (kde-applications kdemultimedia)
FFmpeg-based thumbnail creator for video files
local/gst-libav 1.14.4-1
GStreamer Multimedia Framework ffmpeg Plugin
local/qtav 1.12.0-4
A cross-platform multimedia playback framework based on Qt and FFmpeg
local/transcoder 0.0.6-4
Video converter for Linux using GTK+ and ffmpeg.
$ pacman -Qdt
automoc4 0.9.88-9
doxygen 1.8.14-1
extra-cmake-modules 5.50.0-1
go 2:1.11.1-1
gtk-doc 1.29-1
intltool 0.51.0-3
jq 1.5-6
lib32-libcurl-compat 7.61.1-1
lib32-qjson 0.8.1-4
libappindicator-gtk2 12.10.0-12
pangox-compat 0.0.2+2+gedb9e09-2
sip 4.19.13-1
w3m 0.5.3.git20180125-1
yarn 1.10.1-1
yasm 1.3.0-2
$ pacman -Qm
acroread 9.5.5-9
acroread-fonts-systemwide 1:DC_2015.020.20039-1
amaze 0.2-2
anchor-cms 0.9.2-1
apulse 0.1.12-1
arch-diff 0.2-2
archlinux-artwork 1.6-4
archlinux-themes-kdm 1.4-4
archlinux-themes-sddm 2.0-1
asoundconf 1:1.2-1
attica-qt4 0.4.2-4
audio-recorder 2.1.3-1
automoc4 0.9.88-9
backup-gmail 0.1.2.1-2
borgweb-git 0.1.4.r59.ga9e694d-1
brave 0.23.105-1
breeze-hacked-cursor-theme 1.0-3
breeze-kde4 5.13.4-1
chromium-pepper-flash 1:16.0.0.305-1
cmp_version 3.0.0-2
cpu-x 3.2.3-1
cryfs-gui 1.2.0-1
cryptkeeper 0.9.5-6
dhcpcd-dbus 0.6.0-3
dhcpcd-ui 0.7.5-2
dirsyncpro 1.53-1
dropbox 55.4.171-1
easytranscript 2.50.7-3
edid-decode-git r182.ab18bef-1
eg 1.1.0-1
emerald-icon-theme-kde 2.0-3
enchant1.6 1.6.1-8
epson-inkjet-printer-escpr 1.6.29-1
ffmpeg-compat-57 3.4.2-2
fonts-meta-base 1-2
fonts-meta-extended-lt 3-1
franz 5.0.0_beta.18-1
freefilesync 10.4-1
fslint 2.46-1
fswebcam 20140113-2
gimagereader 3.2.3-4
gkleds 0.8.2-2
gksu 2.0.2-6
gmvault-git 20160431-1
gnome-breeze-git 102.49a5cd6-1
gnome-mime-data 2.18.0-8
gnome-vfs 2.24.4-10
goocanvas1 1.0.0-5
google-musicmanager 1.0.467.4929_r0-4
gqview 2.0.4-6
grive 0.5.0-12
grive-tools 1.15-6
gtk-theme-e17gtk-git V3.22.2.r1.gecebae2-1
gtkdialog-svn 514-7
gtkspellmm 3.0.5-2
hubic 2.1.0-58
hubic-gtk 0.6.2-1
hw-probe 1.4-1
inxi 3.0.24-1
isoimagewriter 0.2-1
java-commons-collections 4.1-1
kde-l10n-fr 17.08.3-2
kde-servicemenus-komparemenu 0.1-3
kde-servicemenus-lprinter-qt 0.5.3-2
kde-thumbnailer-apk 1.0-3
kde-thumbnailer-epub 1.1.9b-1
kdeartwork-colorschemes 15.08.3-3
kdeartwork-desktopthemes 15.08.3-3
kdeartwork-emoticons 15.08.3-3
kdeartwork-iconthemes 15.08.3-3
kdeartwork-weatherwallpapers 15.08.3-3
kdebase-runtime 17.08.3-4
kdebindings-python-common 4.14.3-7
kdebindings-python2 4.14.3-7
kdelibs 4.14.38-4
kdeplasma-applets-netspeed 0.2-2
kio-mtp 0.75.20140630-1
konsolepart4 4.14.3-8
kservicemenueditor 0.2a-4
kuser-frameworks 16.08.3-1
lcms 1.19-7
lib32-apulse 0.1.10-1
lib32-flashplugin 30.0.0.154-1
lib32-libdbusmenu-qt 0.9.2-4
lib32-libmng 2.0.3-1
lib32-qjson 0.8.1-4
lib32-qt4 4.8.7-14
lib32-sni-qt 0.2.6-6
libbonobo 2.32.1-4
libcpuid-git 2:0.4.0.r41.gf178de9-1
libgcj17-bin 1:6.3.0_18+deb9u1-1
libgksu 2.0.12-8
libidn11 1.34-1
libkface-frameworks-git r727.5e68cb9-1
libuser 0.62-2
lprof 1.11.4.1-5
makeblog 0.0.6-1
megasync-qt5 2.9.8-1
menutray 0.52-1
ms-sys 1:2.4.1-2
multisystem 1.0425-1
openwmail-bin 1.0.0-1
orbit2 2.14.19-6
oxygen-kde4 5.13.4-1
p7zip-gui 16.02-4
pacman-utils 1.1.0-1
pcloud-drive 1.4.2-1
pcmciautils 018-8
pdftk-bin 2.02_4_b2-3
perl-linux-desktopfiles 0.25-1
phonon-qt4 4.10.1-3
phonon-qt4-gstreamer 4.9.0-4
phonon-qt4-vlc 0.10.1-2
photorecover 0.9.0-1
php-mcrypt 7.1.12-2
pianobooster 0.6.4b-1
pkgbrowser 0.21-3
polkit-qt4 0.112.0+git20180107-1
pygoocanvas 0.14.1-7
pyqt4-common 4.12.1-2
python-backports.ssl 0.0.9-1
python-cmp_version 3.0.0-2
python-func_timeout 4.3.0-2
python-mechanicalsoup 0.9.0-3
python-pyqt4 4.12.1-2
python-pyside-common 1.2.4-9
python2-gmusicapi 11.0.1-1
python2-gnomevfs 2.28.1-9
python2-gpsoauth 0.4.1-1
python2-imapclient 1.0.2-1
python2-mechanicalsoup 0.9.0-3
python2-proboscis 1.2.6.0-2
python2-pypdf2 1.26.0-1
python2-pyqt4 4.12.1-2
python2-pyside 1.2.4-9
python2-shiboken 1.2.4-4
python2-validictory 1.1.1-1
qdirstat-git 20171008.ea76d73-1
qt-recordmydesktop 0.3.8-7
qt3 1:3.3.8b-12
qtemu 1.0.5-11
recorditnow 0.8.1-10
rednotebook 2.6.1-1
rstudio-desktop-bin 1.1.456-1
sddm-archlinux-theme-git 0.1.r13.ge2054bd-1
sddm-config-editor-git 0.1.r22.g718206d-1
shiboken 1.2.4-4
skype-call-recorder 0.11-2
solarized-sddm-theme 0.1.7-1
stapler 0.4-4
system-config-samba 1.2.100-1
systemd-kcm 1.2.1-4
tkpacman 1.9.0-1
tmpwatch 2.11-3
transcoder 0.0.6-4
ttf-caladea 20130214-1
ttf-courier-prime 1.203-3
ttf-gelasio-ib 1.00-6
ttf-heuristica 1.0.2-3
ttf-impallari-cantora 1.001-2
ttf-mac-fonts 20100901.134-1
ttf-merriweather 1:2.003-1
ttf-merriweather-sans 1.006-4
ttf-noto-fonts-ib 20170227-1
ttf-opensans 1.101-1
ttf-oswald 4.100-2
ttf-oxygen 1:5.4.3-4
ttf-quintessential 1.001-4
ttf-signika 1.002-2
ttf-symbola 11.00-3
tuned 2.9.0-2
ucx 17.0.0.5-1
vivaldi 2.0.1309.29-3
vte 0.28.2-8
wallpapy 1.0.0-2
whatsie 2.1.0-6
xcalib 0.10-1
xorg-server-utils 7.6-4
yaourt 1.9-1
yay 8.1139-1
A priori, tout semble à jour....
Mais comme il y a un pb, il y a un truc qq part ! :D

Cela ne viendrait-il pas de :
aur/ffmpeg-compat-57 3.4.2-2 [installed] (Out of Date) (5) (0,26)
qui est "Out of date" ???
mais aucune nouvelle version est proposée.
Faut-il le désinstaller ?

Re: [x265] update

Publié : mer. 10 oct. 2018, 17:31
par waitnsea
jimarch a écrit :
mer. 10 oct. 2018, 17:05
Cela ne viendrait-il pas de :
aur/ffmpeg-compat-57 3.4.2-2 [installed] (Out of Date) (5) (0,26)
qui est "Out of date" ???
mais aucune nouvelle version est proposée.
Faut-il le désinstaller ?
Bonjour,
Je vois dans mon pacman.log

Code : Tout sélectionner

│[2018-03-09 18:59] [PACMAN] Running 'pacman -Rns x265 ffmpeg avidemux-qt' 
J'avais donc dû désinstaller x265 avec les paquets qui l'avaient en dépendance, faire ma mise à jour et réinstaller
Si tu notes bien ce que tu désistalles aucun risque, tu réinstalles. Si le paquet est Out-of-date tu attends qu'il ne le soit plus ou tu installes une version git s'il y en a une...
Edit: la date est en notation US, donc 9 mars, pas 3 septembre...

Re: [x265] update

Publié : mer. 10 oct. 2018, 18:31
par benjarobin
Non, il ne faut pas désinstaller x265 !!! Surtout pas.
Pour faire bref, oui c'est bien ffmpeg-compat-57 qui te pose problème, si tu n'en as pas besoin il faut le supprimer. Sinon je crains qu'il faudra quand même le supprimer

Mais tu as plus globalement un "petit" souci de maintenance de ton Arch Linux...
La sortie de pacman -Qdt devrait être vide si possible. Si tu as besoin d'un paquet alors tu dois le marquer comme installé explicitement, sinon il doit être supprimé.

Et pour la sortie de pacman -Qm, elle devrait te retourner la liste des paquets installés via AUR. Hors ici je ne pense pas que tu as installé autant de paquet, cette liste devrait contenir un nombre assez limité de paquet... Dans cette liste il y a des paquets qui n'existent même plus sur AUR.

Re: [x265] update

Publié : mer. 10 oct. 2018, 18:44
par waitnsea
benjarobin a écrit :
mer. 10 oct. 2018, 18:31
Non, il ne faut pas désinstaller x265 !!! Surtout pas.
Oh le drame !

Code : Tout sélectionner

Required By (8)

    avidemux-qt
    ffmpeg (requires libx265.so)
    libheif
    avidemux-cli (optional)
    vlc (optional)
    avidemux (make)
    libheif (make)
    vlc (requires libx265.so) (make)

Ça casserait un système de le désinstaller ?
Peux-tu expliquer un peu ?

Re: [x265] update

Publié : mer. 10 oct. 2018, 19:47
par benjarobin
Non cela ne casse pas le système, mais cela risque de désinstaller beaucoup trop de paquets qu'il faudra réinstaller ensuite.

Et ce n'est clairement pas un bon réflexe que tu donnes. La cause n'est pas x264 mais bien ailleurs

Re: [x265] update

Publié : jeu. 11 oct. 2018, 17:42
par Frenzer
Après avoir attendu la mise à jour est passée, c'était peut-être le miroir qui était en train de se mettre à jour ?

Re: [x265] update

Publié : jeu. 11 oct. 2018, 20:12
par jimarch
J'ai désinstallé ffmpeg-compat-57 et la mise à jour s'est effectué normalement !

@Benjarobin
Ok, je vais faire un peu de nettoyage, mais je suis actuellement à l'étranger avec une liaison internet très lente.
Je vais attendre d'être dans de meilleurs conditions !

merci à tous !

pour moi, le sujet est résolu mais je laisse Frenzer mettre le point final puisque c'est lui qui a initié ce fil de discussion !