[virtualbox] Impossible d'installer windows 10

Applications, problèmes de configuration réseau
Elbarto
Elfe
Messages : 671
Inscription : jeu. 22 déc. 2011, 23:15

[virtualbox] Impossible d'installer windows 10

Message par Elbarto » mer. 21 nov. 2018, 11:24

Bonjour,

j'essaie d'installer dans virtualbox (version 5.2.22-1) l'image iso officielle de windows 10 (build 1809 version française d'octobre) , disponible gratuitement sur le site de microsoft,
mais je rencontre des problèmes :

- forte lenteur de l'installation

- parfois l'installation de windows 10 se freeze durant l'étape "copie des fichiers d'installation" (se bloque à 17%), seule la machine virtuelle se freeze, pas l'OS host (archlinux)

- mais parfois l'installation va plus loin et ne se freeze pas, le problème c'est qu'une fois arrivée à l'étape de création du compte utilisateur (login, mot de passe) l'assistant d'installation recommence à nouveau l'étape de création (comme dans une boucle infinie),

pour ceux qui ont déjà installé windows10 sur une machine physique c'est la fastidieuse étape où l'on doit répondre à des questions diverses relatives à l'envoi d'infos privées, censées nous faciliter la vie (et qui font polémiques, le non respect de la vie privée), une fois arrivé à la fin de cette étape au lieu d'afficher le bureau l'installateur recommence de manière infinie cette fastidieuse étape,

pensant à une version boguée de l'iso j'ai téléchargé la précédente image iso d'avril dernier mais les problèmes sont encore présents : freezes aléatoires, et si par chance pas de freeze l'installation ne se termine jamais,

j'ai essayé ce workaround du wiki archlinux concernant virtualbox mais ça ne donne rien :
https://wiki.archlinux.org/index.php/Vi ... SK_FULL%22

les réglages de cette VM windows 10 dans virtualbox :

- 2 coeurs pour le CPU
- 2 Go ram
- pas d'acceleration 2D et 3D (j'ai essayé aussi de les activer mais ça ne résout pas les problèmes de lenteur et de freeze)
- sata controleur pour le disque virtuel et le lecteur optique virtuel
- USB 2.0 controleur
- format VDI pour le disque virtuel (50 Go), allocation dynamique de la taille
- configuration réseau par pont
- paramètre de paravirtualisation : "défaut", j'ai testé aussi "kvm", puis "héritage"

le paquet aur "Oracle VM VirtualBox Extension Pack" a été installé

la configuration de mon PC :
- Intel Core2 Quad CPU Q9650 @ 3.00GHz
- carte mère gigabyte GA-P35-DSL3 socket 775
- 8 Go ram DDR2
- carte graphique amd radeon HD4650 pcie, pilote libre radeon

j'ai testé la ram avec memtest, tout semble ok, les autres machines virtuelles que j'avais installé il y a plusieurs mois (windows XP, windows 7) fonctionnent très bien,
à noter que microsoft ne fournit pas la valeur hash (type md5) des images iso qu'ils proposent, du coup impossible de savoir si l'image iso est corrompue ou pas,

j'aimerai savoir si d'autres utilisateurs archlinux ont rencontré le même souci en voulant installer windows 10 (la dernière iso sur le site de microsoft) dans virtualbox sous archlinux ?
je testerai avec qemu pour voir si ça marche mieux,
merci par avance de vos réponses

JuanicoV
Daikyu
Messages : 62
Inscription : mar. 07 nov. 2017, 20:59
Localisation : Espagne-Valencia

Re: [virtualbox] Impossible d'installer windows 10

Message par JuanicoV » mer. 21 nov. 2018, 21:19

Bonjour Elbarto,

2Go pour Windows10 ça me semble bien léger (c'est un 64bits?), tente avec 4Go ça devrait aller mieux. Ensuite 2 coeurs de Intel Core 2 c'est aussi limite.

J'avais un Windows 7 32bit virtuel avec 3Go et 2 coeurs sur mon phenom 9600 et c’était limite inutilisable et ça plantait souvent...
HP Pavillon - AMD Phenom 9600 - 6Go - SSD
Nvidia GT 520
Dual boot : Archlinux Gnome -Ubuntu Mate

Elbarto
Elfe
Messages : 671
Inscription : jeu. 22 déc. 2011, 23:15

Re: [virtualbox] Impossible d'installer windows 10

Message par Elbarto » ven. 23 nov. 2018, 16:11

Bonjour JuanicoV,

je viens d'essayer avec qemu, qui utilise kvm, j'ai pu installer windows 10 (en configurant le contrôleur en mode IDE dans les options de qemu, car si on utilise le mode virtio ça plante à l'installation malgré l'installation manuelle du pilote virtio via l'image iso, windows 10 se bloque lors de la copie des fichiers à 2%, j'ai pu remettre le mode virtio qu'une fois windows 10 installé, en rajoutant un second disque virtuel),

cette machine virtuelle windows 10 est beaucoup plus lente que ma machine virtuelle windows 7 (toujours sous qemu), en faisant une recherche d'autres utilisateurs constatent aussi cette lenteur dans la virtualisation de windows 10,

concernant virtualbox je n'ai pas encore trouvé de solution pour installer windows 10, si quelqu'un a réussi (avec la version de l'iso de windows 10 d'octobre 2018) alors il faudrait qu'il poste les paramètres de sa machine virtuelle pour virtualbox (ou le fichier de configuration)

Répondre