[SAMBA] erreur au lancement de smb.service

Applications, problèmes de configuration réseau
JulTux
newbie
Messages : 6
Inscription : ven. 26 oct. 2018, 10:14

[SAMBA] erreur au lancement de smb.service

Message par JulTux » dim. 23 déc. 2018, 20:02

Bonjour,

Depuis quelques temps, j'ai ça :
# systemctl status smb.service
déc. 23 19:49:27 Arch systemd[1]: Starting Samba SMB Daemon...
déc. 23 19:49:28 Arch smbd[1238]: [2018/12/23 19:49:28.005498, 0] ../source3/a>
déc. 23 19:49:28 Arch smbd[1238]: create_local_token failed: NT_STATUS_ACCESS>
déc. 23 19:49:28 Arch smbd[1238]: [2018/12/23 19:49:28.006127, 0] ../source3/s>
déc. 23 19:49:28 Arch smbd[1238]: ERROR: failed to setup guest info.
déc. 23 19:49:28 Arch systemd[1]: smb.service: Main process exited, code=exited>
déc. 23 19:49:28 Arch systemd[1]: smb.service: Failed with result 'exit-code'.
déc. 23 19:49:28 Arch systemd[1]: Failed to start Samba SMB Daemon.
Je suis obligé de désactiver winbind.service pour que le service smb se lance...
Je ne parviens pas à corriger le soucis ; une aide serait la bienvenue.

Merci

Edit
J'ai également ça concernant nmb, je ne pense pas que ce soit lié mais bon...
# systemctl status nmb
déc. 23 20:06:29 Arch nmbd[601]: [2018/12/23 20:06:29.057016, 0] ../lib/util/become_daemon.c:149(daemon_status)
déc. 23 20:06:29 Arch nmbd[601]: daemon_status: STATUS=daemon 'nmbd' : No local IPv4 non-loopback interfaces available, waiting for interface ...
déc. 23 20:06:29 Arch nmbd[601]: [2018/12/23 20:06:29.058132, 0] ../source3/nmbd/nmbd_subnetdb.c:254(create_subnets)
déc. 23 20:06:29 Arch nmbd[601]: NOTE: NetBIOS name resolution is not supported for Internet Protocol Version 6 (IPv6).
déc. 23 20:06:39 Arch nmbd[601]: [2018/12/23 20:06:39.058784, 0] ../lib/util/become_daemon.c:138(daemon_ready)
déc. 23 20:06:39 Arch nmbd[601]: daemon_ready: STATUS=daemon 'nmbd' finished starting up and ready to serve connections
déc. 23 20:06:39 Arch systemd[1]: Started Samba NMB Daemon.
déc. 23 20:06:39 Arch nmbd[601]: [2018/12/23 20:06:39.061286, 0] ../source3/nmbd/nmbd_namequery.c:109(query_name_response)
déc. 23 20:06:39 Arch nmbd[601]: query_name_response: Multiple (2) responses received for a query on subnet 192.168.23.2 for name MAISON<1d>.
déc. 23 20:06:39 Arch nmbd[601]: This response was from IP 192.168.23.6, reporting an IP address of 192.168.23.6.
192.168.23.2 est mon pc "Arch" dont il est question.
192.168.23.6 est mon raspberry (raspbian)
MAISON est le workgroup défini dans le smb.conf

laurent85
yeomen
Messages : 297
Inscription : mar. 16 oct. 2018, 21:05

Re: [SAMBA] erreur au lancement de smb.service

Message par laurent85 » dim. 23 déc. 2018, 22:53

Bonjour,
JulTux a écrit :
dim. 23 déc. 2018, 20:02
Depuis quelques temps, j'ai ça :
# systemctl status smb.service
déc. 23 19:49:28 Arch smbd[1238]: ERROR: failed to setup guest info.
Donne le retour de :

Code : Tout sélectionner

getent passwd nobody

JulTux
newbie
Messages : 6
Inscription : ven. 26 oct. 2018, 10:14

Re: [SAMBA] erreur au lancement de smb.service

Message par JulTux » lun. 24 déc. 2018, 08:49

Code : Tout sélectionner

$ getent passwd nobody
nobody:x:65534:65534:Nobody:/:/sbin/nologin
Edit
Bon ça y est je m'en suis sorti...
J'ai trouvé ici la commande suivante :

Code : Tout sélectionner

net -s /dev/null groupmap add sid=S-1-5-32-546 unixgroup=nobody type=builtin
J'avoue cependant ne pas la comprendre !

Répondre