[WIFI] activation wpa bloque la connection [RESOLU )

Applications, problèmes de configuration réseau
Répondre
eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

[WIFI] activation wpa bloque la connection [RESOLU )

Message par eggregor » mer. 27 févr. 2019, 09:36

Bonjour à tous,
J'ai ramé toute l'après-midi d'hier sans trouver de solution.
J'avais gardé une connexion wifi en WEP et je me suis décidé à passer au WPA2-PSK/AES qui est le seul chiffrement non obsolète disponible chez Free, et dont je ne comprends guère les subtilités.
Donc dans l'ordre :
J'ai fait ce qu'il faut sur le site Free pour actualiser mes paramètres avec un reboot Freebox.
J'ai vérifié la présence du paquet wpa_supplicant.
J'ai créé un fichier /etc/wpa_supplicant.conf que voici: (il est conforme au modèle du wiki pour WPA-PSK, mais il existe un modèle WPA-AES = ai-je fait le bon choix?)
ctrl_interface_group=0
eapol_version=2
ap_scan=1
fast_reauth=1
network={
ssid="petithom"
psk=".zl@V.....................AUc"
priority=5
}[/quote]
J'ai lancé la commande $ sudo wpa-supplicant -i wlp3s6 -c /etc/wpa_supplicant.conf
Et je me retrouve avec un fichier wlp3s6-petithom qui me semble apte à faire fonctinner la connexion.
$ sudo cat /netctl/wlp3s6-petithom
Description='Automatically generated profile by wifi-menu'
Interface=wlp3s6
Connection=wireless
Security=wpa
ESSID=petithom
IP=dhcp
Key=".zl@-V...............AUc"
j'espère.
$ systemctl enable dhcpcd ( start auparavant)
==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ====
Authentication is required to manage system service or unit files.
Authenticating as: eggregor
Password:
==== AUTHENTICATION COMPLETE ====
Pour mémoire :
[
b]$ sudo nmcli dev[/b]
DEVICE TYPE STATE CONNECTION
enp1s0 ethernet connecté Connexion filaire 1
wlp3s6 wifi déconnecté --
lo loopback non-géré --
Et persuadé que tout baigne le lance :
$ sudo nmcli connect petithom password ".zl@V................AUc"
Erreur : paramètre « petithom » non reconnu. Essayez plutôt --help. j'espère.
[eggregor@Archlinux ~]$ sudo nmcli dev wifi connect petithom password ".zl@V.............AUc"
Erreur : échec de l'activation de la connexion : (7) Des secrets étaient requis, mais aucun n'a été fourni.
Pour ceux qui savent traduire :

Code : Tout sélectionner

[b]$ journalctl -xe[/b]
févr. 27 08:58:28 Archlinux NetworkManager[472]: <info>  [1551254308.6909] device (wlp3s6): supplicant interface state: disabled -> inactive
févr. 27 08:58:28 Archlinux wpa_supplicant[547]: wlp3s6: Reject scan trigger since one is already pending
févr. 27 09:03:43 Archlinux dhcpcd[496]: wlp3s6: new hardware address: f6:73:db:d8:81:ff
févr. 27 09:03:43 Archlinux NetworkManager[472]: <info>  [1551254623.6585] device (wlp3s6): set-hw-addr: set MAC address to F6:73:DB:D8:81:FF (scanning)
févr. 27 09:03:43 Archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s6: link is not ready
févr. 27 09:03:43 Archlinux NetworkManager[472]: <info>  [1551254623.6829] device (wlp3s6): supplicant interface state: inactive -> disabled
févr. 27 09:03:43 Archlinux NetworkManager[472]: <info>  [1551254623.6832] device (wlp3s6): supplicant interface state: disabled -> inactive
févr. 27 09:03:43 Archlinux wpa_supplicant[547]: wlp3s6: Reject scan trigger since one is already pending
févr. 27 09:08:58 Archlinux dhcpcd[496]: wlp3s6: new hardware address: 3e:e3:15:7c:90:a8 j'espère.
févr. 27 09:08:58 Archlinux NetworkManager[472]: <info>  [1551254938.6585] device (wlp3s6): set-hw-addr: set MAC address to 3E:E3:15:7C:90:A8 (scanning)
févr. 27 09:08:58 Archlinux NetworkManager[472]: <info>  [1551254938.6826] device (wlp3s6): supplicant interface state: inactive -> disabled
févr. 27 09:08:58 Archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s6: link is not ready
févr. 27 09:08:58 Archlinux NetworkManager[472]: <info>  [1551254938.7213] device (wlp3s6): supplicant interface state: disabled -> inactive
févr. 27 09:08:58 Archlinux wpa_supplicant[547]: wlp3s6: Reject scan trigger since one is already pending
févr. 27 09:14:13 Archlinux dhcpcd[496]: wlp3s6: new hardware address: 56:15:19:58:8e:10
févr. 27 09:14:13 Archlinux NetworkManager[472]: <info>  [1551255253.6353] device (wlp3s6): set-hw-addr: set MAC address to 56:15:19:58:8E:10 (scanning)
févr. 27 09:14:13 Archlinux NetworkManager[472]: <info>  [1551255253.6596] device (wlp3s6): supplicant interface state: inactive -> disabled
févr. 27 09:14:13 Archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s6: link is not ready
févr. 27 09:14:13 Archlinux NetworkManager[472]: <info>  [1551255253.7043] device (wlp3s6): supplicant interface state: disabled -> inactive
févr. 27 09:14:13 Archlinux wpa_supplicant[547]: wlp3s6: Reject scan trigger since one is already pending
févr. 27 09:19:28 Archlinux dhcpcd[496]: wlp3s6: new hardware address: 92:d2:dd:0b:32:1c
févr. 27 09:19:28 Archlinux NetworkManager[472]: <info>  [1551255568.6025] device (wlp3s6): set-hw-addr: set MAC address to 92:D2:DD:0B:32:1C (scanning)
févr. 27 09:19:28 Archlinux kernel: IPv6: ADDRCONF(NETDEV_UP): wlp3s6: link is not ready
févr. 27 09:19:28 Archlinux NetworkManager[472]: <info>  [1551255568.6264] device (wlp3s6): supplicant interface state: inactive -> disabled
févr. 27 09:19:28 Archlinux NetworkManager[472]: <info>  [1551255568.6895] device (wlp3s6): supplicant interface state: disabled -> inactive
févr. 27 09:19:28 Archlinux wpa_supplicant[547]: wlp3s6: Reject scan trigger since one is already pending
Dernier point, l'essai d'activation depuis l'applet de NetworkManager ne donne aucun résultat hormis de faire disparaître l'applet quand on envoie.

Je ne sais vraiment pas vers quoi m'orienter, un expert peut-il m'aider ?
(Depuis une tablette Apple, la connexion est effective, c'est donc bien un problème Linux)
Merci par avance de vos éclaircissements.
Dernière modification par eggregor le sam. 02 mars 2019, 11:53, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [WIFI] activation wpa bloque la connection

Message par benjarobin » mer. 27 févr. 2019, 09:57

Bonjour,
Tu ne peux pas utiliser tous ces service réseau en même temps...
  • /etc/wpa_supplicant.conf est utilisé par le service associé
  • netctl
  • dhcpcd
  • NetworkManager
Tu dois désinstaller netctl et n'activer que NetworkManager en tant que service.
Puis utiliser normalement l'interface graphique de NetworkManager
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection

Message par eggregor » mer. 27 févr. 2019, 10:32

Merci de ta rapidité,
je fais çà illico et je raconte ce qu'il en est.

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection

Message par eggregor » mer. 27 févr. 2019, 11:26

Bon, progrès constaté mais toujours connexion impossible.
J'ai vire netctl.
J'ai nettoyé /etc/NetworkManager/system-connections -> qui comportait me suis-je aperçu, deux SSID petithom et petithom 1

J'ai armé NetworkManager :
# systemctl start NetworkManager
# systemctl enable NetworkManager
Created symlink /etc/systemd/system/network-online.target.wants/NetworkManager-wait-online.service → /usr/lib/systemd/system/NetworkManager-wait-online.service.
Ce qui me parait satisfaisant.
J'ai fait un reboot à tout hasard en débranchant le câble.
J'ai cliqué sur l'applet de NM qui propose bien la connexion "petithom" avec la bonne clé enregistrée, mais mais mais... l'applet tourne en attente et revient toujours au même écran d’authentification.

Donc il manque encore quelquechose.

Pour mémoire :
$ nmcli con show
NAME UUID TYPE DEVICE
Connexion filaire 1 64df5fb8-6de8-3db5-8abd-df5c07f175ce ethernet enp1s0
FreeWifi feacdfcc-4067-4dcc-a0fd-8ee91397fdf8 wifi --
petithom 18580186-b84f-41fc-b260-63968c4f03d2 wifi --

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection

Message par eggregor » jeu. 28 févr. 2019, 08:44

Pataglop,
J'ai tenté diverses manips en grattant des infos à droite à gauche sans évoluer d'un pouce.
Je crains de ne pouvoir trouver de solutions sur le forum, donc je suis dans l'impasse.

C'est, vous en conviendrez je suppose, tout à fait triste d'avoir ramé pour installer Arch qui fonctionne parfaitement depuis un an, et de me retrouver piégé comme un débutant
pour une malheureuse connexion wifi.
Je continue mes recherches. Salut aux rares visiteurs.

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection

Message par eggregor » sam. 02 mars 2019, 09:35

Cher benjarobin,
Clairement tu me méprises.
C'est tout à fait ton droit, mais plutôt que de le faire lâchement en jouant le silence radio, ne serait-il pas plus honnête de m'en expliquer les causes ?
Je fais en sorte de ne pas venir trop souvent chercher de l'aide, donc ce n'est pas le gaspillage de temps qui peut te motiver, et d'ailleurs motiver les autres qui restent aussi dans les tranchées.
Quand je suis devenu utilisateur d'Arch, beaucoup, dont toi benjarobin m'ont beaucoup dépanné, alors pourquoi ce changement d'attitude ?
J'espère au moins que tu m'expliques.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10518
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [WIFI] activation wpa bloque la connection

Message par FoolEcho » sam. 02 mars 2019, 11:03

eggregor a écrit :
sam. 02 mars 2019, 09:35
Quand je suis devenu utilisateur d'Arch, beaucoup, dont toi benjarobin m'ont beaucoup dépanné, alors pourquoi ce changement d'attitude ?
J'espère au moins que tu m'expliques.
Je ne vais pas parler en son nom, mais il reste le plus actif sur le forum... alors s'énerver parce qu'il n'y a pas eu de réponse depuis deux jours, comment te dire... :|
eggregor a écrit :
sam. 02 mars 2019, 09:35
Je fais en sorte de ne pas venir trop souvent chercher de l'aide, donc ce n'est pas le gaspillage de temps qui peut te motiver, et d'ailleurs motiver les autres qui restent aussi dans les tranchées.
eggregor a écrit :
sam. 02 mars 2019, 09:35
J'ai tenté diverses manips en grattant des infos à droite à gauche sans évoluer d'un pouce.
Super. Attends je prends ma boule de cristal...

Bref.
Si tu n'explicites pas à partir de quelle configuration tu travailles (la seule qu'on a c'est un profil pour netctl... dont on ignore même s'il a pu fonctionner vu que tu n'as conservé que networkmanager, etc.).... si c'est networkmanager, faut reprendre le nmcli déjà (dont on ignore aussi s'il a fonctionné, as-tu bien désactivé tous les autres gestionnaires réseaux ?). Vérifiez comment tu as réglé la freebox, etc..
«The following statement is not true. The previous statement is true.» :nage:

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection

Message par eggregor » sam. 02 mars 2019, 11:52

Bonjour FoolEcho,

Tu as raison, il faudrait une boule de cristal.
Il y a une méprise de ma part que je viens tout juste de comprendre à cause " de la boule de cristal " .
Je découvre que je n'avais pas moi-même redonné des infos.... Et pourtant si ! j'avais redonné des infos, du moins je le croyais.

Après la réponse de benjarobin, j'ai fait diverses manips qui n'ont pas abouties.
J'ai donc rédigé un message ici-même avec les résultats d'investigation, et quand j'ai fait "Envoyer", j'ai eu une alerte du genre " vous ne pouvez pas poster ici sans être connecté" -> j'ai donc cliqué sur "se connecter" et surprise
mon message a disparu !
j'étais connecté et dans les clous mais tout ce que j'avais écrit était parti dans les limbes du forum.

J'ai donc refait patiemment mon message, cette fois sur un doc writer que j'ai ensuite copié-collé sur une "réponse du forum", et donc je ne comprenais pas que personne ne s'y intéresse, je me suis dit ils font la gueule, je sens le pâté comme une dinde au pôle Nord !
ET quand tu dis boule de cristal, je regarde mon envoi.... Qui effectivement est vide de toute info, mon copié-collage a foiré et je ne m'en suis pas aperçu.

Donc j'ai taillé un costard sur mesure à benjarobin tout à fait à tort, il l’oubliera je présume et j'espère que çà ne nous fâchera pas pour de bon!

Sinon je peux marquer résolu, parce que j'ai finalement réussi la reconnexion de deux machines, après bien des manœuvres et trop de temps passé en recherche.
Au passage c'est très étonnant, d'un ordinateur à l'autre, avec les mêmes logiciels, les situations ne se présentent pas à l'équivalence, et les commandes n’obéissent jamais tout à fait pareil.

Finalement c'est sur le forum english que j'ai trouvé le meilleur tuto, et une fois réglés divers pépins d'activation de wifi "désactivé à l'insu de mon plein gré", tout baigne.
:french:

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [WIFI] activation wpa bloque la connection

Message par benjarobin » dim. 03 mars 2019, 16:56

eggregor a écrit :
sam. 02 mars 2019, 09:35
Cher benjarobin,
Clairement tu me méprises.
...
J'espère au moins que tu m'expliques.
C'est toujours sympa de voir de tel message surtout quand on est parti en weekend prolongé à faire du ski de randonnée (désolé j'avais autre chose à faire...)
Et j'avais bien vu ton message précédent (depuis mon téléphone portable), c'est juste que je n'avais pas d'idée sur le moment et que je n'avais pas le temps (ni les moyens) de chercher la raison du problème...
Tu noteras que mon dernier message sur le forum était du 27 février au matin...
Bref je suis bien un humain, je ne suis pas 100% du temps sur mon PC (d'ailleurs je te réponds de mon portable...)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

eggregor
archer de cavalerie
Messages : 153
Inscription : ven. 25 févr. 2011, 11:52

Re: [WIFI] activation wpa bloque la connection [RESOLU )

Message par eggregor » lun. 04 mars 2019, 09:28

Gloup !
Je bois la tasse, je suis vraiment désolé et honteux en fait, de m'être autant fourvoyé.
Je te demande de bien vouloir oublier tout çà.
Je vieilli, et parfois mon crabe est grincheux.
Peut-être à une autre fois.
:inutile:

Répondre