[pgadmin] - Impossible de créer un serveur (RESOLU)

Applications, problèmes de configuration réseau
Répondre
Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

[pgadmin] - Impossible de créer un serveur (RESOLU)

Message par Hokseed » sam. 27 avr. 2019, 15:50

Bonjour,

J'ai des problèmes en essayant d'utiliser pgadmin4 avec postgresql, j'ai suivi le wiki en ce qui concerne postgres.

Une fois avoir tout installé, je lance pgadmin4 et dans le bloc gauche "Browser", je ne peux pas déplier mes "Servers Group". Lorsque je clique sur le '>' a gauche du Server group, ca charge dans le vide. Donc impossible de créer un server ou, du moins, de le visualiser...

Si quelqu'un peut m'aider parce que j'ai vraiment besoin de pgadmin ! Merci beaucoup d'avance !
Dernière modification par Hokseed le sam. 27 avr. 2019, 17:52, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15395
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pgadmin] - Impossible de créer un serveur

Message par benjarobin » sam. 27 avr. 2019, 17:29

Bonjour,
Je peux reproduire le problème, j'ai ceci comme erreur :

Code : Tout sélectionner

'psycopg2.extensions.Column' object has no attribute '_asdict'
Voir la solution ici : https://stackoverflow.com/questions/556 ... rver-error

Le paquet a déjà été marqué comme
Flagged out-of-date on 2019-04-10
J'ai donc recompilé moi même la version 4.5, et cela fonctionne très bien.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [pgadmin] - Impossible de créer un serveur

Message par Hokseed » sam. 27 avr. 2019, 17:41

benjarobin a écrit :
sam. 27 avr. 2019, 17:29
Voir la solution ici : https://stackoverflow.com/questions/556 ... rver-error
Effectivement c'est également mon probleme merci beaucoup.

Comment est ce que je peux downgrade psycopg2 2.8.1 en 2.7 ?
Elle n'est plus dans mon cache de pacman et je n'ai pas réussi avec pip install --upgrade python-psycopg2==2.7.1

benjarobin
Maître du Kyudo
Messages : 15395
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pgadmin] - Impossible de créer un serveur

Message par benjarobin » sam. 27 avr. 2019, 17:42

Non tu ne dois pas downgrader, mais mettre à jour pgadmin4 en version 4.5
C'est très simple à faire, tu dois récupérer le PKGBUILD, changer la version, et lancer le build du paquet via makepkg

Soit les étapes suivantes :
  • Code : Tout sélectionner

    curl -L -f https://git.archlinux.org/svntogit/community.git/snapshot/community-packages/pgadmin4.tar.gz -O
    tar xvf pgadmin4.tar.gz
    cd community-packages/pgadmin4/trunk/
  • Changer dans le PKGBUILD, pkgver=4.4, en pkgver=4.5
  • Code : Tout sélectionner

    updpkgsums
    makepkg -si
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [pgadmin] - Impossible de créer un serveur

Message par Hokseed » sam. 27 avr. 2019, 17:48

Grand merci à toi ! Je passe en résolu !

Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [pgadmin] - Impossible de créer un serveur

Message par Hokseed » sam. 27 avr. 2019, 18:10

benjarobin a écrit :
sam. 27 avr. 2019, 17:42
Non tu ne dois pas downgrader, mais mettre à jour pgadmin4 en version 4.5
C'est très simple à faire, tu dois récupérer le PKGBUILD, changer la version, et lancer le build du paquet via makepkg
Quoique, j'ai passé en résolu parce que j'ai finalement réussi à downgrade.

Mais apres avoir vu ton dernier message avec une solution beaucoup plus propre j'ai essayé mais je me retrouve toujours avec la 4.4.
Apres avoir fait le makepkg il suffit de relancer pgadmin4 ?

benjarobin
Maître du Kyudo
Messages : 15395
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pgadmin] - Impossible de créer un serveur (RESOLU)

Message par benjarobin » sam. 27 avr. 2019, 18:26

Tu as bien changer la version dans le PKGBUILD ? Que te donne : pacman -Qi pgadmin4 ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [pgadmin] - Impossible de créer un serveur (RESOLU)

Message par Hokseed » sam. 27 avr. 2019, 19:18

Oui PKGBUILD modifié en 4.5, le pacman -Qi me donne 4.4.

J'ai remarqué que le makepkg -si m'a renvoyé
"==> Vérification des signatures des fichiers sources grâce à gpg…
pgadmin4-4.5.tar.gz ... ÉCHEC (Clé publique inconnue 8881B2A8210976F2)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées."
à la fin... Je sais pas du tout a quoi d'ou ca vient

benjarobin
Maître du Kyudo
Messages : 15395
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [pgadmin] - Impossible de créer un serveur (RESOLU)

Message par benjarobin » sam. 27 avr. 2019, 19:19

Tu dois configurer GnuPG de telle manière a récupérer automatiquement la clé nécessaire...

Attention comme le build est réalisé avec ton utilisateur courant (donc pas root), alors tout ce qui concerne GnuPG doit être fait avec ton utilisateur.
Attention de ne pas confondre avec le keyring de pacman.

J'ai ceci comme configuration : /home/ben/.gnupg/gpg.conf

Code : Tout sélectionner

display-charset utf-8
no-greeting
armor
keyserver hkp://keys.gnupg.net
keyserver-options timeout=10
keyserver-options auto-key-retrieve
La doc associée : https://wiki.archlinux.org/index.php/Gn ... _keyserver
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Hokseed
Hankyu
Messages : 26
Inscription : sam. 24 déc. 2016, 15:10

Re: [pgadmin] - Impossible de créer un serveur (RESOLU)

Message par Hokseed » sam. 27 avr. 2019, 19:47

Impressionant ! Ca a resolu le problème encore merci !

Me voila avec un beau pgadmin 4.5 !

Répondre