[wifi] débit faible en 5ghz AC

Applications, problèmes de configuration réseau
aty879
Daikyu
Messages : 62
Inscription : dim. 14 août 2016, 14:47

[wifi] débit faible en 5ghz AC

Message par aty879 » dim. 28 juil. 2019, 17:35

Bonjour,

Je viens d'installer Arch Linux sur mon nouveau portable un DELL XPS et je rencontre un soucis de vitesse en wifi.
je suis connecté en 6 Mb/s en 5ghz. Savez-vous d'ou ça peut venir en sachant que ma carte est bien reconnue ?
J'ai testé sur deux bornes wifi différentes (une livebox 4 et une google wifi) je suis toujours bloqué à 6 Mb/s.

Code : Tout sélectionner

Interface wlp2s0
		ifindex 2
		wdev 0x1
		addr xxxxx
		ssid xxxx
		type managed
		channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
		txpower 20.00 dBm
ma carte wifi :

Code : Tout sélectionner

Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
Merci !

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [wifi] débit faible en 5ghz AC

Message par waitnsea » lun. 29 juil. 2019, 05:25

Bonjour,
Que renvoie $ cat /proc/sys/net/ipv4/tcp_ecn ?

aty879
Daikyu
Messages : 62
Inscription : dim. 14 août 2016, 14:47

Re: [wifi] débit faible en 5ghz AC

Message par aty879 » lun. 29 juil. 2019, 11:21

Bonjour,

J'ai "2" qui s'affiche en retour à cette commande.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [wifi] débit faible en 5ghz AC

Message par waitnsea » lun. 29 juil. 2019, 11:59

aty879 a écrit :
lun. 29 juil. 2019, 11:21
J'ai "2" qui s'affiche en retour à cette commande.
Donc ça ne vient pas d'un problème d'ECN. J'ai la même carte (avec quelques soucis aussi, mais différents)...
En dehors des copiages des lib que l'on retrouve sur les forums et wiki (par exemple ici ), mais dont je ne suis pas sûr que ce soit utile car le paquet linux-firmware est tout récent et doit quand même être bien à jour, je ne vois à te conseiller que :
* créer un fichier de conf avec :

Code : Tout sélectionner

# echo "options ath10k_core skip_otp=y" > /etc/modprobe.d/ath10k.conf

* blacklister les modules inadéquats en ajoutant ces 2 lignes à /etc/modprobe.d/modprobe.conf

Code : Tout sélectionner

blacklist ath5k
blacklist ath9k
* forcer les bons modules en ajoutant cfg80211 aux modules de ton mkinitcpio.conf (sans oublier de relancer # mkinitcpio -P après)
mais je ne peux pas dire plus, mon wifi étant en 2.4 Ghz et fonctionnant très bien sous linux-LTS

aty879
Daikyu
Messages : 62
Inscription : dim. 14 août 2016, 14:47

Re: [wifi] débit faible en 5ghz AC

Message par aty879 » lun. 29 juil. 2019, 12:17

waitnsea a écrit :
lun. 29 juil. 2019, 11:59
* créer un fichier de conf avec :

Code : Tout sélectionner

# echo "options ath10k_core skip_otp=y" > /etc/modprobe.d/ath10k.conf

* blacklister les modules inadéquats en ajoutant ces 2 lignes à /etc/modprobe.d/modprobe.conf

Code : Tout sélectionner

blacklist ath5k
blacklist ath9k
J'ai testé les deux ajouts mais sans succès...

aty879
Daikyu
Messages : 62
Inscription : dim. 14 août 2016, 14:47

Re: [wifi] débit faible en 5ghz AC

Message par aty879 » lun. 29 juil. 2019, 15:28

Re,

Je suis pas le seul après quelques recherches : https://bugs.launchpad.net/ubuntu/+sour ... ug/1828304

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2014
Inscription : jeu. 15 mars 2012, 05:08

Re: [wifi] débit faible en 5ghz AC

Message par waitnsea » lun. 29 juil. 2019, 18:35

aty879 a écrit :
lun. 29 juil. 2019, 15:28
Re,

Je suis pas le seul après quelques recherches : https://bugs.launchpad.net/ubuntu/+sour ... ug/1828304
Si tu veux essayer un downgrade, la solution pratique c'est le paquet aur/downgrade :

Code : Tout sélectionner

 downgrade linux-firmware                                                                             ✔  10002  18:34:19
Paquets disponibles :

-  1)  linux-firmware    20190118.a8b75ca  1  any  (distant)
-  2)  linux-firmware    20190212.28f5f7d  1  any  (distant)
-  3)  linux-firmware    20190313.efd2c1c  1  any  (distant)
...

Sélectionner le paquet numéro : 

aty879
Daikyu
Messages : 62
Inscription : dim. 14 août 2016, 14:47

Re: [wifi] débit faible en 5ghz AC

Message par aty879 » mer. 31 juil. 2019, 12:11

Bonjour,

Merci pour ton aide, je vais essayer en effet de downgrader le linux-firmware.

Répondre