Page 1 sur 1

[VPN] Pas de connexion en L2TP

Publié : sam. 16 nov. 2019, 13:22
par Chon
Bonjour à tous,

Problème de connexion à un serveur VPN en L2TP.
Je précise que ce n'est pas un pb du serveur vu que le PC sous Win10 de mon épouse voisin s'y connecte sans souci.
Je précise également que mon PC sous Arch se connecte sans pb à un autre serveur VPN mais en PPTP.
Ce que je peux montrer de ma config :

Ce qui est installé :

Code : Tout sélectionner

[chon ~]$ pacman -Qs l2tp
local/networkmanager-l2tp 1.2.14-1
    L2TP support for NetworkManager
local/xl2tpd 1.3.15-1
    an open source implementation of the L2TP maintained by Xelerance
    Corporation
[chon ~]$ pacman -Qs swan
local/libreswan 3.29-2
    IPsec implementation with IKEv1 and IKEv2 keying protocols
[chon ~]$
La fenêtre d'identification VPN :

Image

Les paramètres IPv4 :

Image

Les paramètres IPsec :

Image

Les paramètres PPP :

Image

Ai-je oublié d'installer quelque chose ?
J'ai tenté de cocher/décocher un certain nombre d'options sans succès.

J'avoue que là, je sèche...
Si ça inspire quelqu'un ?
Un grand merci par avance.

Re: [VPN] Pas de connexion en L2TP

Publié : sam. 16 nov. 2019, 14:17
par hopimet
Salut,

Une piste ici : https://gist.github.com/pastleo/aa3a952 ... b771d079c9
Essaye de décocher Enable IPsec tunnel to L2TP host. D'après ce tuto il semble qu'il y ait un bug.

Mais je ne peux pas tester n'ayant pas d'hôte à me connecter en L2TP.

Re: [VPN] Pas de connexion en L2TP

Publié : sam. 16 nov. 2019, 15:08
par Chon
Merci à toi hopimet !

Décidément, t'es de garde ? :mrgreen: :)

Bon, malheureusement, ça n'a pas fonctionné même en redémarrant NetworkManager. :cry:

Re: [VPN] Pas de connexion en L2TP

Publié : sam. 16 nov. 2019, 15:21
par hopimet
Tu as essayé de modifier le protocole dans la fenêtre ppp ? Le PC sous win 10 utilise lequel ? MSCHAPv2 aussi ?

Re: [VPN] Pas de connexion en L2TP

Publié : dim. 17 nov. 2019, 08:36
par Chon
hopimet a écrit :
sam. 16 nov. 2019, 15:21
Tu as essayé de modifier le protocole dans la fenêtre ppp ? Le PC sous win 10 utilise lequel ? MSCHAPv2 aussi ?
Oui, même protocole.

Re: [VPN] Pas de connexion en L2TP

Publié : mer. 20 nov. 2019, 20:20
par viperpaulo
Hello,

J'ai le même problème Android et Linux ne se connectent pas tandis que MacOS si... Peut-être que l'implémentation Linux a un paramétrage plus strict..