[firefox] connexions impossibles (RESOLU)

Applications, problèmes de configuration réseau
Répondre
eggregor
yeomen
Messages : 216
Inscription : ven. 25 févr. 2011, 11:52

[firefox] connexions impossibles (RESOLU)

Message par eggregor » ven. 03 janv. 2020, 10:06

Bonjour à tous,
Ce problème étant apparu sur un ordinateur portable, juste après la mise à jour comportant xorgproto, j'avais cherché de l'aide depuis un fil déjà en fin de course
sur le sujet xorgproto, que je pensais possiblement coupable des troubles suivants :

- Impossibilité d'atteindre une quelconque adresse internet hormis celle du forum archlinuxfr et le serveur de gmail.

Un conseil en retour qui suggérait de démarrer firefox sans les modules n'a rien donné.

Code : Tout sélectionner

Et voilà qu'hier j'ai fait un mise à jour sur mon ordi de bureau conduisant ce matin aux mêmes problèmes que sur le portable.
Cette fois seul le forum est accessible, les mails sur gmx.fr ne passant pas non plus.
Je ne crois pas que la mise à jour comportait firefox.
C'est donc d'une dépendance commune à un autre paquet que pourrait provenir le problème.

Verriez-vous la-dedans un tel paquet ?
cat /var/log/pacman.log
[2020-01-02T11:54:07+0100] [ALPM] upgraded expat (2.2.9-2 -> 2.2.9-3)
[2020-01-02T11:54:07+0100] [ALPM] upgraded libtirpc (1.1.4-2 -> 1.2.5-1)
[2020-01-02T11:54:10+0100] [ALPM] upgraded python (3.8.0-1 -> 3.8.1-1)
[2020-01-02T11:54:10+0100] [ALPM] upgraded bind-tools (9.14.8-4 -> 9.14.9-1)
[2020-01-02T11:54:10+0100] [ALPM] upgraded bluez (5.52-1 -> 5.52-2)
[2020-01-02T11:54:10+0100] [ALPM] upgraded bluez-libs (5.52-1 -> 5.52-2)
[2020-01-02T11:54:10+0100] [ALPM] upgraded libarchive (3.4.0-3 -> 3.4.1-1)
[2020-01-02T11:54:12+0100] [ALPM] upgraded linux (5.4.6.arch1-1 -> 5.4.7.arch1-1)
[2020-01-02T11:54:12+0100] [ALPM] upgraded broadcom-wl (6.30.223.271-154 -> 6.30.223.271-157)
[2020-01-02T11:54:12+0100] [ALPM] upgraded libjpeg-turbo (2.0.3-1 -> 2.0.4-1)
[2020-01-02T11:54:12+0100] [ALPM] upgraded libedit (20191025_3.1-1 -> 20191211_3.1-1)
[2020-01-02T11:54:13+0100] [ALPM] upgraded llvm-libs (9.0.0-4 -> 9.0.1-1)
[2020-01-02T11:54:13+0100] [ALPM] upgraded catfish (1.4.10-2 -> 1.4.11-1)
[2020-01-02T11:54:13+0100] [ALPM] upgraded dhcpcd (8.1.2-1 -> 8.1.4-1)
[2020-01-02T11:54:13+0100] [ALPM] upgraded git (2.24.1-2 -> 2.24.1-4)
[2020-01-02T11:54:13+0100] [ALPM] upgraded groff (1.22.4-2 -> 1.22.4-3)
[2020-01-02T11:54:13+0100] [ALPM] upgraded grub (2:2.04-3 -> 2:2.04-5)
[2020-01-02T11:54:13+0100] [ALPM] upgraded hwinfo (21.60-2 -> 21.67-1)
[2020-01-02T11:54:13+0100] [ALPM] upgraded imagemagick (7.0.9.10-1 -> 7.0.9.13-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded intel-gmmlib (19.3.4.1-1 -> 19.4.1-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded libva (2.5.0-1 -> 2.6.0-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded intel-media-driver (19.3.1-3 -> 19.4.0-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded lftp (4.8.4-5 -> 4.9.0-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded libevent (2.1.11-3 -> 2.1.11-4)
[2020-01-02T11:54:14+0100] [ALPM] upgraded libnm (1.22.0-1 -> 1.22.2-1)
[2020-01-02T11:54:14+0100] [ALPM] upgraded libva-utils (2.5.0-1 -> 2.6.0-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded linux-firmware (20191215.eefb5f7-1 -> 20191220.6871bff-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded nano (4.6-1 -> 4.7-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded networkmanager (1.22.0-1 -> 1.22.2-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded nvidia (440.44-5 -> 440.44-8)
[2020-01-02T11:54:21+0100] [ALPM] upgraded openvpn (2.4.8-1 -> 2.4.8-2)
[2020-01-02T11:54:21+0100] [ALPM] upgraded pacman-contrib (1.2.0-3 -> 1.3.0-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded v4l-utils (1.16.7-1 -> 1.18.0-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded parole (1.0.4-1 -> 1.0.5-1)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-encode-locale (1.05-5)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-http-date (6.05-1)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-file-listing (6.04-6)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-html-tagset (3.20-8)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-html-parser (3.72-8)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-lwp-mediatypes (6.02-6)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-io-html (1.001-5)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-http-message (6.18-3)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-http-cookies (6.08-1)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-http-daemon (6.01-7)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-http-negotiate (6.01-6)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-net-http (6.19-2)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-try-tiny (0.30-3)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-www-robotrules (6.02-6)
[2020-01-02T11:54:21+0100] [ALPM] installed perl-libwww (6.43-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded perl-xml-parser (2.44-9 -> 2.45-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded python-pyparsing (2.4.5-1 -> 2.4.6-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded smartmontools (7.0-1 -> 7.1-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded talloc (2.3.0-1 -> 2.3.1-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded vulkan-icd-loader (1.1.129-1 -> 1.1.130-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded wireguard-arch (0.0.20191219-2 -> 0.0.20191226-2)
[2020-01-02T11:54:21+0100] [ALPM] upgraded wireguard-tools (0.0.20191219-1 -> 1.0.20191226-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded xapps (1.6.7-1 -> 1.6.8-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded xf86-input-wacom (0.38.0-1 -> 0.39.0-1)
[2020-01-02T11:54:21+0100] [ALPM] upgraded xfce4-terminal (0.8.8-2 -> 0.8.9.1-1)
[2020-01-02T11:54:22+0100] [ALPM] transaction completed
[2020-01-02T11:54:23+0100] [ALPM] running '20-systemd-sysusers.hook'...
[2020-01-02T11:54:23+0100] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-01-02T11:54:23+0100] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-01-02T11:54:23+0100] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-01-02T11:54:23+0100] [ALPM] running '30-systemd-update.hook'...
[2020-01-02T11:54:23+0100] [ALPM] running '60-depmod.hook'...
[2020-01-02T11:54:29+0100] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-01-02T11:54:29+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-01-02T11:54:29+0100] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-01-02T11:54:29+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.4.7-arch1-1
[2020-01-02T11:54:29+0100] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2020-01-02T11:54:30+0100] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2020-01-02T11:54:30+0100] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2020-01-02T11:54:30+0100] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2020-01-02T11:54:30+0100] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2020-01-02T11:54:31+0100] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2020-01-02T11:54:31+0100] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2020-01-02T11:54:31+0100] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2020-01-02T11:54:31+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-01-02T11:54:31+0100] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] ==> Starting build: 5.4.7-arch1-1
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] -> Running build hook: [modconf]
[2020-01-02T11:54:33+0100] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2020-01-02T11:54:35+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-01-02T11:54:36+0100] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-01-02T11:54:38+0100] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2020-01-02T11:54:40+0100] [ALPM-SCRIPTLET] -> Running build hook: [keyboard]
[2020-01-02T11:54:42+0100] [ALPM-SCRIPTLET] -> Running build hook: [fsck]
[2020-01-02T11:54:43+0100] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-01-02T11:54:43+0100] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-01-02T11:54:48+0100] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-01-02T11:54:48+0100] [ALPM] running 'dbus-reload.hook'...
[2020-01-02T11:54:48+0100] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-01-02T11:54:48+0100] [ALPM] running 'glib-compile-schemas.hook'...
[2020-01-02T11:54:48+0100] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-01-02T11:54:48+0100] [ALPM] running 'texinfo-install.hook'...
[2020-01-02T11:54:48+0100] [ALPM] running 'update-desktop-database.hook'...
Il y a bien une MAJ de NetworkManager, après tout pourquoi pas lui ?
Quelqu'un aurait-il un problème comparable ?
Peut-être faudrait-il "rétrograder" NM ? Je vais un peu potasser le sujet rétrograder, mais si vous avez une meilleure idée, bien entendu je suis preneur.
Dernière modification par eggregor le sam. 04 janv. 2020, 11:31, modifié 2 fois.

hopimet
Elfe
Messages : 977
Inscription : mer. 14 mars 2012, 22:48

Re: [firefox] connexions impossibles

Message par hopimet » ven. 03 janv. 2020, 10:14

Salut,

Dans tes paquets il y a également dhcpcd.

De plus je vois opnvpn. Tu utilises passe par un vpn pour te connecter à internet ?

Un truc simple pour commencer serait de voir si tu as le même problème avec un autre navigateur. Installe chromium par exemple et teste. Si ça fonctionne ça voudra dire que le problème vient de firefox. Tu peux aussi directement regarder dans les préférences de connexion de firefox quels sont les paramètres indiqués.

Avatar de l’utilisateur
fran
yeomen
Messages : 231
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [firefox] connexions impossibles

Message par fran » ven. 03 janv. 2020, 12:20

Bonjour
Je suis dans le même cas , je ne peux me connecter que sur le site archlinux et google et les mises à jour fonctionne aussi via yay -Syu.

C'est pareil en wifi où ethernet , j'ai une freebox V6 pour connecter.

J'ai testé avec chromium , le problème est identique.

Avec un livecd ça fonctionne correctement , ainsi que la wifi de mon smartphone , je peux accéder à tous les sites.

merci
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

hopimet
Elfe
Messages : 977
Inscription : mer. 14 mars 2012, 22:48

Re: [firefox] connexions impossibles

Message par hopimet » ven. 03 janv. 2020, 13:14

Apparemment certains ont un problème similaire avec networkmananger : https://bbs.archlinux.org/viewtopic.php?id=251685
Ou encore : https://bbs.archlinux.org/viewtopic.php?id=251703

Faut peut être essayer de downgrader.

Edit : on peut voir aussi le contenu de resolv.conf ?
cat /etc/resolv.conf

Avatar de l’utilisateur
fran
yeomen
Messages : 231
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [firefox] connexions impossibles

Message par fran » ven. 03 janv. 2020, 13:42

Pour moi , j'ai ça
[franck@portableHP ~]$ cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.0.254
nameserver fd0f:ee:b0::1
[franck@portableHP ~]$

[franck@portableHP ~]$ pacman -Q networkmanager
networkmanager 1.22.2-1
[franck@portableHP ~]$

Il faudrait essayer en retrogradant networkmanager?
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

hopimet
Elfe
Messages : 977
Inscription : mer. 14 mars 2012, 22:48

Re: [firefox] connexions impossibles

Message par hopimet » ven. 03 janv. 2020, 13:49

Essaye d'abord d'ajouter dans ton resolv.conf :
nameserver 8.8.8.8

Juste pour tester. Puis tu reboot.

Avatar de l’utilisateur
fran
yeomen
Messages : 231
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [firefox] connexions impossibles

Message par fran » ven. 03 janv. 2020, 14:05

je viens de tester .
Ça ne fonctionne pas .
Mais un truc bizarre , j'ajoute nameserver 8.8.8.8 dans resolv.conf , j'enregistre bien et après un reboot , ce n'est plus affiché dans le fichier.

c'est normal ?
ça veux dire quoi nameserver 8.8.8.8

La dernière màj de networkmanager
[2019-12-26T10:56:59+0100] [ALPM] upgraded networkmanager (1.22.0-1 -> 1.22.2-1)
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

hopimet
Elfe
Messages : 977
Inscription : mer. 14 mars 2012, 22:48

Re: [firefox] connexions impossibles

Message par hopimet » ven. 03 janv. 2020, 14:10

C'était juste pour changer le serveur DNS au cas où.

Mais je viens de voir que cette version de nm est buguée.
https://bugs.archlinux.org/task/64880

Modifie /etc/NetworkManager/NetworkManager.conf en ajoutant:

[main]
dhcp=dhcpcd


Tu remets aussi ton resolv.conf à l'état d'origine.

Et ensuite : sudo systemctl restart NetworkManager

Avatar de l’utilisateur
fran
yeomen
Messages : 231
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [firefox] connexions impossibles

Message par fran » ven. 03 janv. 2020, 14:22

Super , ça fonctionne ( j'ai testé après redémarrage aussi , au cas où)
Merci

Pour resolv.conf , il se remettait à l'état d'origine après un redémarrage.
Donc c'est un bug de networkmanager
Ça veut dire quoi la modif faite dans le fichier NetworkManager.conf
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

hopimet
Elfe
Messages : 977
Inscription : mer. 14 mars 2012, 22:48

Re: [firefox] connexions impossibles

Message par hopimet » ven. 03 janv. 2020, 14:30

En fait c'est le client dhcp interne de nm qui déconne semble t'il. Donc en attendant que ce soit patché on lui demande d'utiliser à la place un démon externe, en l'occurrence dhcpcd.

Code : Tout sélectionner

dhcp
           This key sets up what DHCP client NetworkManager will use. Allowed values are dhclient, dhcpcd, and
           internal. The dhclient and dhcpcd options require the indicated clients to be installed. The internal
           option uses a built-in DHCP client which is not currently as featureful as the external clients.

           If this key is missing, it defaults to internal. It the chosen plugin is not available, clients are
           looked for in this order: dhclient, dhcpcd, internal.
Pour plus d'infos, voir : man 5 networkmanager.conf

Avatar de l’utilisateur
fran
yeomen
Messages : 231
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [firefox] connexions impossibles

Message par fran » ven. 03 janv. 2020, 14:36

Merci pour ton aide
HP elitebook 2570P : arch xfce
intelNuc :arch xfce

eggregor
yeomen
Messages : 216
Inscription : ven. 25 févr. 2011, 11:52

Re: [firefox] connexions impossibles

Message par eggregor » ven. 03 janv. 2020, 15:16

Re,
Mêmes causes, mêmes effets en remplaçant dhcp=dhcpcd.

Grand merci pour cette solution efficace.
Je mets "résolu"

Répondre