[wifi] utilisation iw

Applications, problèmes de configuration réseau
AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

[wifi] utilisation iw

Message par AchilleFraisse » sam. 01 févr. 2020, 21:53

bonjour
j'ai suivi ce tuto pour mettre en place le wifi sur mon pc : https://wiki.archlinux.fr/wifi
a chaque fois que je démarre mon ordi, je dois activer ma carte reseau :

Code : Tout sélectionner

ip link set wlan0 up
elle ne s'active pas une fois pour toute ?
je dois aussi a chaque demarrage lancer la commande :

Code : Tout sélectionner

wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant.conf
?
en gros si je veux activer le reseau sur mon pc j'ai juste a lancer ce script au demarrage ?

Code : Tout sélectionner

ip link set wlan0 up
wpa_supplicant -B -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf
dhcpcd wlan0
?
et je n'ai pas compris la section "Configuration logiciel" ?
je ne l'ai pas fait et ca marche quand meme.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10576
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [wifi] utilisation iw

Message par FoolEcho » dim. 02 févr. 2020, 09:12

AchilleFraisse a écrit :
sam. 01 févr. 2020, 21:53
en gros si je veux activer le reseau sur mon pc j'ai juste a lancer ce script au demarrage ?
C'est la raison d'être des gestionnaires de connexion réseau, ne pas réinventer la roue: https://wiki.archlinux.fr/wifi#Figer_sa_configuration . :|
«The following statement is not true. The previous statement is true.» :nage:

Répondre