[mount] impossible de naviguer ds les CD/DVD - ils n'apparaissent pas dans les explorateurs de fichiers (résolu)

Applications, problèmes de configuration réseau
Le Limule
Hankyu
Messages : 35
Inscription : jeu. 02 août 2012, 20:42

[mount] impossible de naviguer ds les CD/DVD - ils n'apparaissent pas dans les explorateurs de fichiers (résolu)

Message par Le Limule » ven. 14 févr. 2020, 21:29

Bonjour!

Je ne peux pas naviguer ds les CD ou les DVD. (pourtant cela marchait avant)

Quand je mets un CD/DVD ds le lecteur DVD, le CD/DVD n'apparaît pas ds les explorateurs de fichiers (Thunar, SpaceFM, pcmanfm).

(le périphérique est /dev/sr0)

Code : Tout sélectionner

[guigui@guigui-ordi ~]$ mount
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sys on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
dev on /dev type devtmpfs (rw,nosuid,relatime,size=1720464k,nr_inodes=430116,mode=755)
run on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
/dev/sda3 on / type ext4 (rw,relatime)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
bpf on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=32,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=12555)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
/dev/sda1 on /boot type ext2 (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=345584k,mode=700,uid=1000,gid=985)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=985)
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ mount | grep sr0
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ mount /dev/sr0
mount: /dev/sr0: impossible à trouver dans /etc/fstab.
[guigui@guigui-ordi ~]$ 
Si j'ajoute alors "/dev/sr0 /media/cdrom udf,iso9660 user,noauto,ro 0 0" ds fstab, alors je peux voir ceci:

Code : Tout sélectionner

[guigui@guigui-ordi ~]$ mount /dev/sr0
mount: /media/cdrom: /dev/sr0 déjà monté ou point de montage actif.
[guigui@guigui-ordi ~]$
 guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ 
[guigui@guigui-ordi ~]$ mount | grep sr0
[guigui@guigui-ordi ~]$ 
Pour information, voici les propriétés de /dev/sr0 que je peux avoir avec SpaceFM:

Code : Tout sélectionner

DEVICE
/dev/sr0 removable ejectable optical no_media

USAGE
/dev/sr0      ( no media )

FSTAB
/dev/sr0 /media/cdrom udf,iso9660 user,noauto,ro 0 0

INFO
Showing information for /dev/sr0
  native-path:                 /sys/devices/pci0000:00/0000:00:11.0/ata2/host1/target1:0:0/1:0:0:0/block/sr0
  device:                      11:0
  device-file:                 /dev/sr0
    presentation:              /dev/sr0
    by-id:                     /dev/disk/by-id/ata-ATAPI_iHAS122_C_3522526_3E8208501472
  system internal:             0
  removable:                   1
  has media:                   0
  is read only:                0
  is mounted:                  0
  mount paths:                 
  presentation hide:           0
  presentation nopolicy:       0
  presentation name:           
  presentation icon:           
  automount hint:              
  size:                        0
  block size:                  0
  usage:                       
  type:                        
  version:                     
  uuid:                        
  label:                       
  optical disc:
    blank:                     0
    appendable:                0
    closed:                    0
    num tracks:                0
    num audio tracks:          0
    num sessions:              0
  drive:
    vendor:                    ATAPI
    model:                     ATAPI   iHAS122   C
    revision:                  XL01
    serial:                    3522526_3E8208501472
    WWN:                       
    detachable:                0
    ejectable:                 1
    media:                     
      compat:                  optical_cd
    interface:                 scsi
    if speed:                  (unknown)
Je peux écouter/voir des CD/DVD avec un lecteur média (vlc par exemple), mais je ne peux pas naviguer ds les CD/DVD avec un explorateur de fichier.

Que puis-je faire pour résoudre cela?

Merci d'avance!
Dernière modification par Le Limule le sam. 15 févr. 2020, 10:24, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15923
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [mount] impossible de naviguer ds les CD/DVD - ils n'apparaissent pas dans les explorateurs de fichiers

Message par benjarobin » ven. 14 févr. 2020, 21:33

Bonjour,
C'est parfaitement normal, un CD audio ne peux pas être ouvert dans un explorateur de fichier.
Tu ne devrais pas ajouter de ligne dans le fstab !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Le Limule
Hankyu
Messages : 35
Inscription : jeu. 02 août 2012, 20:42

Re: [mount] impossible de naviguer ds les CD/DVD - ils n'apparaissent pas dans les explorateurs de fichiers

Message par Le Limule » ven. 14 févr. 2020, 21:45

Merci de ton retour.

Oui je suis bien d'accord avec toi. Le problème c'est que je ne peux pas ouvrir les CD/DVD de données dans un explorateur de fichier. (avec ou sans ligne ds le fstab)

Le Limule
Hankyu
Messages : 35
Inscription : jeu. 02 août 2012, 20:42

Re: [mount] impossible de naviguer ds les CD/DVD - ils n'apparaissent pas dans les explorateurs de fichiers

Message par Le Limule » sam. 15 févr. 2020, 10:23

OK, je viens de faire une petite MAJ de mon système, et le pb a disparu.

(j'étais sur le dépôt d'archivage à la date du 12 août 2019, et je suis passé à la date du 19 août 2019 - c'est à dire que ds mirorlist j'ai changé la date du dépôt pour le serveur archive.archlinux.org)

Répondre