[reseau] autonegociation à 100Mb max (résolu)

Applications, problèmes de configuration réseau
Avatar de l’utilisateur
pascalp
Daikyu
Messages : 74
Inscription : sam. 14 juil. 2007, 18:06
Localisation : Utrecht
Contact :

[reseau] autonegociation à 100Mb max (résolu)

Message par pascalp »

Bonjour,

Je n'arrive pas à avoir du gigabit avec ma carte reseau :(

Code : Tout sélectionner

[root@vinci pascal]# lspci | grep Ether
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
[root@vinci pascal]# mii-tool -v
eth0: negotiated 100baseTx-FD flow-control, link ok
  product info: vendor 00:07:32, model 17 rev 2
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
[root@vinci pascal]# lsmod | grep r8169
r8169                  42643  0 
mii                     3995  1 r8169
Pourtant normalement ça ne devrait pas poser de problème? c'est bien r8169 qui gère ma carte reseau?
Dernière modification par pascalp le mar. 13 déc. 2011, 13:24, modifié 3 fois.
Avatar de l’utilisateur
Desintegr
Chu Ko Nu
Messages : 354
Inscription : jeu. 28 avr. 2011, 16:42
Localisation : Orléans - France

Re: [reseseau] autonegociation à 100Mb max

Message par Desintegr »

mii-tool est un outil déprécié.
Il faudrait utiliser l'outil ethtool à la place.

D'après les informations retournées par mii-tool, ta carte ou plutôt pilote ne supporte pas les connexions Gigabit.

D'après cette page (http://www.rvdavid.net/how-to-get-gigab ... ntu-linux/), il semblerait que ce soit une limitation du module r8169.

Vérifie toutefois avec ethtool si le mode 1000 est bien supporté.
Avatar de l’utilisateur
pascalp
Daikyu
Messages : 74
Inscription : sam. 14 juil. 2007, 18:06
Localisation : Utrecht
Contact :

Re: [reseseau] autonegociation à 100Mb max

Message par pascalp »

Code : Tout sélectionner

[pascal@vinci ~]$ ethtool eth0
Settings for eth0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Half 1000baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	                                     1000baseT/Full 
	Link partner advertised pause frame use: Symmetric Receive-only
	Link partner advertised auto-negotiation: Yes
	Speed: 1000Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
Curieux il me dit 1000... Pourtant avec un transfert je plafonne à ~11MB/s.

En face je suis connecte à 1000:

Code : Tout sélectionner

[pascal@freenas ~]$ ifconfig 
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=9b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM>
	ether 00:01:c0:06:d4:51
	inet 192.168.1.154 netmask 0xffffff00 broadcast 192.168.1.255
	media: Ethernet autoselect (1000baseTX <full-duplex>)
	status: active
Je croyais que le module r8169 le supportait mais apparement non.
Avatar de l’utilisateur
pascalp
Daikyu
Messages : 74
Inscription : sam. 14 juil. 2007, 18:06
Localisation : Utrecht
Contact :

Re: [reseau] autonegociation à 100Mb max (Abandonné)

Message par pascalp »

J'ai essaye depuis windows, pareil. J'ai aussi un chipset 8168x sur le NAS :( Possible que 'ai le soucis sur les 2PCs mais pour le nas, faut que j'aille voir les gas de freebsd.
Avatar de l’utilisateur
pascalp
Daikyu
Messages : 74
Inscription : sam. 14 juil. 2007, 18:06
Localisation : Utrecht
Contact :

Re: [reseau] autonegociation à 100Mb max (abandonné)

Message par pascalp »

ça y est je suis en 1000! :)

sur arch pas de soucis, installation de r8168 et ça roule.

Sur le nas, depuis je suis passé à centos 6, installé r8168 et impossible de forcer le 1000Mb.

Code : Tout sélectionner

insmod ./src/r8168.ko speed=1000 duplex=1 autoneg=0
ethtool -s eth1 speed 1000 duplex full autoneg off
Les commandes passent en 100Mbs mais pas en 1000

J'ai changé de cable et ça marche, pourtant c'est du 5e, le plus récent que j'ai et il fait environ 1m ?!?! Remplacé par un vieux cat 5...

Par contre avec scp, je plafonne à 200Mb à cause du processeur atom un peu faiblard.

~400Mb en nfs
oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [reseau] autonegociation à 100Mb max (abandonné)

Message par oktoberfest »

Voilà une bonne nouvelle (même si je n'ai pas cette carte).
Tu peux donc passer le sujet en [résolu].
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM
Répondre