[i3] Impossible de démarrer i3

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
kasuke
Hankyu
Messages : 14
Inscription : mar. 06 déc. 2016, 01:54

[i3] Impossible de démarrer i3

Message par kasuke » mer. 10 janv. 2018, 18:43

Bonjour,
Après un long moment d'absence sur archlinux, je décide de m'y remettre. J'avais une config i3 sur mon ubuntu (qui est le même ordinateur) et tout fonctionnait.
Sauf que je n'ai jamais réussi à charger i3 sur Archlinux.
Alors j'ai essayé en faisant un exec i3 dans mon .xinitrc, ça ne fonctionne pas.
Quand je suis en tty et que je lance la commande exec i3, ça me redémarre juste la session tty en me délogant instantanément.
Je suis un peu perdu, je ne sais pas ce qu'il faut faire, la seule interface graphique que j'utilise du coup c'est gdm.
S'il faut fournir des log de xorg ou autre dites moi, et si quelqu'un a déjà installé i3 sur Arch, j'aimerais bien savoir comment il a fait.

Merci d'avance.

Avatar de l’utilisateur
onyx67
Elfe
Messages : 731
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [i3] Impossible de démarrer i3

Message par onyx67 » mer. 10 janv. 2018, 19:20

Ce n'est pas la commande exec qu'il faut lancer mais startx. Si ça peut t'aider: https://wiki.archlinux.fr/Startx
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

kasuke
Hankyu
Messages : 14
Inscription : mar. 06 déc. 2016, 01:54

Re: [i3] Impossible de démarrer i3

Message par kasuke » mer. 10 janv. 2018, 20:14

ok mais il me semble que ça ne fonctionnait pas plus.
Dans ce cas il faut mettre startx chemin vers i3 dans xinitrc ?

Avatar de l’utilisateur
onyx67
Elfe
Messages : 731
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [i3] Impossible de démarrer i3

Message par onyx67 » mer. 10 janv. 2018, 22:32

Que renvoie un échec startx? Faudrait voir également les logs de xorg
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

kachory
newbie
Messages : 5
Inscription : dim. 21 mai 2017, 09:00

Re: [i3] Impossible de démarrer i3

Message par kachory » jeu. 22 févr. 2018, 18:34

kasuke a écrit :
mer. 10 janv. 2018, 20:14
ok mais il me semble que ça ne fonctionnait pas plus.
Dans ce cas il faut mettre startx chemin vers i3 dans xinitrc ?
Tu as réussi à démarrer depuis ?

Je suis sous Arch + i3 aussi et, comme toi, je lance ce dernier depuis un tty.

Il faut d'abord créer le fichier suivant dans ton home

Code : Tout sélectionner

.xinitrc
dans lequel tu écriras l'instruction suivante à l'attention de x ( qui se sert du fichier .xinitrc pour savoir ce qu'il à faire une fois lancé ) :

Code : Tout sélectionner

exec i3
Puis, à chaque démarrage de ta machine tu lanceras x par la commande évoquée plus haut :

Code : Tout sélectionner

startx
Voilà :wink:
Lenovo Yoga 710 14IKB ( Black ) - i5 6200U - 8 Go DDR4 - 256 Go SSD
Archlinux & i3

Répondre