[GNOME/WAYLAND] problème avec le pavé numérique et Verr Num (RÉSOLU)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
superboa
Hankyu
Messages : 43
Inscription : mer. 30 mars 2016, 11:05

[GNOME/WAYLAND] problème avec le pavé numérique et Verr Num (RÉSOLU)

Message par superboa » dim. 29 sept. 2019, 14:45

Bonjour tout le monde,

Après une installation (en ligne de commande) fraîche de mon Arch Linux, j'ai un problème avec le clavier.

Verr Num ne s'active pas au démarrage et les chiffres du pavé numérique ne fonctionnent pas.

C'est apparemment un problème qui vient de Wayland.

Je précise que j'ai installé le pilote libre NVIDIA (xf86-video-nouveau).

Y a-t-il une solution au problème ?

Merci par avance.
Dernière modification par superboa le mer. 09 oct. 2019, 19:32, modifié 1 fois.

laurent85
Chu Ko Nu
Messages : 313
Inscription : mar. 16 oct. 2018, 21:05

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par laurent85 » mer. 02 oct. 2019, 16:16

superboa a écrit :
dim. 29 sept. 2019, 14:45
C'est apparemment un problème qui vient de Wayland.
Bonjour,
As-tu essayé ces solutions ?
https://bbs.archlinux.org/viewtopic.php?id=249301

superboa
Hankyu
Messages : 43
Inscription : mer. 30 mars 2016, 11:05

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par superboa » mer. 02 oct. 2019, 20:26

Bonjour Laurent,
Merci pour ta réponse.

La solution 1 : passer la valeur à false pour « org.gnome.desktop.peripherals.keyboard.remember-numlock-state » n’a rien changé pour moi.

La solution 2 : cocher l’option « Les touches du pavé numérique sont toujours numériques (comme sur Mac OS) » située dans -> Ajustements > Clavier & souris -> Options supplémentaires d’agencement -> Diverses options de compatibilité, m’a tout de même permis d’activer la touche Verr Num au démarrage.

Je poursuis mes investigations…

superboa
Hankyu
Messages : 43
Inscription : mer. 30 mars 2016, 11:05

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par superboa » mer. 02 oct. 2019, 21:02

Bon, toujours rien.
Je tiens à préciser que j’utilise un PC fixe et non un ordinateur portable.
J’apporte également quelques précisions :
au démarrage :
- soit la touche « Verr Num est activée, et il faut que je la désactive pour avoir accès aux chiffres du pavé numérique.
- soit la touche « Verr Num est désactivée, et il faut que je l’active pour avoir accès aux chiffres du pavé numérique.

Si ça peut aider…

Avatar de l’utilisateur
Kristen
Elfe
Messages : 623
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par Kristen » jeu. 03 oct. 2019, 15:00

Salut
Je suis dans le même cas que toi. Le pavé numérique ne fonctionne pas automatiquement sauf pour la connexion avec gdm. À chaque fois, je dois penser à appuyer saur la touche Verr Num.
Depuis le 14 octobre 2011 sur archlinux
GNOME sur PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
XFCE sur PC portable : Lenovo ThinkPad T520i

Avatar de l’utilisateur
Costalfy
newbie
Messages : 8
Inscription : mar. 12 avr. 2011, 14:01
Localisation : Charleroi (Belgique)
Contact :

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par Costalfy » jeu. 03 oct. 2019, 15:34

Je suis dans le meme cas que vous.
Certaine fois le fonctionnement est meme inversé, c-à-d, qu'il faut éteindre le pavé numérique pour qu'il fonctionne... super bizarre

superboa
Hankyu
Messages : 43
Inscription : mer. 30 mars 2016, 11:05

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num

Message par superboa » mer. 09 oct. 2019, 19:31

Salut tout le monde,
problème résolu après quelques mises à jour (par contre, je ne pourrais pas vous préciser lesquelles).

Avatar de l’utilisateur
Kristen
Elfe
Messages : 623
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [GNOME/WAYLAND] problème avec le pavé numérique et Verr Num (RÉSOLU)

Message par Kristen » mer. 09 oct. 2019, 21:44

Super, je vérifierai quand je serai sur le fixe. Pour le moment je suis sur PC portable sans clavier numérique.
Depuis le 14 octobre 2011 sur archlinux
GNOME sur PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
XFCE sur PC portable : Lenovo ThinkPad T520i

Répondre