[Openbox] Bug sur tint2

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
rodak
Hankyu
Messages : 12
Inscription : mer. 30 sept. 2020, 22:58

[Openbox] Bug sur tint2

Message par rodak »

Bonjour,
Je me suis lancé sur Openbox il y a quelques jours, et en mettant gnome-latex dans le lanceur tint2, ça le fait complètement bugger... le lanceur n'apparaît plus et le paramétreur graphique ne répond plus... ça ne revient à la normale que si on supprime la ligne

Code : Tout sélectionner

launcher_item_app = /usr/share/applications/org.gnome.gnome-latex.desktop
que cet ajout a créé dans le fichier de configuration ~/.config/tint2/tint2rc.
Je n'ai pas vu de référencement de ce bug (certes hyper spécifique) par recherche internet...
Y aurait-il un moyen de le contourner ?
rodak
Hankyu
Messages : 12
Inscription : mer. 30 sept. 2020, 22:58

Re: [Openbox] Bug sur tint2

Message par rodak »

Mon problème n'a pas soulevé les foules mais je l'ai résolu : pour afficher les icônes, tint2 va chercher les fichiers .desktop dans /usr/share/applications. Quand on lance tint2conf en ligne de commande, tint2 indique des erreurs sur les icônes de certains fichiers .desktop, dont celui gnome-latex (org.gnome.gnome-latex.desktop, ligne Icon=...).
La solution que j'ai trouvée est de copier les fichiers desktop dont j'ai besoin dans le répertoire de config de tint2, de mettre le bon chemin dans le fichier de config de tint2 (~/.config/tint2/tint2rc) et de changer, donc, l'icône, pour en mettre un qui ne le fait pas râler.
Répondre