[luminosité] touche clavier pour luminosité

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
djipey
Chu Ko Nu
Messages : 437
Inscription : sam. 04 juin 2011, 10:13

[luminosité] touche clavier pour luminosité

Message par djipey » sam. 27 oct. 2012, 11:04

Bonjour.

Je suis sous Openbox et je suis confronté à un problème tout simple. Arch ne reconnait pas par défaut mes touches pour monter/baisser la luminosité. Je suis sur un laptop donc ça marche (enfin non, ça ne marche pas) grâce à une combinaison Fn + uneTouche. J'ai essayé de trouver la valeur de la touche luminositéUp avec xev, mais rien n'y fait.
Par comparaison, quand je fais Fn + VolumeDown, j'ai bien XF86AudioLowerVolume. Mais là quand je fais Fn + luminostéUp, xev ne me retourne rien.

Est-ce que vous auriez une idée pour contourner ça ?


Bien à vous.

Avatar de l’utilisateur
MrMen
Chu Ko Nu
Messages : 477
Inscription : sam. 11 juil. 2009, 14:33
Localisation : (33)

Re: [luminosité] touche clavier pour luminosité

Message par MrMen » sam. 27 oct. 2012, 16:06

Tu peux toujours binder une autre touche pour faire ça…
Arch 64 | Awesome | Zsh | Bépo

djipey
Chu Ko Nu
Messages : 437
Inscription : sam. 04 juin 2011, 10:13

Re: [luminosité] touche clavier pour luminosité

Message par djipey » sam. 27 oct. 2012, 16:27

Ouais mais tu avoueras que ce n'est pas vraiment une solution. Déjà parce que ces touches sont marquées avec un petit dessin bien pratique, et ensuite parce qu'étant sous openbox, je pense qu'à peu près toutes mes touches sont mappées, d'une façon ou d'une autre. Ajoute à ça que j'utilise vim, lui aussi mappant certaines touches, je peux t'assurer qu'à chaque fois que je veux ajouter un raccourci clavier, je galère avec les conflits.

Avatar de l’utilisateur
MrMen
Chu Ko Nu
Messages : 477
Inscription : sam. 11 juil. 2009, 14:33
Localisation : (33)

Re: [luminosité] touche clavier pour luminosité

Message par MrMen » sam. 27 oct. 2012, 16:48

Oui je comprends bien le soucis. C'était une solution comme une autre… Tu n'as pas un keycode qui apparait quand tu fais «luminosité up» ? Et en faisant les tests pour tous les fn+fx pas un seul luminosité up ?
Arch 64 | Awesome | Zsh | Bépo

sushi
Hankyu
Messages : 36
Inscription : mer. 27 juil. 2011, 23:18

Re: [luminosité] touche clavier pour luminosité

Message par sushi » sam. 27 oct. 2012, 18:37

djipey a écrit :J'ai essayé de trouver la valeur de la touche luminositéUp avec xev, mais rien n'y fait.
Par comparaison, quand je fais Fn + VolumeDown, j'ai bien XF86AudioLowerVolume. Mais là quand je fais Fn + luminostéUp, xev ne me retourne rien.
Même constat chez moi. C'est pas récent et j'avais fini par lacher l'affaire. Mon portable étant en fixe et avec une luminosité déjà limite à fond, cette fonction ne me manque pas trop. Mais moi aussi j'aimerai comprendre le pourquoi.

Courage, tu n'es pas le seul ;)

Clark
archer
Messages : 142
Inscription : dim. 01 juil. 2007, 15:41

Re: [luminosité] touche clavier pour luminosité

Message par Clark » sam. 27 oct. 2012, 20:23

Avez-vous regardé cette page du wiki : http://wiki.archlinux.fr/Xmodmap ?

Elle est faite (à la base) exprès pour résoudre ce problème...

Clark
archer
Messages : 142
Inscription : dim. 01 juil. 2007, 15:41

Re: [luminosité] touche clavier pour luminosité

Message par Clark » sam. 27 oct. 2012, 20:42

Il est aussi possible qu'un module spécifique soit nécessaire pour certains portables (je pense aux samsung par ex). Quelle est la marque des votres ?

sushi
Hankyu
Messages : 36
Inscription : mer. 27 juil. 2011, 23:18

Re: [luminosité] touche clavier pour luminosité

Message par sushi » sam. 27 oct. 2012, 22:34

@clark

J'avais plus regardé "Extra_Keyboard_Keys" sur le wiki.

Jouer avec xmodmap ne sert a rien dans mon cas, le problème étant qu'il n'y pas de keycode attribué pour les touches de luminosité. Pour le son j'avais trouvé une solution, parce que j'avais des touches pour binder. La c'est comme si la touche n'existait pas.

Méthode du wiki :
1. test avec showkey = pas de keycode
2. test avec dmesg pour trouver un scancode = rien
"If nothing new appears in dmesg then your key does not have a scancode, which means that it is not recognized by the kernel and cannot be used."
Je m'étais donc arrêté là. En me disant que ca finira bien par marcher un jour lors d'un changement de kernel...

Sinon ma machine c'est un Compaq 6720s (HP).

sushi
Hankyu
Messages : 36
Inscription : mer. 27 juil. 2011, 23:18

Re: [luminosité] touche clavier pour luminosité

Message par sushi » sam. 27 oct. 2012, 23:04

Tient je viens de me rendre contre d'un bug, en débranchant par erreur ma machine. En fait les touches marchent, mais juste pas tout de suite. Je m'explique :

1. Le pc est branché, je baisse la luminosité avec la touche spéciale = rien en se passe
2. Je débranche le pc = la luminosité passe au réglage du mode batterie (plus faible dans mon cas). J'augmente via la touche spéciale = rien ne se passe
3. Je rebranche le pc = la luminosité se règle comme elle aurait du le faire immédiatement en "1."
4. Je débranche le pc = la luminosité se règle comme elle aurait du le faire immédiatement en "2."

Il faut faire un cycle branché / débranché, et le réglage est pris en compte ! Étonnant non ? Ca marche aussi dans l'autre sens pour le mode sur batterie. D'autant plus surprenant que je n'arrive pas à détecter de codes pour ces touches...

antiheros
Hankyu
Messages : 25
Inscription : dim. 04 oct. 2009, 18:59

Re: [luminosité] touche clavier pour luminosité

Message par antiheros » sam. 27 oct. 2012, 23:24

le changement de luminosité que tu décris n'à rien à voir avec les touches de fonction, la luminosité est modifiée uniquement par le passage de secteur à batterie et vice versa. Pour t'en convaincre, débranche ton ordi puis rebranche le sans appuyer sur les touches de fonction, tu observeras le même changement de luminosité.

PS j'ai le même hp compaq 6720s que toi, et le même problème que je n'ai pas pu résoudre non plus.

edit : correction, je viens d'essayer exactement ta manip et il se produit ce que tu décris chez moi aussi, à savoir une augmentation de la luminosité quand je débranche et une diminution quand je rebranche, c'est à dire exactement l'inverse de ce qui se passe si on n'appuie pas sur les touches de fonction. vraiment bizarre ce truc !

sushi
Hankyu
Messages : 36
Inscription : mer. 27 juil. 2011, 23:18

Re: [luminosité] touche clavier pour luminosité

Message par sushi » sam. 27 oct. 2012, 23:43

Ouai, du coup ca permet de régler la luminosité comme on veut, à condition d'avoir le chargeur et du courant sous la main. Si on est juste avec la batterie, impossible de régler la luminosité.

Une piste : j'ai survolé des vieux posts sur d'autre forum où ca parle de rajouter une option a la ligne du kernel dans grub, relatif a l'acpi. Mais j'ai la flemme de creuser :)

Et sinon, personne ne sait comment régler la luminosité simplement avec une ligne de commande ? Pour le binder sur autre touche.

Avatar de l’utilisateur
MrMen
Chu Ko Nu
Messages : 477
Inscription : sam. 11 juil. 2009, 14:33
Localisation : (33)

Re: [luminosité] touche clavier pour luminosité

Message par MrMen » dim. 28 oct. 2012, 01:26

Dans le cas ou tu veux justevmodifier la luminosite en ligne de commande, un cat en root sur un fichier de /proc reglera le probleme.
Tout depend de ta carte graphique et du module que tu utilises ensuite...
Arch 64 | Awesome | Zsh | Bépo

djipey
Chu Ko Nu
Messages : 437
Inscription : sam. 04 juin 2011, 10:13

Re: [luminosité] touche clavier pour luminosité

Message par djipey » dim. 28 oct. 2012, 09:57

Même pas besoin, un

xbacklight -inc 40

marche très bien. Après je m'en fiche que la luminosité ne soit pas native, tant que je peux mapper sur une combinaison de touches. En l'occurence, je voulais mapper ça sur Fn + luminosité. Comme je l'ai fait avec le son, sauf que là, dans le terminal avec xev, pas de X86LuminositéMachin.

Avatar de l’utilisateur
LuX
archer de cavalerie
Messages : 182
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [luminosité] touche clavier pour luminosité

Message par LuX » jeu. 01 nov. 2012, 23:38

Bonjour

Sushi l'a évoqué, il suffit souvent d'ajouter une ou plusieurs option(s) à la ligne de commande de grub au démarrage. Exemple extrait de mon /etc/grub.d/40_custom (j'utilise grub2, avec grub modifier directement le fichier menu.lst) :

Code : Tout sélectionner

menuentry "Arch Linux, avec Linux linux (on /dev/sda2)" {
set root=(hd0,2)
linux /boot/vmlinuz-linux root=UUID=480b8c27-aa9e-475c-bde1-772e768c85f1 ro  quiet acpi_osi=Linux
initrd /boot/initramfs-linux.img
}
Voir ici :
https://wiki.archlinux.org/index.php/AS ... owersaving

Ou là :
http://geekdefrance.fr/2010/07/15/acpi_ ... ez-le-feu/

Chez moi ça a réglé le problème sur deux portables (un Dell et un Toshiba). Cela dit d'autres posts ici ou ailleurs préconisent d'autres valeurs, par exemple "acpi_osi=". Voir Google :

https://www.google.fr/search?q=archlinu ... osit%C3%A9

Cordialement,
LuX

djipey
Chu Ko Nu
Messages : 437
Inscription : sam. 04 juin 2011, 10:13

Re: [luminosité] touche clavier pour luminosité

Message par djipey » ven. 02 nov. 2012, 22:52

Euh, petite question au passage. Quand je dois modifier ce genre de choses, je le fais sur le fichier /boot/grub/grub.cfg.

Est-ce que c'est un problème, comparé au fichiers que tu modifies ?

Sinon, voici ma ligne de boot:

Code : Tout sélectionner

linux	/boot/vmlinuz-linux root=UUID=2745938a-fdf9-447b-866f-f3de5518aed5 ro  quiet pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor
J'ai d'abord essayé sans le acpi_backlight=vendor, puis avec, et je ne récupère l'usage de mes hotkeys pour la luminosité.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10508
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [luminosité] touche clavier pour luminosité

Message par FoolEcho » sam. 03 nov. 2012, 10:13

djipey a écrit :Euh, petite question au passage. Quand je dois modifier ce genre de choses, je le fais sur le fichier /boot/grub/grub.cfg.

Est-ce que c'est un problème, comparé au fichiers que tu modifies ?
Ce n'est un problème que si tu utilises grub-mkconfig pour générer ton grub.cfg. Dans ce cas, il faut éditer /etc/default/grub avant de lancer la commande.
https://wiki.archlinux.org/index.php/GR ... mmended.29
«The following statement is not true. The previous statement is true.» :nage:

djipey
Chu Ko Nu
Messages : 437
Inscription : sam. 04 juin 2011, 10:13

Re: [luminosité] touche clavier pour luminosité

Message par djipey » sam. 03 nov. 2012, 10:41

Ouais j'ai utilisé ça la première fois, et maintenant j'édite un fichier plein de conditions absolument illisible. J'aurais bien voulu garder la syntaxe de Grub (la vieille version), un peu comme celle qu'ils proposent dans le wiki, mais j'ai peur qu'en adoptant ça, je risque de manquer quelque chose et que ça ne boote plus.

sushi
Hankyu
Messages : 36
Inscription : mer. 27 juil. 2011, 23:18

Re: [luminosité] touche clavier pour luminosité

Message par sushi » lun. 12 nov. 2012, 21:54

@LuX Merci pour les liens

@djipey
j'ai peur qu'en adoptant ça, je risque de manquer quelque chose et que ça ne boote plus.
N'ai pas peur de modifier les fichiers de grub, je plante régulièrement mon grub, ce n'est vraiment pas un problème :)
Je l'ai encore fait ce W-E...

Fait une copie de ton fichier de config avant modification. Si ton linux ne démarre plus, il suffit de remettre le bon fichier soit en bootant sur un livecd, soit en utilisant ta session windows si tu en as une et que ta partition où se trouve /boot est formaté en Ext (grâce a ext2fsd par exemple). Ou commente / dé-commente les lignes concernés dans le fichier. Dans tout les cas ce ne sera pas une très grosse perte de temps si tu as anticipé le plantage ^^'

Ce qui est plus chiant, c'est quand on rate l'installation de grub dans la mbr. Là il faut nécessairement passer par un livecd, faire un chroot, et réinstaller proprement grub. Mais il n'y aucune raison d'en arriver là en modifiant juste quelques fichiers de configuration.

Avatar de l’utilisateur
Youpi
yeomen
Messages : 252
Inscription : sam. 16 juin 2012, 22:44

Re: [luminosité] touche clavier pour luminosité

Message par Youpi » mar. 20 nov. 2012, 17:52

j'ai trouvé ça, si ça peut aider :

http://forum.pcastuces.com/augmentet_la ... s13018.htm

la touche Fn est contrôlée par le BIOS. Peut-être que c'est là que tu peux activer la luminosité.

Il y a un module du noyau Linux dédié aux portables Samsung, samsung-laptop . Il faudrait peut-être le charger

sudo modprobe samsung-laptop

et exécuter la commande

sudo rfkill list

afin de voir si quelque chose est bloqué.

Il y a sûrement aussi des applications qui permettent de changer la luminosité de l'écran. Sous ma ArchLinux disponibles sont

easy-slow-down-manager-nf-svn 30-2 (3)
Fan, brightness and WiFi controls for Samsung laptops including NF110/NF210/NF310

xbrightness 0.3-2 (5)
Software X11 brightness control

La commande

apt-cache search brightness

et l'interface Synaptic devraient t'en dire plus sur ces applications pour Mint.
Arch 64 bit + Kernel ck-corex + Tint2 et fbpanel + OpenBox + Bumblebee + conky + eclipse et matlab
navigateur internet : iron (yaourt iron-bin)

Répondre