[cairo-compmgr] Problème de compilation (résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

[cairo-compmgr] Problème de compilation (résolu)

Message par Starkdop » mer. 09 janv. 2013, 23:03

Bonjour à tous.

J'essaye désespérément d'installer Cairo Composite Manager (pour les petits effets transparence et tout tavu), je suis sous Openbox.
J'ai récupéré cairo-compmgr version git dans les dépots AUR. Durant la compilation j'ai cette erreur :

Code : Tout sélectionner

/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_compress_section_contents: error: undefined reference to 'compressBound'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_compress_section_contents: error: undefined reference to 'compress'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_get_full_section_contents: error: undefined reference to 'inflateEnd'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_get_full_section_contents: error: undefined reference to 'inflateInit_'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_get_full_section_contents: error: undefined reference to 'inflate'
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.7.2/../../../../lib/libbfd.a(compress.o):function bfd_get_full_section_contents: error: undefined reference to 'inflateReset'
collect2: error: ld returned 1 exit status

Evidemment je ne comprends rien à cette erreur.
Ensuite j'ai télécharger compmgr version pas git toujours dans les paquet AUR. Mais j'ai cette erreur:

Code : Tout sélectionner

libz.a could not read symbols
Je suis un peu perdu, vous pouvez m'aider ?
Dernière modification par Starkdop le sam. 12 janv. 2013, 12:01, modifié 5 fois.

Avatar de l’utilisateur
chipster
Maître du Kyudo
Messages : 2063
Inscription : ven. 11 août 2006, 22:25
Localisation : Saint-Étienne (42)
Contact :

Re: Problème compilation cairo-compmgr

Message par chipster » jeu. 10 janv. 2013, 09:20

topic :D

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] problème de compilation

Message par FoolEcho » jeu. 10 janv. 2013, 20:34

Pour cairo-compmgr, modifie la ligne suivante dans le PKGBUILD:

Code : Tout sélectionner

./autogen.sh --prefix=/usr LIBS="-ldl -lgmodule-2.0"
par:

Code : Tout sélectionner

./autogen.sh --prefix=/usr LIBS="-ldl -lgmodule-2.0 -lz"
(c'est ce que m'inspire l'erreur que tu rencontres et le dernier commentaire sur AUR)
Ça devrait compiler au moins (je n'ai pas testé après).

Et... du coup, pour cairo-compmgr-git, pareil, ça devrait compiler avec:

Code : Tout sélectionner

./autogen.sh --prefix=/usr LIBS="-ldl -lgmodule-2.0 -lm -lz"
(ça le fait chez moi en tous cas)

Je n'ai pas testé le programme sinon. Indique-nous si ça fonctionne et on pourra le signaler sur AUR. :D
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] problème de compilation

Message par Starkdop » jeu. 10 janv. 2013, 22:04

J'avais les mains jointes pendant la compilation mais malheureusement cette manip' ne fonctionne pas ni pour la version normale, ni pour la version git.
EDIT: au début j'utiliser xcompmgr, mais j'ai eu des problème d'ombres et je trouve qu'il n'est pas très personnalisable. Si quelqu'un a une alternative à cairo et à xcompmgr, je suis preneur :)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] problème de compilation

Message par FoolEcho » ven. 11 janv. 2013, 09:39

Starkdop a écrit :cette manip' ne fonctionne pas ni pour la version normale, ni pour la version git.
Ne fonctionne pas ou ne compile pas ?
Désolé d'insister parce que chez moi, aucun problème: d'une part les deux compilent avec -lz en plus (sans effectivement, ça ne passe pas) et cairo-compmgr -c par exemple depuis un terminal et j'ai bien de quoi configurer (bon après, ayant déjà un gestionnaire de fenêtre je n'ai pas testé dans le .xinitrc Cairo_Compmgr).
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
z3bra
archer
Messages : 127
Inscription : jeu. 28 juin 2012, 23:17

Re: [cairo-compmgr] problème de compilation

Message par z3bra » ven. 11 janv. 2013, 11:58

Starkdop a écrit :Si quelqu'un a une alternative à cairo et à xcompmgr, je suis preneur
Il y a compton-git disponible sur AUR. C'est un fork de xcompmgr-dana, lui même un fork de xcompmgr.
Tu as toutes les fonctionnalité d'xcompmgr, avec d'autres effets en plus (je les ai plus en tête, le man est ton ami ;) )
archlinux - 2bwm [ blog | git ]

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] problème de compilation

Message par Starkdop » ven. 11 janv. 2013, 16:23

Ne fonctionne pas ou ne compile pas ?
Ne se compile pas.
Il y a compton-git disponible sur AUR. C'est un fork de xcompmgr-dana, lui même un fork de xcompmgr.
Durant l'installation de compton-git, j'ai cette erreur:

Code : Tout sélectionner

/usr/bin/ld: ne peut trouver -lGL
collect2: erreur: ld a retourné 1 code d'état d'exécution
make: *** [compton] Erreur 1
Je n'ai rien trouvé sur internent :(

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] problème de compilation

Message par FoolEcho » ven. 11 janv. 2013, 16:45

Quelle est la sortie pour cairo-compmgr ou cairo-compmgr-git ? (il manque peut-être une dépendance dans les PKGBUILDs vu que ça compile au moins chez moi et j'ai testé aussi sous i686 )
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] problème de compilation

Message par Starkdop » ven. 11 janv. 2013, 17:03

Voici le pastebin de la compilation de cairo-compmgr-git:
http://pastebin.com/TgBcRycq

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] problème de compilation

Message par FoolEcho » ven. 11 janv. 2013, 18:05

Supprime le répertoire src et relance la construction du paquet. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] problème de compilation

Message par Starkdop » ven. 11 janv. 2013, 18:16

Supprime le répertoire src et relance la construction du paquet.
Toujours la même erreur, même en ayant gardé le -lz dans PKGBUILD.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] problème de compilation

Message par FoolEcho » ven. 11 janv. 2013, 18:21

:shock: ... pige pas. C'est pareil avec cairo-compgmr ?
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] problème de compilation

Message par Starkdop » ven. 11 janv. 2013, 18:57

... pige pas. C'est pareil avec cairo-compgmr ?
Oui, j'ai exactement les même erreurs que j'ai mentionné dans mon topic.

J'abandonne les boyz :cry:

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] Problème de compilation (abandon)

Message par FoolEcho » ven. 11 janv. 2013, 19:55

... voudrais bien investiguer un peu plus quand même si tu veux... avec le log complet de la compilation ainsi que la sortie de find /usr/lib -iname "libgl*" (en root ; iname parce que j'ai un doute sur libgl ou libGL... m'a l'air d'être libGL). J'ai l'impression qu'il te manque libgl ce qui m'étonne, tu as quelle carte graphique et son pilote est-il installé ?
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] Problème de compilation (abandon)

Message par Starkdop » ven. 11 janv. 2013, 22:39

Je ne peux pas récupérer la totalité des logs de la compilation étant donné que mon terminal ne remonte pas assez haut.
Voici les logs:
http://pastebin.com/Qcz28GbW

Pour ce qui est de la commande: find /usr/lib -iname "libgl*", voici ce qui en résulte:

Code : Tout sélectionner

[root@mathieu-desktop cairo-compmgr]# find /usr/lib -iname "libgl*"
/usr/lib/libglibmm-2.4.so
/usr/lib/libglib-2.0.so
/usr/lib/libglibmm-2.4.so.1
/usr/lib/libglibsharpglue-2.so
/usr/lib/pkgconfig/libglade-2.0.pc
/usr/lib/xorg/modules/extensions/libglx.so
/usr/lib/xorg/modules/extensions/libglx.so.310.19
/usr/lib/libglade-2.0.so.0.0.7
/usr/lib/libGL.so.1
/usr/lib/libglibmm-2.4.so.1.3.0
/usr/lib/libgladesharpglue-2.so
/usr/lib/libGL.so
/usr/lib/libglade-2.0.a
/usr/lib/libglapi.so.0
/usr/lib/libGL.so.310.19
/usr/lib/libglibmm_generate_extra_defs-2.4.so
/usr/lib/libglibmm_generate_extra_defs-2.4.so.1.3.0
/usr/lib/libglapi.so.0.0.0
/usr/lib/libglapi.so
/usr/lib/gtk-2.0/2.10.0/engines/libglide.so
/usr/lib/libglade-2.0.so
/usr/lib/libglibmm_generate_extra_defs-2.4.so.1
/usr/lib/libglade-2.0.so.0
/usr/lib/libglib-2.0.so.0
/usr/lib/libGL.la
/usr/lib/libglib-2.0.so.0.3400.3
Normalement Xorg et mon pilote Nvidia propriétaire est bien installé.
La résolution est bien à son maximum, la transparence et les divers effets fonctionnent bien avec xcompmgr donc normalement, aucun problème côté affichage.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] Problème de compilation

Message par FoolEcho » sam. 12 janv. 2013, 09:22

Ça ira avec la sortie de find je pense.
Ton installation de xorg-server (au minimum, espérons) est cassée, en effet il manque au moins /usr/lib/xorg/modules/extensions/libglx.xorg (j'ai pas vérifié pour les autres, mais cette bibliothèque m'a attiré l'œil). Chose que tu devrais pouvoir vérifier avec pacman -Qk xorg-server (dans le doute, fais de même avec xorg-xinit xorg-server-utils et nvidia, nvidia-utils).

Donc réinstalle au moins xorg-server et retente la compilation. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] Problème de compilation

Message par Starkdop » sam. 12 janv. 2013, 11:04

Effectivement, un fichier était manquant xorg-server. Je l'ai donc réinstallé et le fichier manquant est revenu.
Par contre, je n'ai pas installé nvidia et nvidia-utils étant donné que j'ai installé mon pilote via le .run de chez Nvidia.
J'ai quand même essayé d'installer nvidia et nvidia utils mais ils rentrent en conflit avec libGL.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10579
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [cairo-compmgr] Problème de compilation

Message par FoolEcho » sam. 12 janv. 2013, 11:21

Starkdop a écrit :Par contre, je n'ai pas installé nvidia et nvidia-utils étant donné que j'ai installé mon pilote via le .run de chez Nvidia.
:rhooo: C'est très mal ! Arch a un gestionnaire de paquets et le paquet existe, ce n'est pas pour rien. :twisted:
Starkdop a écrit :J'ai quand même essayé d'installer nvidia et nvidia utils mais ils rentrent en conflit avec libGL.
Il te suffit de désinstaller libgl avec pacman -Rdd libgl puis impérativement d'installer nvidia. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Starkdop
Hankyu
Messages : 14
Inscription : jeu. 03 janv. 2013, 18:02

Re: [cairo-compmgr] Problème de compilation

Message par Starkdop » sam. 12 janv. 2013, 12:00

Et voilà, victoire !
J'ai viré le pilote Nvidia venant du .run en faisant # ./NVIDIA.run --uninstall, j'ai installé nvidia et nvidia-utils.
J'ai retenté la compilation et elle s'est déroulée avec succès !

@FoolEcho merci beaucoup pour ton aide !

En plus, je n'ai plus de problème d'ombre que j'avais avec xcompmgr. J'ai des effets intéressants en plus etc...
Je conseil vivement cairo-compmgr !

Répondre