[libxcb] Bug avec certaines applis

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

[libxcb] Bug avec certaines applis

Message par Skunnyk » mer. 02 janv. 2008, 22:47

Hellow les Archers,

Je ne sais pas si d'autres ont le même genre de problème, mais dès que je lance une appli java graphique, j'ai droit à de belle insultes de ce genre:

Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xab6c6767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xab6c68b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xab712a8d]
#3 /opt/java/jre/lib/i386/xawt/libmawt.so [0xab81b64e]
#4 /opt/java/jre/lib/i386/xawt/libmawt.so [0xab7f9f97]
#5 /opt/java/jre/lib/i386/xawt/libmawt.so [0xab7fa248]
#/opt/java/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xab7fa54f]

Le log complet: http://pastebin.archlinux.fr/32294 .

J'ai 2 pc sous Arch, j'ai le problème avec les 2.
Sur mon portable, j'ai ces erreurs, et l'appli ne se lance pas. Sur le fixe, les erreurs s'affichent, et ensuite l'appli se lance sans problème ...
Cela ne me gênait pas trop jusqu'à maintenant, n'utilisant pas vraiment java sur mon portable ..

Mais j'ai voulu testé un jeux (Dark Horizons : Lore Invasion pour ne pas le citer), et cette même erreur apparait sur mes 2 machines, et sur aucune des 2 le jeu ne se lance ... J'ai réinstallé la libxcb, defois que .. mais aucun changement! (il n'y a pas eu de mises à jour depuis début novembre, et ces problèmes datent d'après il me semble). En même temps, je ne sais pas si les erreurs sont du à java, à la libxcb ou autres chose ...

Un avis ?

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » lun. 14 janv. 2008, 22:31

Et bien, je vois que ca n'inspire pas grand monde tout ca ;)
Juste pour signaler que j'ai encore ce problème, il y a eu une update de la jre (6u3-2), mais toujours pareil ! Je me sens un peu seul là :p

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » lun. 14 janv. 2008, 23:16

j'ai installé une appli java pour tester et j'ai la même erreur. Voilà t'es bien avancé maintenant :lol:

Avatar de l’utilisateur
bapt
Daikyu
Messages : 85
Inscription : jeu. 20 sept. 2007, 09:20
Contact :

Message par bapt » mar. 15 janv. 2008, 09:08

Moi j'utilise icedtea (sur mon aur :)) et je n'ai pas ce problèmes, en plus c'est libre.

Par contre c'est long a compiler et ne compile qu'en root (bug fakeroot)

Avatar de l’utilisateur
FredBezies
Elfe
Messages : 572
Inscription : ven. 21 déc. 2007, 21:25
Localisation : Biganos (33)
Contact :

Message par FredBezies » mar. 15 janv. 2008, 10:17

bapt a écrit :Moi j'utilise icedtea (sur mon aur :)) et je n'ai pas ce problèmes, en plus c'est libre.

Par contre c'est long a compiler et ne compile qu'en root (bug fakeroot)
Combien de temps ? Car je serais intéressé par icedtea... Par contre, compiler en root... :(
"Ceux qui sont prêts à sacrifier une liberté essentielle pour acheter une sûreté passagère, ne méritent ni l'une ni l'autre." (Benjamin Franklin)

Répondre