[dwm] Téléchargement, installation et configration(resolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 16:45

Étrange ta configuration, normalement tu ne dois pas avoir graphical.target ni default.target...
Donne la sortie de :

Code : Tout sélectionner

rm -R graphical.target default.target
systemctl disable slim.service
systemctl enable slim.service
tree /etc/systemd/system
cat /proc/cmdline
reboot
# Le pc redémarre...
date
systemctl status -l slim.service
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 17:00

Les deux fichiers se suppriment sans soucis.
Lorsque je désactive slim.service, il supprime /etc/systemd/system/display-manager.service.
Lorsque je réactive slim.service, il créer un lien symbolique sur le fichier donnée ci-dessus.
Sortie : tree/etc/systemd/system :

Code : Tout sélectionner

/etc/systemd/system
|_dbus-org.wicd.daemon.service -> /usr/lib/systemd/system/wicd.service
|_display-manager.service -> /usr/lib/systemd/system/slim.service
|_getty.target.wants
| |_getty@tty1.service -> /usr/lib/systemd/system@getty/service
|_multi-user.target.wants
  |_remote-fs.target -> ../../../../usr/lib/systemd/system/remote-fs.target
  |_wicd.service -> /usr/lib/systemd/system/wicd.service

2 directories, 5 files
Sortie : cat /proc/cmdline

Code : Tout sélectionner

BOOT_IMAGE=/vmlinuz-linux root=UUID=fc2d71e4-cde7-4db7-9d04-d37e769e04fa rw quiet
reboot (le PC redémarre)
Sortie date :

Code : Tout sélectionner

mer. mai 7 17:01:30 CEST 2014
Sortie systemctl status -l slim.service :

Code : Tout sélectionner

slim.service - SLiM Simple Login Manager
  Loaded: loaded (/usr/lib/systemd/system/slim.service; enable)
  Active: [color=#FF0000]failed[/color] (Result: start-limit) since mer. 2014-05-07 17:01:25 CEST; 1min 25s ago
 Process: 263 ExecStart=/usr/bin/slim -nodaemon [color=#FF0000](code=exited, status=1/FAILURE)[/color]
Main PID: 263 (code=exited, status=1/FAILURE

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 17:09

En résumé slim essaye bien de se lancer, mais échoue...

Tu as bien lancé systemctl status en root ? Ce qui m’intéresse c'est la partie qui est ensuite (le log).
Sinon peux tu donner la sortie en root (si non identique) de :

Code : Tout sélectionner

journalctl -b -u slim.service
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 17:29

Sortie de journalctl -b -u slim.service :

Code : Tout sélectionner

mai 07 17:01:18 Desktop slim[214]: /usr/bin/xauth: file /var/run/slim.auth does not exist
mai 07 17:01:19 Desktop systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
mai 07 17:01:19 Desktop systemd[1]: Unit slim.service entered failed state.
mai 07 17:01:20 Desktop systemd[1]: slim.service holdoff time over, scheduling restart
mai 07 17:01:20 Desktop systemd[1]: Stopping SLiM Simple Manager...
mai 07 17:01:20 Desktop systemd[1]: Starting SLiM Simple Manager...
mai 07 17:01:20 Desktop systemd[1]: Started SliM Simple Manager.
mai 07 17:01:20 Desktop slim[237]: /usr/bin/xauth: file /var/run/slim.auth does no exist
mai 07 17:01:21 Desktop systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
mai 07 17:01:21 Desktop systemd[1]: Unit slim.service entered failed state.
mai 07 17:01:21 Desktop systemd[1]: slim.service holdoff time over, scheduling restart.
mai 07 17:01:21 Desktop systemd[1]: Stopping SLiM Simple Manager...
mai 07 17:01:21 Desktop systemd[1]: Starting SLiM Simple Manager...
mai 07 17:01:21 Desktop systemd[1]: Started SLiM Simple Manager.
mai 07 17:01:21 Desktop slim[255]: /usr/bin/xauth: file /var/run/slim.auth does not exist
mai 07 17:01:22 Desktop systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
mai 07 17:01:22 Desktop systemd[1]: Unit slim.service entered failed state.
mai 07 17:01:22 Desktop systemd[1]: slim.service holdoff time over, scheduling restart.
mai 07 17:01:22 Desktop systemd[1]: Stopping SLiM Simple Manager...
mai 07 17:01:22 Desktop systemd[1]: Starting SLiM Simple Manager...
mai 07 17:01:22 Desktop systemd[1]: Started SLiM Simple Manager.
mai 07 17:01:22 Desktop slim[259]: /usr/bin/xauth: file /var/run/slim.auth does no exist
mai 07 17:01:23 Desktop systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
mai 07 17:01:23 Desktop systemd[1]: Unit slim.service entered failed state.
mai 07 17:01:23 Desktop systemd[1]: slim.service holdoff time over, scheduling restart.
mai 07 17:01:23 Desktop systemd[1]: Stopping SLiM Simple Manager...
mai 07 17:01:23 Desktop systemd[1]: Starting SLiM Simple Manager...
mai 07 17:01:23 Desktop systemd[1]: Started SLiM Simple Manager.
mai 07 17:01:23 Desktop slim[263]: /usr/bin/xauth: file /var/run/slim.auth does no exist
mai 07 17:01:24 Desktop systemd[1]: slim.service: main process exited, code=exited, status=1/FAILURE
mai 07 17:01:24 Desktop systemd[1]: Unit slim.service entered failed state.

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 19:57

Suite à un reboot, directement depuis un tty, copie le log de Xorg (/var/log/Xorg.0.log) dans un dossier "temporaire" et donne nous son contenu.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 20:10

Je n'ai pas de fichier Xorg.o.log

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 20:15

Si obligé que tu es un fichier :

Code : Tout sélectionner

/var/log/Xorg.0.log
Attention c'est un '0' (zero) et non un 'o' (lettre o)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 20:18

Ben non , j'en ai pas. J'ai meme pas de Xorg tout court !

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [dwm] Téléchargement, installation et configration(en co

Message par FoolEcho » mer. 07 mai 2014, 20:21

Ça ne risque pas de fonctionner sans serveur X (ce qui explique pourquoi tu n'avais pas libx11 notamment...). :copain:

Xorg
«The following statement is not true. The previous statement is true.» :nage:

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 20:25

benjarobin a écrit :Tout d'abord est ce que slim se lance si tu tapes :

Code : Tout sélectionner

systemctl start slim
AchilleFraisse a écrit :Oui, slim ce lance !
AchilleFraisse a écrit : J'ai meme pas de Xorg tout court !
Il n'y a pas comme un problème ? Comment slim peut se lancer sans Xorg ? C'est possible ?! Je ne pense pas...
Donc tu m'as fait partir dans des hypothèses plus ou moins farfelus...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 20:32

Excusez moi, ce n'etait pas nvidia mais nouveau !
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Ah daccord ;). Je suis entrain d'installer xorg, et ils disent te taper la commande suivante : pacman -S xf86-video-votrepilote . Or, ma carte graphique c'est nvidia. Mais il me dit que le packet xf86-video-nvidia n'existe pas !

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 20:49

Les choses avance petit à petit ;)
Lorsque je reboot mon PC j'arrive directement sur la page de slim. Quand je me logue, j'ai un xterm en haut à gauche de mon écran, puis au out de 10s, mon ecran revient sur un terminale noir. ??? Et dwm ne se lance pas. Pourtant je l'ai compilé

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 20:51

benjarobin a écrit :
benjarobin a écrit :Tout d'abord est ce que slim se lance si tu tapes :

Code : Tout sélectionner

systemctl start slim
AchilleFraisse a écrit :Oui, slim ce lance !
AchilleFraisse a écrit : J'ai meme pas de Xorg tout court !
Il n'y a pas comme un problème ? Comment slim peut se lancer sans Xorg ? C'est possible ?! Je ne pense pas...
Donc tu m'as fait partir dans des hypothèses plus ou moins farfelus...
Lorsque je disait que slim se lancer, c'est qu'il n'y avait pas de message d'erreur, mais je restait tout de meme dans mon terminale. Desole pour ce mal entendu ;(

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » mer. 07 mai 2014, 21:05

Le xterm et les 10s c'était à cause de mon fichier .xinitrc. Comment il faut que je le configure correctement ? Et y-a t-il quelque chose d'autre à installer ou normalement je suis au complet ?

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » mer. 07 mai 2014, 21:06

AchilleFraisse a écrit :Quand je me logue, j'ai un xterm en haut à gauche de mon écran, puis au out de 10s, mon ecran revient sur un terminale noir. ??? Et dwm ne se lance pas. Pourtant je l'ai compilé
Je te conseil de lire calmement le Wiki (DWM, Slim, ...) !!! Et surtout essayer de comprendre ce que tu fais...
Pour t'aider, je te donne une piste : slim à le même comportement que startx et utilise donc le fichier .xinitrc
Wiki a écrit :SLiM utilise cependant le fichier $HOME/.xinitrc pour démarrer votre session. Vous devrez donc en adapter le contenu en y ajoutant:

Code : Tout sélectionner

exec $1
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » jeu. 08 mai 2014, 10:05

Re,
J'ai bien installé xorg comme indiqué ici : http://wiki.archlinux.fr/Xorg

Code : Tout sélectionner

pacman -Syu xorg-server xorg-xinit xorg-server-utils
pacman -S xf86-video-votrepilote
J'ai bien installé slim comme indiqué ici : http://wiki.archlinux.fr/Slim

Code : Tout sélectionner

pacman -S slim
systemctl enable slim
systemctl start slim
J'ai bien installé dwm comme indiqué ici : http://wiki.archlinux.fr/DWM

Code : Tout sélectionner

pacman -S git
git clone http://git.suckless.org/dwm
make 
make install
Et voici le contenu de mon fichier .xinitrc qui se trouve dans ~/ :

Code : Tout sélectionner

exec $1
exec dwm
Mais lorsque je redémarre l'ordinateur je retombe de nouveau sur mon tty :o

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [dwm] Téléchargement, installation et configration(en co

Message par FoolEcho » jeu. 08 mai 2014, 10:35

AchilleFraisse a écrit :et ils disent te taper la commande suivante : pacman -S xf86-video-votrepilote . Or, ma carte graphique c'est nvidia. Mais il me dit que le packet xf86-video-nvidia n'existe pas !
Nvidia :copain:
AchilleFraisse a écrit :J'ai bien installé dwm comme indiqué ici : http://wiki.archlinux.fr/DWM

Code : Tout sélectionner

pacman -S git
git clone http://git.suckless.org/dwm
make
make install
Il est nettement préférable d'utiliser le paquet fourni vu que tu ne fais apparemment pas de modifications.
Et même si tu faisais des modifications, un PKGBUILD est préférable.
AchilleFraisse a écrit :Et voici le contenu de mon fichier .xinitrc qui se trouve dans ~/ :

Code : Tout sélectionner

exec $1
exec dwm
Le second exec n'a aucun sens.
«The following statement is not true. The previous statement is true.» :nage:

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » jeu. 08 mai 2014, 10:41

C'est bon, pour le lancement de slim ça marche, c'était une erreur dans mon fichier 10-keyboard-terminate.conf .
Mais la deuxième ligne je dois la mettre pour qu'il me lance dwm ne fois que je me suis logué non ?
Il faut que je mette quoi sinon ?
Avec le fichier .xinitrc comme dit plus haut, j'arrive sur la page de slim. Puis une fois logué, il y a une barre qui s'affiche sur le haut avec les chiffres de 1 à 9 à gauche et a droite il y a écrit dwm-6.1. Mais le fond d'écran reste le même. Pourtant je croyais que dwm ne prenait pas en charge es fond d'écran par défaut. Il faudrait donc que mon fond d'écran soit unis non. De plus, j'ai un curseur de souris qui s'affiche, mais quand je bouge la souris, il ne se passe rien :o

AchilleFraisse
Elfe
Messages : 579
Inscription : dim. 27 avr. 2014, 09:32

Re: [dwm] Téléchargement, installation et configration(en co

Message par AchilleFraisse » jeu. 08 mai 2014, 10:47

Par contre, lorsque j'ai tapé cette commande :

Code : Tout sélectionner

systemctl enable -f graphical.target
, le même message d'erreur que j'ai évoqué" hier est apparu. Je l'ai donc laisser tomber et ça marche quand même. Elle sert à quoi exactement alors ?

benjarobin
Maître du Kyudo
Messages : 15922
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [dwm] Téléchargement, installation et configration(en co

Message par benjarobin » jeu. 08 mai 2014, 11:36

Cette commande est invalide et ne sert à rien, c'est une erreur de t'avoir indiqué cette commande.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre