[openbox] Lancement impossible(résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
Powlow
Hankyu
Messages : 31
Inscription : lun. 04 août 2014, 16:25

[openbox] Lancement impossible(résolu)

Message par Powlow » sam. 20 déc. 2014, 13:36

Bonjour à tous,

J'ai récemment refait l'install de ma distro, et j'ai décidé de passer à Openbox. J'ai donc installé xorg & cie puis les paquets openbox, obconf, obmenu et lxappearance.
Le soucis c'est qu'il ne veut tout simplement pas démarrer ; j'ai ce message au lancement de la commande openbox-session :

Code : Tout sélectionner

Openbox-Message: Échec de l'ouverture de l'affichage depuis la variable d'environnement DISPLAY.
Bon, soit, du coup j'ai essayé de me tourner vers xfce4, histoire de voir si ça fonctionnerai ou pas ; je l'ai installé, toussa. Marche nikel, et aucun message d'erreur au lancement... wtf ?

Aurais-je loupé une étape de config avec openbox ? Sur aucun des sites/wiki que j'ai pu aller visiter concernant l'installation d'openbox ils ne parlent de configurer une variable DISPLAY ou whatever...

Quelqu'un ici qui aurait une idée d'où le soucis pourrait venir ? :-/
Dernière modification par Powlow le dim. 21 déc. 2014, 16:01, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15476
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [openbox] Lancement impossible

Message par benjarobin » sam. 20 déc. 2014, 14:16

Comment lances tu Openbox ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
alh54
archer de cavalerie
Messages : 182
Inscription : lun. 02 déc. 2013, 21:52

Re: [openbox] Lancement impossible

Message par alh54 » sam. 20 déc. 2014, 16:36

T u as 2 solutions:
Solution 1
Démarre en mode texte, après le login tu exécutes un startx
Dans ce cas, il faut créer un ~/.xinitrc

Code : Tout sélectionner

$ sudo cp /etc/skel/.xinitrc ~/
Tu édites ton .xinitrc et rajoutes:

Code : Tout sélectionner

exec openbox-session
Solution 2
Utiliser un gestionnaire de session, personnellement j'utilise SDDM que je trouve très bien, et l'activer au démarrage, par exemple:

Code : Tout sélectionner

# systemctl enable sddm.service

Avatar de l’utilisateur
Powlow
Hankyu
Messages : 31
Inscription : lun. 04 août 2014, 16:25

Re: [openbox] Lancement impossible

Message par Powlow » sam. 20 déc. 2014, 17:17

J'utilise openbox-session pour le démarrer (enfin essayer de le démarrer...). Je pense que que l'on lance cette commande d'un .xinitrc ou directement depuis le terminal l'effet est le même ?
En tout cas j'ai essayé les deux et ça marche pas dans les deux cas...
Et quant à utiliser un gestionnaire de connexion, oui, peut-etre, mais j'aimerai bien que ça fonctionne sans, déjà :wink:

benjarobin
Maître du Kyudo
Messages : 15476
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [openbox] Lancement impossible

Message par benjarobin » sam. 20 déc. 2014, 17:22

Quel est le contenu de .xinitrc ?
Quelle est la sortie de startx ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

coolgeek
archer
Messages : 100
Inscription : jeu. 24 juin 2010, 09:44

Re: [openbox] Lancement impossible

Message par coolgeek » sam. 20 déc. 2014, 17:46

startx est un script, il initialise diverse chose avant d'executer le contenu du .xinitrc. Je ne pense donc pas que executer "openbox-session" depuis le terminal ou depuis startx soit equivalent.

Avatar de l’utilisateur
Powlow
Hankyu
Messages : 31
Inscription : lun. 04 août 2014, 16:25

Re: [openbox] Lancement impossible

Message par Powlow » dim. 21 déc. 2014, 16:00

Ok, bon je viens de réessayer et ça fonctionne ... Ne me demandez pas comment...
Bon, je vais essayer de configurer Openbox du coup. Merci quand même. J'avoue que je me sens un peu con là.

Répondre