[XFCE] tearing nvidia (contourné)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Répondre
Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

[XFCE] tearing nvidia (contourné)

Message par Kristen » ven. 24 août 2018, 09:54

Bonjour
J'ai un problème de tearing avec le pilote nvidia et XFCE.
J'ai démarré nvidia-settings en root et cocher Force Full Composition Pipeline
Image

Je valide et je n'ai plus de tearing. Je sauvegarde le fichier 20-nvidia.conf https://pastebin.com/S9NUV87W dans mon home pour servir de modèle pour en créer un en suivant cette discussion
Dedans, j'ai mis

Code : Tout sélectionner

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    #Option "TripleBuffer" "true"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-D-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, VGA-0: nvidia-auto-select +1$
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
et bien évidemment, ça ne fonctionne pas, je me retrouve avec un écran noir au redémarrage du PC.
Qu'est-ce que j'ai loupé ?
Merci

PS : Toutes les MAJ sont faites.
Dernière modification par Kristen le dim. 26 août 2018, 06:46, modifié 1 fois.
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

benjarobin
Maître du Kyudo
Messages : 15424
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [XFCE] tearing nvidia

Message par benjarobin » ven. 24 août 2018, 17:11

Si ton fichier 20-nvidia.conf contient vraiment ceci alors tu as comme un souci, il manque la fin de la ligne de metamodes...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [XFCE] tearing nvidia

Message par Kristen » ven. 24 août 2018, 20:33

Oupss, la ligne a été coupé au collage

Code : Tout sélectionner

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    #Option "TripleBuffer" "true"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 750 Ti"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DVI-D-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, VGA-0: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

benjarobin
Maître du Kyudo
Messages : 15424
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [XFCE] tearing nvidia

Message par benjarobin » ven. 24 août 2018, 22:46

Hum... Il faudrait voir le log de Xorg
Personnellement j'ai une ligne "plus simple"

Code : Tout sélectionner

Section "Device"
    Identifier "Card0"
    Driver "nvidia"
    Option "TripleBuffer" "true"
EndSection

Section "Screen"
    Identifier     "metaScreen"
    Device         "Card0"
    DefaultDepth    24
    Option "metamodes" "DFP-0: nvidia-auto-select @1920x1080 +0+0 { ForceFullCompositionPipeline = On }, DFP-3: nvidia-auto-select @1680x1050 +1920+0 { ForceFullCompositionPipeline = On }"    
EndSection
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [XFCE] tearing nvidia

Message par Kristen » sam. 25 août 2018, 09:22

Alors le Xorg.0.log OK donc sans 20-nvidia.conf
https://pastebin.com/tDvAyqX5

et le Xorg.0.log avec 20-nvidia.conf
https://pastebin.com/8i6Vq1wL

J'ai essayé de modifier plusieurs choses dans la ligne Option "metamodes" mais ne sachant pas à quoi ça correspond, rien n'a fonctionné.
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

benjarobin
Maître du Kyudo
Messages : 15424
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [XFCE] tearing nvidia

Message par benjarobin » sam. 25 août 2018, 11:18

Essaye cette ligne pour l'option metamodes (la configuration générée par Nvidia était fausse...):

Code : Tout sélectionner

Option "metamodes" "DFP-0: nvidia-auto-select @1920x1080 +0+0 { ForceFullCompositionPipeline = On }, CRT-0: nvidia-auto-select @1280x1024 +1920+0 { ForceFullCompositionPipeline = On }"
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [XFCE] tearing nvidia

Message par Kristen » sam. 25 août 2018, 12:35

C'est fait. Au lancement, je me retrouve avec un écran noir et un petit carré en haut à gauche comme avant. J'ouvre une console TTY et sans être connecter ni en root ni en utilisateur, je repasse dans ma session et ça marche !!!???
Je redémarre pour contrôler et rebelote, j'ai un écran noir. Je laisse pour voir si ça va changer, au bout de trente secondes environ, toujours rien.

Par contre, ça a l'air de fonctionner pour le tearing.
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [XFCE] tearing nvidia (contourné)

Message par Kristen » dim. 26 août 2018, 06:48

J'ai lâchement contourné le problème en retournant avec KDE. Et de ce fait pour supprimer le tearing, le fichier fait par nvidia-setting fonctionne bien. Alors pourquoi avec XFCE ça ne fonctionne pas ???
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

AnEuzvil
newbie
Messages : 4
Inscription : jeu. 05 sept. 2013, 12:37

Re: [XFCE] tearing nvidia (contourné)

Message par AnEuzvil » dim. 26 août 2018, 09:47

Bonjour,
Le compositeur d'Xfce n'est pas toujours très "accueillant" à l'égard de certaines cartes graphiques. Une solution de contournement existe cependant : Désactiver le compositeur natif et le remplacer par community/compton 0.1_beta2.5-11
X compositor that may fix tearing issues
:wink:

Avatar de l’utilisateur
Kristen
Elfe
Messages : 614
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [XFCE] tearing nvidia (contourné)

Message par Kristen » dim. 26 août 2018, 12:25

Merci je note si des fois il me prend envie de revenir avec XFCE. Je trouve quand même un peu lourd comme méthode de changer de compositeur pour ne plus avoir de tearing !
Depuis le 14 octobre 2011 sur archlinux
actuellement avec XFCE sur
PC fixe : i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i

Répondre