[sway/qt] scale qui foire quand je plug/unplug un écran

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
Avatar de l’utilisateur
rotsix
newbie
Messages : 7
Inscription : lun. 05 nov. 2018, 21:02

[sway/qt] scale qui foire quand je plug/unplug un écran

Message par rotsix »

Bonjour à tous

J'utilise sway sur mon laptop (1080p), et des applications Qt (notamment qutebrowser).
Quand je branche/débranche mon 2e écran (1440p), le scaling des fenêtres Qt chie. elles deviennent trop grandes.
Par contre, quand rallume sway avec l'écran branché, tout est bien avec les bonnes échelles.

Sauriez-vous comment je peux forcer le recalcul de la taille des fenêtres ? Le problème est lié à sway ? à Qt ?
Merci d'avance!
viperpaulo
Chu Ko Nu
Messages : 379
Inscription : lun. 06 déc. 2010, 13:58

Re: [sway/qt] scale qui foire quand je plug/unplug un écran

Message par viperpaulo »

Hello,

Quelle est ta config pour les sorties ?
Peut-être qu'un truc du genre pourrait marcher :

Code : Tout sélectionner

output * scale 1
output HDMI-1 scale 1.5
Avatar de l’utilisateur
rotsix
newbie
Messages : 7
Inscription : lun. 05 nov. 2018, 21:02

Re: [sway/qt] scale qui foire quand je plug/unplug un écran

Message par rotsix »

Salut,
J'ai regardé du côté de Sway, et avec/sans mon second écran j'obtiens les même résultats avec un scaling toujours égal à 1.
Je pense que le problème vient plutôt de Qt qui galère entre les deux résolutions.

On peut ici ( http://sprunge.us/IFjov6 ) très bien voir le problème avec la police dans les onglets.

Merci de ton aide
Répondre