[KDE 4.1] Problème root xauth/dbus ? [RESOLU]

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

[KDE 4.1] Problème root xauth/dbus ? [RESOLU]

Message par webjdm » ven. 01 août 2008, 01:53

Salut,
Je viens d'installer une KDE 4.1 toute fraiche, histoire de tester la bête.
Apres quelques configurations, je suis confronté à ce problème:
Lorque je suis en root, j'essai de lancer kwrite /chemin/quejeveux/ (ou un autre programme), j'ai de suite un :

Code : Tout sélectionner

kwrite: cannot connect to X server :0.0  etc
Apres quelques recherches, je modifie /etc/pam.d/su en:

Code : Tout sélectionner

session         optional        pam_xauth.so
Je relance kwrite et j'obtiens un:

Code : Tout sélectionner

kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(8196) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
Alors là, je ne sais pas quoi faire, je me contenterais bien de nano, mais c'est pas le top! Une idée sera la bienvenue... merci! :)
Dernière modification par webjdm le sam. 02 août 2008, 22:52, modifié 2 fois.

maxi_jac
Daikyu
Messages : 94
Inscription : dim. 15 juin 2008, 17:43

Message par maxi_jac » ven. 01 août 2008, 02:16

Bon je pose quand même la question xD : DBus lancé ?


++ B.

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 11:01

Hal est en DAEMONS dans le rc.conf, donc je suppose qu'il lance D-Bus au chargement. Je penses qu'il n'y a pas de problème.
EDIT: J'arrive a lancer sans problème kwrite en utilisateur... au cas où si il y aurait une question. :?

EDIT: DAEMONS pas MODULES :oops:
Dernière modification par webjdm le ven. 01 août 2008, 11:50, modifié 1 fois.

Avatar de l’utilisateur
AddiKT1ve
Elfe
Messages : 543
Inscription : sam. 10 mai 2008, 22:46
Localisation : Lève les yeux...
Contact :

Message par AddiKT1ve » ven. 01 août 2008, 11:39

hal doit être dans la liste des daemons, pas des modules...
Devenez colocataire de Rootards.
##hippie irc.freenode.net

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 11:49

AddiKT1ve a écrit :hal doit être dans la liste des daemons, pas des modules...
Désolé de ce que j'ai écrit, je l'ai bien mis en DAEMONS pas en MODULES!!
:oops: C'est donc pas ça le problème...

maxi_jac
Daikyu
Messages : 94
Inscription : dim. 15 juin 2008, 17:43

Message par maxi_jac » ven. 01 août 2008, 12:03

Ca te coute rien de le mettre explicitement dans ta liste de daemons.


++ B.

Avatar de l’utilisateur
AddiKT1ve
Elfe
Messages : 543
Inscription : sam. 10 mai 2008, 22:46
Localisation : Lève les yeux...
Contact :

Message par AddiKT1ve » ven. 01 août 2008, 12:09

maxi_jac a écrit :Ca te coute rien de le mettre explicitement dans ta liste de daemons.


++ B.
?
Devenez colocataire de Rootards.
##hippie irc.freenode.net

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » ven. 01 août 2008, 13:43

tu dois démarrer ton X avec startx, c'est ca ? (en tout cas, pas de kdm/gdm)

si c'est le cas, c'est juste qu'il te manque un variable, rajoute ca:

Code : Tout sélectionner

export XAUTHORITY="$HOME/.Xauthority"
dans ton ~/.bashrc (ou le fichier de démarrage de ton shell)

PS: sinon, le souci de dbus n'en est pas un, c'est juste que le root n'a pas de session X de lancée

maxi_jac
Daikyu
Messages : 94
Inscription : dim. 15 juin 2008, 17:43

Message par maxi_jac » ven. 01 août 2008, 15:45

Je voulais dire de mettre dbus dans la liste des daemons, hal le lance automatiquement sinon ?


++ B.

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 16:15

Salut,
J'ai rajouter la ligne export dans mon ~/.bashrc mais rien n'y fait. Pour résumé simplement:
J'ai kdm lancé automatiquement grace a inittab. Ma session s'ouvre apres que j'ai entré mon mot de passe. Mais je n'arrive a rien lancé en root, mise à part nano (comme editeur texte) . J'ai hal wicd et cups dans les DAEMONS en plus. J'ai pas trop de souci aparant, bien que je n'arrive pas a dézipper une simple archive, ni a archiver...

mon .xsession-errors:

http://pastebin.com/m606f36b5

Pour d-bus:

Code : Tout sélectionner

bash-3.2# dbus-launch
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-xviOSaOaOD,guid=0fc908850d80b930038c32f448931b46
DBUS_SESSION_BUS_PID=4779
DBUS_SESSION_BUS_WINDOWID=35651585

bash-3.2# kwrite /etc/X11/xorg.conf
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(4822) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
:?:

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » ven. 01 août 2008, 16:24

webjdm a écrit :Salut,
J'ai rajouter la ligne export dans mon ~/.bashrc mais rien n'y fait. Pour résumé simplement:
une fois rajouté, il faut la prendre en compte:

Code : Tout sélectionner

source ~/.bashrc
et seulement après connecte toi en root avec su, et pour vérifier si c'est bien pris en compte:

Code : Tout sélectionner

echo $XAUTHORITY
webjdm a écrit :bien que je n'arrive pas a dézipper une simple archive, ni a archiver...
ca n'as pas de rapport avec X ca...

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 16:53

ca n'as pas de rapport avec X ca...
En effet, c'est un autre problème que je recontre, aussi...

Sinon:

Code : Tout sélectionner

bash-3.2# echo $XAUTHORITY
/root/.xauthLIBhR5

bash-3.2# kwrite /etc/X11/xorg.conf
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(3207) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
Cela ne change pas plus, le problem est ailleurs :(

EDIT: en essayant startx, ça m'a ouvert trois fenetres (de X) mais pas KDE.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » ven. 01 août 2008, 17:32

et une autre application X, ca fonctionne?
shaman par exemple, il demande pas d'environnement kde...

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » ven. 01 août 2008, 18:07

Et avec kdesu ?
http://fr.wikipedia.org/wiki/Kdesu

Et puis si tu n'aimes pas nano, il y a vim qui est bien mieux ;-)

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 19:03

tuxce a écrit :et une autre application X, ca fonctionne?
shaman par exemple, il demande pas d'environnement kde...
Oui shaman se lance en root. :)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » ven. 01 août 2008, 19:52

webjdm a écrit :
tuxce a écrit :et une autre application X, ca fonctionne?
shaman par exemple, il demande pas d'environnement kde...
Oui shaman se lance en root. :)
essais:

Code : Tout sélectionner

rm -rf /var/tmp/kdecache-root
et relance kwrite
et pour dbus:

Code : Tout sélectionner

ps -ef | grep dbus

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 20:14

Voila :wink: :arrow:

Code : Tout sélectionner

bash-3.2# rm -rf /var/tmp/kdecache-root

bash-3.2# kwrite /etc/X11/xorg.conf
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
klauncher(3349) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!

bash-3.2# ps -ef | grep dbus
dbus      2532     1  0 20:06 ?        00:00:00 /usr/bin/dbus-daemon --system
root      2758     1  0 20:06 ?        00:00:00 dbus-launch --autolaunch eedb5ef297e3524afcd2fa5248922d25 --binary-syntax --close-stderr
root      2759     1  0 20:06 ?        00:00:00 /usr/bin/dbus-daemon --fork --print-pid 5--print-address 7 --session
joel      2840     1  0 20:06 ?        00:00:00 dbus-launch --sh-syntax --exit-with-session
joel      2841     1  0 20:06 ?        00:00:00 /usr/bin/dbus-daemon --fork --print-pid 5--print-address 7 --session
root      3374  3366  0 20:09 pts/2    00:00:00 grep dbus
Skunnyk a écrit :Et avec kdesu ?
http://fr.wikipedia.org/wiki/Kdesu

Et puis si tu n'aimes pas nano, il y a vim qui est bien mieux ;-)
kdesu ne fonctionne pas :(

Par contre j'ai réussis a ouvrir kwrite en root, en faisant ça:

Code : Tout sélectionner

bash-3.2# dbus-launch kwrite                
kdeinit4: preparing to launch /usr/lib/kde4/libexec/klauncher
kdeinit4: preparing to launch /usr/bin/kded4                 
kdeinit4: preparing to launch /usr/bin/kbuildsycoca4         
kbuildsycoca4 running...                                     
kbuildsycoca4(4320)/kdecore (KService) KServicePrivate::init: The desktop entry file  "kmplayer.desktop"  has Type= "Application"  but is located under " "services" " instead of "apps"                                                                                      

kbuildsycoca4(4320)/kdecore (KService) KBuildServiceFactory::createEntry: Invalid Service :  "kmplayer.desktop"                                                                     
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/kommander.desktop" is not compliant with XDG standard (missing trailing semicolon).             
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/krita_raw.desktop" is not compliant with XDG standard (missing trailing semicolon).             
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/krita_png.desktop" is not compliant with XDG standard (missing trailing semicolon).             
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/krita_openexr.desktop" is not compliant with XDG standard (missing trailing semicolon).         
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/krita_jpeg.desktop" is not compliant with XDG standard (missing trailing semicolon).            
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in ".hidden/krita_tiff.desktop" is not compliant with XDG standard (missing trailing semicolon).            
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kspread.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                 
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/krita.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                   
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kword.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                   
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/karbon.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                  
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kplato.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                  
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kpresenter.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                              
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kformula.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kivio.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                   
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kchart.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                                  
kbuildsycoca4(4320)/kdecore (KService) KServicePrivate::init: The desktop entry file  "/opt/kde/share/applications/kde/koffice.desktop"  has Type= "Application"  but no Exec line  

kbuildsycoca4(4320)/kdecore (KService) KBuildServiceFactory::createEntry: Invalid Service :  "/opt/kde/share/applications/kde/koffice.desktop"                                      
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kudesigner.desktop" is not compliant with XDG standard (missing trailing semicolon).                                                                              
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kexi.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(4320) KConfigGroup::readXdgListEntry: List entry MimeType in "/opt/kde/share/applications/kde/kugar.desktop" is not compliant with XDG standard (missing trailing semicolon).
kbuildsycoca4(4320)/kdecore (KService) KBuildServiceFactory::collectInheritedServices: parent mimetype not found: "text/xml"
kbuildsycoca4(4320)/kdecore (KService) KBuildServiceFactory::collectInheritedServices: parent mimetype not found: "text/xml"
kdeinit4: preparing to launch /usr/lib/kde4/libexec/kconf_update
kded(4318): Communication problem with  "kded" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." "

kded(4319): "Impossible d'atteindre KLauncher via D-Bus, erreur lors de l'appel de kdeinit_exec_wait :
empty
"

QDBusConnection received a message of type 3 that it shouldn't have
error: "org.freedesktop.DBus.Error.ServiceUnknown" "The name :1.3 was not provided by any.service files"
"KConfigIni: In file /tmp/kde-root/kconf_updateEj4333.tmp, line 1: " Invalid entry (missing '=')
QDBusConnection received a message of type 2 that it shouldn't have
QThreadStorage: Thread 0xbc8e80 exited after QThreadStorage 2147483645 destroyed
Ca charge pendant quelques secondes, mais ça l'ouvre :o

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » ven. 01 août 2008, 20:30

On va dire que c'est résolu, il suffit que je lance la premiere fois avec dbus-launch programme et ça roule 8)
Merci pour l'aide!

Avatar de l’utilisateur
Calimero
Elfe
Messages : 692
Inscription : ven. 02 mai 2008, 18:16
Localisation : Nantes (44)

Message par Calimero » sam. 02 août 2008, 22:06

Moi j'faisais "sudo programme" en utilisateur... :lol:

Car sous Arch (et sous Arch uniquement), jamais je n'ai pu lancer d'appli graphique en root. Logique en même temps, puisque root n'a pas de session graphique de lancée...

Code : Tout sélectionner

[root@webgine ~]# kwrite
No protocol specified
kwrite: cannot connect to X server :0.0
Mais alors, pourquoi sous Knoppix par exemple, en root je tape kwrite ça le lance ?? Mystère.
Mes trucs : LiveCD http://ctkarch.org/ ; Blog, guide Arch, etc… http://calimeroteknik.free.fr/
In a world without walls and fences, who needs windows and gates ?

webjdm
Hankyu
Messages : 43
Inscription : sam. 17 mai 2008, 17:43

Message par webjdm » sam. 02 août 2008, 22:55

Calimero a écrit :Moi j'faisais "sudo programme" en utilisateur... :lol:

Car sous Arch (et sous Arch uniquement), jamais je n'ai pu lancer d'appli graphique en root. Logique en même temps, puisque root n'a pas de session graphique de lancée...

Code : Tout sélectionner

[root@webgine ~]# kwrite
No protocol specified
kwrite: cannot connect to X server :0.0
Mais alors, pourquoi sous Knoppix par exemple, en root je tape kwrite ça le lance ?? Mystère.
Comme je l'ai dit sur mon premier post, si tu modifies la dernière ligne de /etc/pam.d/su en:

Code : Tout sélectionner

session         optional        pam_xauth.so
peut-être que tu pourras lancer kwrite en root.

Répondre