[e17] police toute petite et impossible à modifier (résolu)

Xorg, Compiz, KDE / Gnome / Xfce / Fluxbox / e17 / fvwm ... GDM/KDM/XDM...
bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

[e17] police toute petite et impossible à modifier (résolu)

Message par bgse » mar. 23 déc. 2008, 17:40

j'ai installé hier un arch tout propre, avec e17.

petit soucis (entre autres, mais chaque chose en son temps) : les polices (bureau, titre des fenêtres, «panneau de config») sont toute petites (pas de screen, je n'ai pas su en prendre encore). tellement petites que c'est totalement illisible et donc pas utilisable (pas du tout).

en rebootant sur un vieux kubuntu sur lequel j'avais installé également e17, j'ai pu mémoriser l'emplacement du paramétrage des polices, et j'ai mémorisé les boutons sur lesquels appuyer également.

j'ai donc rebooté sur mon arch, et je me suis dirigé vers la bonne option. c'était les mêmes îcones etc… j'étais au bon endroit. j'ai cliqué sur le bouton « very big », puis « apply ». je n'ai observé aucun changement…
sur une autre partie de ce même écran, on peut choisir la police : en changeant la police (au hazard, puisque je ne pouvais pas lire le nom des polices) puis « apply », on voit que la police change (même si la police est sur 2 pixels d'épaisseur, je vois qu'elle change).

j'ai parcouru les wikis et les forums, et j'ai l'impression que je suis le seul à avoir ce problème.
par contre d'autres ont eu d'autres problèmes, et visiblement une recompilation de e17 est privilégiée à chaque fois.

dois-je me diriger vers cette voie ?
est-ce simple à faire avec les outils disponible dans arch ?

Merci !!

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mar. 23 déc. 2008, 19:57

Bonjour,

Les réponses à ces questions sont contenues dans les trois pages suivantes:
http://wiki.archlinux.fr/e17:install

http://wiki.archlinux.org/index.php/E17

http://wiki.archlinux.fr/arch:makepkg

En très résumé, pour compiler tout en faisant un paquet, et installer à la suite, il te faut les outils de compilation, il te faut makepkg, fakeroot, et si j'en oublie tu trouveras ça dans les docs ci-dessus. (Ou plus généralement dans les wiki archlinux.fr et archlinux.org aux rubriques makepkg et pkgbuild en particulier)

Et oui, une fois que tout est en place, les compilations sont faciles*. (Il y a la méthode avec la commande makepkg, ou il y a yaourt qui peut souvent le faire).

* sauf quand elles loupent, bien entendu. :D

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » mar. 23 déc. 2008, 20:29

merci.

les 2 liens sur e17 je les avais déjà lus.
pour la compilation, je ne compte pas refaire le PKGBUILD, car il existe peut-être déjà j'imagine.
je vais chercher la bonne commande pour installer tout en recompilant avant.

sinon il faudra que je change de wm. mon but est de quitter gnome.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mar. 23 déc. 2008, 21:50

Re,
bgse a écrit :merci.

les 2 liens sur e17 je les avais déjà lus.
Alors relis-les. ;)
pour la compilation, je ne compte pas refaire le PKGBUILD, car il existe peut-être déjà j'imagine.
je vais chercher la bonne commande pour installer tout en recompilant avant.
le wiki anglais pour e17 a écrit :If you need an e17 package which is not (yet) available in the [community] repo, see if it is available in the AUR.
Quand tu tappes 'yaourt -G e17-svn' dans un répertoire créé pour l'occasion, yaourt télécharge le pkgbuild et tout fichier qui l'accompagne. Une fois fait tu lances la commande 'makepkg' dans ce répertoire. Cela télécharge les sources les détare et les compile avant d'en faire un paquet. Il te faut voir où ça va se mettre, car tu peux faire en sorte que le paquet aille dans le répertoire de ton choix. Après, tu peux l'installer avec la commande 'pacman -A lepaquet.tar.gz' (yaourt et makepkg quand à eux, en simple utilisateur, si yaourt a besoin du mot de passe il te le signale au moment).
sinon il faudra que je change de wm. mon but est de quitter gnome.
Ce ne sont pas les gestionnaires de fenêtres qui manquent. Si tu n'y arrives pas avec e17, tu apprécieras la facilité offerte par lxde.

http://lxde.org/

As-tu yaourt installé ?

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » mar. 23 déc. 2008, 22:05

mélodie a écrit :Re,

Alors relis-les. ;)
oui, je les déjà relu. il n'y a aucune information qui m'étaient utiles.
mélodie a écrit :
le wiki anglais pour e17 a écrit :If you need an e17 package which is not (yet) available in the [community] repo, see if it is available in the AUR.
Quand tu tappes 'yaourt -G e17-svn' dans un répertoire créé pour l'occasion, yaourt télécharge le pkgbuild et tout fichier qui l'accompagne. Une fois fait tu lances la commande 'makepkg' dans ce répertoire. Cela télécharge les sources les détare et les compile avant d'en faire un paquet. Il te faut voir où ça va se mettre, car tu peux faire en sorte que le paquet aille dans le répertoire de ton choix. Après, tu peux l'installer avec la commande 'pacman -A lepaquet.tar.gz' (yaourt et makepkg quand à eux, en simple utilisateur, si yaourt a besoin du mot de passe il te le signale au moment).
je vais faire ça (déjà fait quand j'avais créé un PKGBUILD) ou bien lancer yaourt -Sb
mélodie a écrit :As-tu yaourt installé ?
oui

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » mar. 23 déc. 2008, 23:17

j'essaye de compiler le groupe e17-svn.
voici mon cheminement :

1) j'ai l'impression que yaourt ne peut pas installer les groupes, et donc je passe par pacman (ou yaourt -Sg e17-svn) pour trouver le contenu du groupe

2) pacman n'est pas capable de compiler alors je décide de compiler à la main dans yaourt chacun des éléments du groupe

3) si je lance yaourt sans sudo alors je suis coincé car certains droits sont requis mais yaourt ne me demande pas le mot de passe.

4) donc je lance sudo yaourt -Sb , et j'ai des erreurs à la compilation (aclocal command not found et pas de fichier makefile)

si quelqu'un a des éléments de réponse, en attendant je continue de chercher.

merci !

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mer. 24 déc. 2008, 03:08

Si j'invoque 'yaourt e17' j'obtiens ceci: une longue liste d'extensions et gadgets pour e17. Si je me réfère à la doc, si il manque un paquet, allez sur AUR. Et sur AUR tu trouves pareil que avec yaourt.

http://aur.archlinux.org/packages.php?O ... o_Orphans=

http://aur.archlinux.org/packages.php?O ... o_Orphans=

Pas de e17, même pas un e17-svn.

Désolée. :(

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » mer. 24 déc. 2008, 12:59

bgse a écrit :1) j'ai l'impression que yaourt ne peut pas installer les groupes, et donc je passe par pacman (ou yaourt -Sg e17-svn) pour trouver le contenu du groupe
Exact, yaourt ne semble pas savoir installer un groupe alors que pacman sait, voir bug : http://bugs.archlinux.fr/task/127
2) pacman n'est pas capable de compiler alors je décide de compiler à la main dans yaourt chacun des éléments du groupe
Ce n’est pas le but de pacman que de builder des paquets, cette tâche revient à makepkg (qui est utilisé par yaourt).
3) si je lance yaourt sans sudo alors je suis coincé car certains droits sont requis mais yaourt ne me demande pas le mot de passe.
Merci de lire le wiki sur yaourt, on y parle de sudo et yaourt…
4) donc je lance sudo yaourt -Sb , et j'ai des erreurs à la compilation (aclocal command not found et pas de fichier makefile)
Il faut un minimum d’outils de base pour faire de la compilation, commencer par installer le groupe base-devel (avec pacman).
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » mer. 24 déc. 2008, 13:14

Ah oui, et euh pourquoi tu veux refaire les paquets e17-svn ?
Si tu ne fais que les rebuilder ça ne changera rien au résultat, si tu veux les toutes dernières versions de chaque paquet qui compose e17-svn, il faudra modifier les PKGBUILDs…
Parce que e17-svn est un ensemble de paquets community qui sont déjà prébuildés et qui proviennent directement de AUR (mais sont marqués en tant que paquets sains).

Je ne dis pas ça pour te décourager, c’est plus pour tu comprennes ce que tu t’apprêtes à faire.
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » mer. 24 déc. 2008, 13:20

mélodie a écrit :Si je me réfère à la doc, si il manque un paquet, allez sur AUR. Et sur AUR tu trouves pareil que avec yaourt.
De ce que j’ai compris c’est si il manque un paquet non vital pour avoir quelque chose de fonctionnel…
Pas de e17, même pas un e17-svn.

Désolée. :(
Normal, d’une part parce que e17 n’est pas encore sorti ;) et de plus e17-svn n’est pas un paquet mais un groupe de paquets (sorte de méta-paquet, comme le groupe xorg).
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » mer. 24 déc. 2008, 13:23

gyo a écrit :Ce n’est pas le but de pacman que de builder des paquets, cette tâche revient à makepkg (qui est utilisé par yaourt).
pas de problème, je mentionnais ça pour vous donner la façon dont je réfléchis.
gyo a écrit :Merci de lire le wiki sur yaourt, on y parle de sudo et yaourt…
ok, donc, quand on dit d'utiliser yaourt en tant qu'utilisateur, ça n'exclut pas d'utiliser sudo.
gyo a écrit :Il faut un minimum d’outils de base pour faire de la compilation, commencer par installer le groupe base-devel (avec pacman).
ok, je m'en doutais un peu.


hier soir j'ai donc testé plusieurs wm :
- openbox et fluxbox : problème du style « failed to open the display because of the display environment variable ». après moultes recherches, ça parle de drivers, de problèmes de locales… mais après plusieurs essais (modification driver, manipulation des locales) j'avais toujours le même message (au démarrage de gdm ou autre).

- fvwm : je n'ai pas pu me logger. j'avais beau rentrer login/passwd dans le DM, je revenais toujours au même écran.

- xfce : ça marche. j'ai pu me logger et « tout marche bien navette » pour l'instant.


je retente la compilation de e17 dans 2 jours.

et joyeux noël à tous !

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » mar. 30 déc. 2008, 10:58

salut, alors j'ai essayé d'avancer sur le sujet :

- j'ai installé base-devel et j'ai tenté la compilation de e17-svn et e17-extra-svn.
certains composants compilaient sans problème et s'installaient sans problème, mais d'autres me donnaient des erreurs à la compilation. ça n'était pas des erreurs dues à des outils manquants. par contre j'avais des erreurs toujours du style : telle fonction dans tel fichier source fait appel à telle autre fonction qui se trouve théoriquement dans tel autre fichier source sauf qu'il ne le trouve pas.
alors ce sont des erreurs dans le code source ? étonnant, d'autant que les binaires disponibles ont été compilés à partir des mêmes sources…
donc ces composants là, je les ai installé avec les binaires et pas avec les sources (je n'ai pas voulu commencer à entrer dans le code source…).
ensuite j'ai essayé de démarré e17, avec le même soucis que j'avais décrit dans mon premier message, donc je laisse tomber.

- je me suis rabattu sur fluxbox, qui contrairement à la première fois, a bien démarré (peut-être dû à la façon de démarrer fluxbox ?), et maintenant je vais essayer d'y rester.


je pense qu'on peut passer le topic en [abandon], à moins que quelqu'un ait une autre suggestion ?

jul01
newbie
Messages : 1
Inscription : jeu. 21 sept. 2006, 12:46

Message par jul01 » jeu. 15 janv. 2009, 13:20

Est-ce que tu as essayé la commande enlightenment_remote?

J'avais un problème de police qui était aussi illisible lors de ma première utilisation de e17 et j'ai réussi à modifier la font avec la commande
enlightenment_remote -font-default-set default Vera-Bold 12
puis faire un enlightenment_remote -font-apply

Tu peux trouver plus d'info à cette page http://www0.get-e.org/E17_User_Guide/En ... 6.1.2.html

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » ven. 16 janv. 2009, 18:48

merci beaucoup.

je note et je vais tester.

Avatar de l’utilisateur
Nashmun
newbie
Messages : 9
Inscription : mer. 11 févr. 2009, 18:23
Localisation : gard

Message par Nashmun » mar. 17 févr. 2009, 22:09

Bonsoir ^^

Je me permet de remonter ce topic, puisque j'ai exactement le même problème, et que le dernier post ne datte que d'un mois. Si jamais je dois créer un nouveau sujet, je le referais ;)

Alors, j'ai tenté de modifier la police avec enlightenment_remote, mais j'obtiens le message d'erreur suivant :

Code : Tout sélectionner

The E_IPC_SOCKET environment variable is not set. This is 
> exported by Enlightenment to all processes it launches. 
> This environment variable must be set and must point to 
> Enlightenment's IPC socket file (minus port number). 
> ERROR: Enlightenment_remote cannot set up the IPC socket.
J'ai cherché et je suis tombé sur un sujet où ils disaient qu' un rm -rf .e/
rm -rf /tmp/enlightenment-* refaisait marcher tout ça, et apparement chez celui qui l'a fait ça a marché.

Malheureusement, pas pour moi :(

Si quelqu'un a une suggestion, je suis prenneur car E est totalement inutilisable avec une police à 1px ^^"

Avatar de l’utilisateur
indiana tux
Hankyu
Messages : 32
Inscription : sam. 07 févr. 2009, 09:05

Message par indiana tux » mer. 18 févr. 2009, 10:35

J'avais le même problème impossible à résoudre, ça m'avait tellement énervé que je m'était installé xfce pour pouvoir me servir de mon pc, et puis en rebootant sur e17, miracle, toutes les polices étaient redevenues normales. J'ai viré xfce en gardant les fichiers de configuration et maintenant tout roule.

C'est vraiment dommage que Bgse ne dise pas si ça lui a résolu le problème

La solution de toute façon m'interesse, si j'ai le temps je m'en occuperai...

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » sam. 21 févr. 2009, 00:27

indiana tux a écrit : C'est vraiment dommage que Bgse ne dise pas si ça lui a résolu le problème
non, ne pouvant rien lire sur e17 et ne résolvant pas, j'ai testé d'autres wm.
et je suis tombé amoureux de awesome… :oops:

Avatar de l’utilisateur
Az
Hankyu
Messages : 42
Inscription : ven. 25 juil. 2008, 23:55

Message par Az » sam. 21 févr. 2009, 12:40

Bonjour !!

Je viens d'avoir exactement le même problème !!

Et effectivement les commandes données ci-dessus ne fonctionnent pas !

Bref j'ai réussi à résoudre ça :D

1) Le problème vient du thème par défaut, on va donc en télécharger un autre simply-white par exemple:

Code : Tout sélectionner

wget http://exchange.enlightenment.org/theme/get/304
2) On le place dans le bon dossier

Code : Tout sélectionner

mv simply-white-0.9.2.edj ~/.e/e/themes
3) Et la il faut un peu connaitre E17 pour ouvrir le menu permettant de changer de thème. Donc dans le menu il faut choisir l'avant dernier menu puis encore une fois l'avant dernier. A ce moment la fenêtre de sélection des thèmes s'ouvre. On prend le radiobox de gauche et on sélectionne le thème simply-white et on appuye sur Apply (bouton du milieu).

Et voila normalement tout marche après cela !

Az

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » sam. 21 févr. 2009, 16:34

merci.

en fait, j'avais tenté ce genre de manip mais pas pour changer de thème, pour changer la police.

j'ai installé e17 sur ma vielle partoche ubuntu, j'ai repéré où changer la taille de la police. ensuite reboot sur arch, je reproduis, mais sans succès.

comme tu le dis, il faut connaître un minimum e17 pour savoir où triffouiller.

bref, très bien ta manip, je vais essayer peut-être ce soir, et si ça marche on pourra fermer ce topic.

bgse
archer de cavalerie
Messages : 183
Inscription : ven. 12 sept. 2008, 22:09

Message par bgse » dim. 22 févr. 2009, 12:36

bon, j'y suis là, avant de réinstaller e17 j'ai wget le theme et je l'ai posé là où il faut.

maintenant j'ai rebooté sur e17, j'y suis logué, mais la navigation est difficile, je ne trouve pas le menu de configuration.

y a t il un raccourcis pour l'ouvrir ?
ou bien clique-droit sur le bureau ou autre…

Répondre